You are not logged in.

#1 2017-09-14 16:24:10

zulqurnain
Member
Registered: 2016-11-15
Posts: 16

[SOLVED] AUR Zoneminder Cmake Compiling issues - Sept.2017 [SOLVED]

HELP PLEASE!!
hello, a few weeks ago i had zone minder installed on my arch, then moved to a new rig and didnt install zoneminder (because it recomends LAMP stack, and thats time consuming). Now that i have more than one camera set up in a property i manage i decided it was time to get into heavy zoneminding. Unfortunately the package was updated and now i can not install zone minder. I have emailed the maintainer, no reply, and well i guess not many  humans are into zoneminder and arch at the same time....
As of the 1.12 or something updates, zoneminder is complied with cmake. I love arch and learning and PKGBUILD is great but this is not the case entirely for zoneminder now. . I dont really have much IT educational background (just years of tinkering and being bold) and out of love for this i read and read. However cmake is a bit beyond my scope for learning at the moment (two baby girls, demanding wife, work, etc ), was hoping somebody could point to me in the right direction or provide the right links to read so that I can hopefully fix  or at least help the maintainer with more relevant info (if he/she resurfaces) and eventually update the aur with something that works.

I have read a few things about cmake and as i read more i get it more, but there isnt any info i found that is similar and what they did to fix it (or i didnt get it)

There is a downside to install arch manually and not via yoaurt but right now need the zoneminder for work and any other alternative so far does not convince me.

The error arises when it is buliding CXX object that pertains to two specific files comms.cpp and comms.h
7%] Building CXX object src/CMakeFiles/zm.dir/zm_comms.cpp.o
-----
In file included from /tmp/yaourt-tmp-USER/aur-zoneminder/src/ZoneMinder-1.30.4/src/zm_comms.cpp:20:0:

>>>
/tmp/yaourt-tmp-USER/aur-zoneminder/src/ZoneMinder-1.30.4/src/zm_comms.cpp: In member function ‘virtual int CommsBase::readV(int, ...)’:
/tmp/yaourt-tmp-USER/aur-zoneminder/src/ZoneMinder-1.30.4/src/zm_comms.cpp:59:18: error: ‘::readv’ has not been declared
   int nBytes = ::readv( mRd, iov, iovcnt );
                  ^~~~~
/tmp/yaourt-tmp-USER/aur-zoneminder/src/ZoneMinder-1.30.4/src/zm_comms.cpp:59:18: note: suggested alternative: ‘read’
   int nBytes = ::readv( mRd, iov, iovcnt );
                  ^~~~~
                  read

<<<<
The error suggest to modify 'readv' and 'writev' to just 'read' and 'write'

i know where the file is and can modify it to fit the suggestion, but is that really it? or is the error underlying something else?

since typing this post i tried something else that come to mind, i have managed to set up the project directory correctly so that PKGBUILD exists and I can makepkg -s from project directory however in doing it populates the folder with files that give me the same error as doing it from yaourt (the files i modified are overwritten),

SOooOooo, which cmake file and command do i edit so that it can target a specif folder instead of it automatically populating the folder and overwriting the files i edited?

think im getting somewhere....


--------------------------------------------
Thanks for Posting back on this one >>> MESMER << zoneminder's maintainer was not MIA. he patched it up.
Been using it now since that update and everything works fine.

Last edited by zulqurnain (2017-09-30 12:15:59)

Offline

#2 2017-09-17 08:41:37

mis
Member
Registered: 2016-03-16
Posts: 230

Re: [SOLVED] AUR Zoneminder Cmake Compiling issues - Sept.2017 [SOLVED]

There was a patch added (see AUR comments). Have you tried building it since the patch was added?

Offline

#3 2017-09-17 10:45:17

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,407
Website

Re: [SOLVED] AUR Zoneminder Cmake Compiling issues - Sept.2017 [SOLVED]

Moving to AUR issues.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB