You are not logged in.

#1 2017-09-16 16:54:49

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Corebird - Error when adding account: "TLS-certificate not acceptable"

Hello!

I've installed the Twitter client Corebird. When adding an account I get an error message "TLS-certificate not acceptable".

Any hints how to solve this issue would be much appreciated.

I've already reinstalled ca-certificates, but to no avail...

Offline

#2 2017-09-16 19:27:40

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 23,331
Website

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2017-09-17 04:57:56

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,181
Website

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Does it log somewhere or have a debug option? Without detailed logs, we can't do much.

Offline

#4 2017-09-17 06:38:54

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Thank you.

The debugging message that relates to the problem is:

(corebird:1446): corebird-CRITICAL **: AccountCreateWidget.vala:59: TLS-Certificate not acceptable

And for the sake of completeness here the full debugging output:

$  G_MESSAGES_DEBUG=all corebird --gst-debug-level=3
(corebird:1446): Gtk-DEBUG: Connecting to session manager
(corebird:1446): Gtk-DEBUG: Failed to get the GNOME session proxy: The name org.gnome.SessionManager is not owned
(corebird:1446): Gtk-DEBUG: Failed to get the Xfce session proxy: The name org.xfce.SessionManager is not owned
(corebird:1446): Gtk-DEBUG: Failed to get an inhibit portal proxy: The name org.freedesktop.portal.Desktop is not owned
(corebird:1446): corebird-DEBUG: Corebird.vala:207: startup

(corebird:1446): Gtk-WARNING **: Theme parsing error: style.css:20:13: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(corebird:1446): Gtk-WARNING **: Theme parsing error: style.css:230:16: The 'outline-radius' property has been renamed to '-gtk-outline-radius'

(corebird:1446): Gtk-WARNING **: Theme parsing error: style.css:236:19: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(corebird:1446): Gtk-WARNING **: Theme parsing error: style.css:237:25: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(corebird:1446): Gtk-WARNING **: Theme parsing error: style.css:242:36: The :insensitive pseudo-class is deprecated. Use :disabled instead.
(corebird:1446): corebird-DEBUG: MainWindow.vala:482: Could not load geometry, account == null
(corebird:1446): corebird-DEBUG: Creating stream for screen_name

(corebird:1446): corebird-CRITICAL **: AccountCreateWidget.vala:59: TLS-Certificate not acceptable

Offline

#5 2017-09-18 03:32:42

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,181
Website

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Are you able to access Twitter from the browser?

Offline

#6 2017-09-18 04:55:46

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Yes, I'm able to access Twitter from the browser.

Offline

#7 2017-09-18 09:50:33

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,181
Website

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Hmm.. I don't have my Arch machine handy right now, but can you check which ssl library it is using. That should help narrow things down.

Offline

#8 2017-09-21 16:10:45

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

Good question...

 find /usr/lib -name *ssl* 

gives me:

/usr/lib/libxmlsec1-openssl.so.1
/usr/lib/libevent_openssl-2.1.so.6
/usr/lib/libssl3.so
/usr/lib/libssl.so
/usr/lib/libssl.so.1.1
/usr/lib/kde4/kcm_ssl.so
/usr/lib/kde4/kded_kssld.so
/usr/lib/libevent_openssl.so
/usr/lib/libxmlsec1-openssl.so
/usr/lib/libevent_openssl-2.1.so.6.0.2
/usr/lib/openssl-1.0
/usr/lib/openssl-1.0/libssl.so
/usr/lib/openssl-1.0/pkgconfig/libssl.pc
/usr/lib/openssl-1.0/pkgconfig/openssl.pc
/usr/lib/libxmlsec1-openssl.so.1.2.24
/usr/lib/libssl.so.1.0.0

Offline

#9 2017-09-21 16:15:38

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

And querying installed packages gives:

pacman -Qs ssl
local/openssl 1.1.0.f-2
    The Open Source toolkit for Secure Sockets Layer and Transport Layer Security
local/openssl-1.0 1.0.2.l-1
    The Open Source toolkit for Secure Sockets Layer and Transport Layer Security

Offline

#10 2017-09-21 16:23:18

cirkit
Member
From: San Francisco
Registered: 2008-01-29
Posts: 64
Website

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

The `find` command you posted just gives you the openssl libraries that are on the filesystem when you search for them in /usr/lib. Can you run ldd on corebird to see what it is using. In a different but similar thread the unacceptable TLS certificate message was resolved by reinstalling a certificates package. You may be running into something similar.

Last edited by cirkit (2017-09-21 16:24:41)

Offline

#11 2017-09-23 16:39:22

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

According to the thread you have provided the link for I had already reinstalled the package. This did not help.

Thanks for pointing to ldd. Using it gives me a the list of the libraries, but I cannot identify a hint on an ssl library. Here is the full output:

        linux-vdso.so.1 (0x00007ffc09d7a000)
        libsoup-2.4.so.1 => /usr/lib/libsoup-2.4.so.1 (0x00007f4eb333a000)
        libjson-glib-1.0.so.0 => /usr/lib/libjson-glib-1.0.so.0 (0x00007f4eb3113000)
        libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00007f4eb2e01000)
        libgstreamer-1.0.so.0 => /usr/lib/libgstreamer-1.0.so.0 (0x00007f4eb2ac8000)
        libgspell-1.so.1 => /usr/lib/libgspell-1.so.1 (0x00007f4eb28a5000)
        libgtk-3.so.0 => /usr/lib/libgtk-3.so.0 (0x00007f4eb1f8d000)
        libgdk-3.so.0 => /usr/lib/libgdk-3.so.0 (0x00007f4eb1c98000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00007f4eb1a49000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00007f4eb1823000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00007f4eb1505000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00007f4eb12e1000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007f4eb0f46000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007f4eb0cf3000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f4eb09e0000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007f4eb0629000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00007f4eb02c1000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f4eb0073000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007f4eafd27000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f4eafb23000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f4eaf905000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007f4eaf701000)
        libunwind.so.8 => /usr/lib/libunwind.so.8 (0x00007f4eaf4e7000)
        libdw.so.1 => /usr/lib/libdw.so.1 (0x00007f4eaf29f000)
        librt.so.1 => /usr/lib/librt.so.1 (0x00007f4eaf097000)
        libenchant.so.1 => /usr/lib/libenchant.so.1 (0x00007f4eaee8c000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00007f4eaec7f000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f4eae940000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f4eae72f000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f4eae529000)
        libcairo-gobject.so.2 => /usr/lib/libcairo-gobject.so.2 (0x00007f4eae320000)
        libatk-bridge-2.0.so.0 => /usr/lib/libatk-bridge-2.0.so.0 (0x00007f4eae0f1000)
        libepoxy.so.0 => /usr/lib/libepoxy.so.0 (0x00007f4eade0b000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00007f4eadbf5000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f4ead9b0000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00007f4ead7ad000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00007f4ead5a2000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f4ead397000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00007f4ead194000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f4eacf91000)
        libxkbcommon.so.0 => /usr/lib/libxkbcommon.so.0 (0x00007f4eacd51000)
        libwayland-cursor.so.0 => /usr/lib/libwayland-cursor.so.0 (0x00007f4eacb49000)
        libwayland-egl.so.1 => /usr/lib/libwayland-egl.so.1 (0x00007f4eac947000)
        libwayland-client.so.0 => /usr/lib/libwayland-client.so.0 (0x00007f4eac738000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f4eac526000)
        libthai.so.0 => /usr/lib/libthai.so.0 (0x00007f4eac31c000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f4eac074000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f4eabdad000)
        libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f4eabb76000)
        libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0x00007f4eab972000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f4eab749000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x00007f4eab53b000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f4eab330000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00007f4eab119000)
        libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f4eaaf02000)
        libmount.so.1 => /usr/lib/libmount.so.1 (0x00007f4eaacae000)
        libffi.so.6 => /usr/lib/libffi.so.6 (0x00007f4eaaaa5000)
        libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f4eaa832000)
        /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f4eb393e000)
        libicuuc.so.59 => /usr/lib/libicuuc.so.59 (0x00007f4eaa482000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007f4eaa25c000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f4ea9f74000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f4ea9d40000)
        libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f4ea9b3c000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f4ea992f000)
        libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007f4ea972b000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f4ea9514000)
        libelf.so.1 => /usr/lib/libelf.so.1 (0x00007f4ea92fc000)
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f4ea90ec000)
        libatspi.so.0 => /usr/lib/libatspi.so.0 (0x00007f4ea8ebb000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f4ea8c6c000)
        libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f4ea89d3000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f4ea87a1000)
        libdatrie.so.1 => /usr/lib/libdatrie.so.1 (0x00007f4ea8599000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f4ea8395000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f4ea818f000)
        libblkid.so.1 => /usr/lib/libblkid.so.1 (0x00007f4ea7f44000)
        libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f4ea7d3f000)
        libicudata.so.59 => /usr/lib/libicudata.so.59 (0x00007f4ea622c000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f4ea5ea5000)
        libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007f4ea5c1e000)
        libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f4ea59f2000)
        libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007f4ea56d6000)
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007f4ea54c1000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f4ea52ac000)

Offline

#12 2017-09-25 12:32:12

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 5,566

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f4ea9f74000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f4ea9d40000)
        libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f4ea9b3c000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f4ea992f000)

Looks like this package uses kerberos to authenticate.

output of pacman -Qs krb ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#13 2017-10-01 11:05:23

uliri
Member
From: Berlin, Germany
Registered: 2017-09-13
Posts: 7

Re: Corebird - Error when adding account: "TLS-certificate not acceptable"

The output of pacman -Qs krb is

local/krb5 1.15.1-1
    The Kerberos network authentication system

Offline

Board footer

Powered by FluxBB