You are not logged in.

#1 2017-08-04 19:30:32

kay94
Member
Registered: 2017-08-04
Posts: 3

TurboBoost / Thinkpad T430

Hi!

I'm working on a Lenovo Thinkpad T430 and have some issues with the Turbo Boost feature of the Intel i5 3320M in it. As good as the intention with it might be: In combination with the laptop cooling system beeing to weak, I would rather go without it. Usually I don't have problems with overheating, since I'm doing a

# echo 2200000 | tee /sys/devices/system/cpu/cpu[0-3]/cpufreq/scaling_max_freq

on every system start with a service. In most cases, this is just good enough to have reasonable temperatures, but however sometimes the turbo boost kicks in. If this is, while there actually are some heavy tasks like a compilation running (thus resulting in 100% on all threads), I easily get 95C (especially when I don't notice the turbo boost). This is extremely annoying for me, as it clearly reduces my hardwares' lifetime which I'd like to use as long as possible. I've tried different things, but wasen't able to get rid of the turbo boost - except for always clocking the CPU on 1.2GHz (nominal is 2.6GHz), since this is the only option Lenovo offers in the BIOS (pretty poor!).

Right now, i7z reports the frequency to be 3.0GHz (found a way to reproducably provoke turbo boost), even though I did a

# echo 1 | tee /sys/devices/system/cpu/intel_pstate/no_turbo

i7z says:

TURBO ENABLED on 2 Cores, Hyper Threading ON
# cat /sys/devices/system/cpu/intel_pstate/status
active

One guy, seems to have the same problem as me, without a real solution either:
https://www.reddit.com/r/thinkpad/comme … rbo_boost/

I also tried thermald, but was not able to get a configuration, that would make any impact (didn't find many explanations or examples on the web). Even though that would probably be even better than just getting rid of turbo boost. The best imaginable would be for me, to just name a target temperature that is never considerably exceeded, no matter what ambient temperatur or system load.

Please note I won't accept the default thermal bounderies of somewhat around a 100C bevor throttle really kicks in (someone wants to sell more hardware?) and also regularly renew termal paste, clean the fan and give it some new lubricant if neccessary.

Does somebody have an idea, what I could do or an example of a working thermal-conf.xml? This is my configuration, btw:

<?xml version="1.0"?>

<!--
use "man thermal-conf.xml" for details
-->

<!-- BEGIN -->
<ThermalConfiguration>
<Platform>
	<Name>MyLaptop</Name>
	<ProductName>T430</ProductName>
	<Preference>QUIET</Preference>
	<ThermalSensors>
		<ThermalSensor>
			<Type>pkg-temp-0</Type>
			<Path>/sys/class/thermal/thermal_zone0/</Path>
			<AsyncCapable>1</AsyncCapable>
		</ThermalSensor>
		<ThermalSensor>
			<Type>pkg-temp-1</Type>
			<Path>/sys/class/thermal/thermal_zone1/</Path>
			<AsyncCapable>1</AsyncCapable>
		</ThermalSensor>
	</ThermalSensors>
	<ThermalZones>
		<ThermalZone>
			<Type>cpu_package</Type>
			<TripPoints>
				<TripPoint>
					<SensorType>pkg-temp-0</SensorType>
					<Temperature>45000</Temperature>
					<type>passive</type>
					<ControlType>PARALLEL</ControlType>
					<CoolingDevice>
						<index>1</index>
						<type>intel_pstate</type>
						<influence> 100 </influence>
						<SamplingPeriod> 10 </SamplingPeriod>
					</CoolingDevice>
					<CoolingDevice>
						<index>2</index>
						<type>rapl_controller</type>
						<influence> 100 </influence>
						<SamplingPeriod> 16 </SamplingPeriod>
					</CoolingDevice>
					<CoolingDevice>
						<index>3</index>
						<type>intel_powerclamp</type>
						<influence> 100 </influence>
						<SamplingPeriod> 12 </SamplingPeriod>
					</CoolingDevice>
				</TripPoint>
			</TripPoints>
		</ThermalZone>
	</ThermalZones>
</Platform>
</ThermalConfiguration>

Thanks in advance for any effort!

Offline

#2 2017-08-07 14:11:31

kay94
Member
Registered: 2017-08-04
Posts: 3

Re: TurboBoost / Thinkpad T430

Are there any other command or file logs I could provide?

Offline

#3 2017-09-24 06:05:12

edge320
Member
Registered: 2017-09-24
Posts: 1

Re: TurboBoost / Thinkpad T430

I have the same issue and manage to stop turbo boost using his info here
https://askubuntu.com/questions/619875/ … 114#620114
and temps are normal now , when on load the cpu goes until 2.60ghz.
Instal cpu frequency scaling indicator also to see that it actually works well

Offline

#4 2017-09-24 14:00:48

stupidus
Member
Registered: 2012-02-27
Posts: 118

Re: TurboBoost / Thinkpad T430

I have a T420, so the CPU is one generation older, but I also struggled with disabling TurboBoost. I cannot remember all the things that I have tried. But I think, what worked in the end was to use tlp and setting CPU_BOOST_ON_AC=0 in its configuration file. However, even without TurboBoost, I still have some issues with overheating, especially on Javascript heavy websites, but it did get a bit better.

Offline

#5 2017-09-28 18:18:55

kay94
Member
Registered: 2017-08-04
Posts: 3

Re: TurboBoost / Thinkpad T430

Thank you both for your efforts! I found someone to look at the problem more deeply. The bug report is here:

https://bugzilla.kernel.org/show_bug.cgi?id=196757

Normally, when echo'ing "1" into /sys/devices/system/intel_pstate/no_turbo, CPU frequency indeed does not go beyond 2.6GHz. But it does, when considerably high enough graphic load is present.
A small script to reliably (at least for me) get rid of turbo is here:

https://github.com/kayb94/no_turbo

Regards
Kay

Last edited by kay94 (2017-09-28 18:21:45)

Offline

Board footer

Powered by FluxBB