You are not logged in.

#26 2017-10-07 01:49:04

Registered: 2014-03-31
Posts: 18

Re: [SOLVED] System crash after upgrade

I have created a live USB and booted.

I mount my root and boot partitions

I chroot to the root partition

I then ran

/bin/pacman -S intel-ucode

and it replied:

error: GPGME error: Invalid crypto engine
error: database 'archzfs' is not valid (invalid or corrupted database (PGP signature))

So I exited chroot and ran

pacman -S intel-ucode -root /mnt/arch/sda2

this worked

Then I rebooted and the microcode error persisted

So I rebooted and exited the boot menu and again added


to the command as before.


:: running early hook [udev]
Warning: /lib/modules/4.13.3-1-ARCH/modules.devname not found - ignoring
starting version 234
:: running hook [udev]
:: triggering uevents... 
Waiting for 10seconds for device /dev/sda2... 
ERROR: device '/dev/sda2' not found. Skipping fsck
:: mounting '/dev/sda2' on real root
mount: /new_root: no filesystem type specified. 
You are now being dropped into an emergency shell. 
sh: can't access tty; job control turned off

No microcode complaint - hurrah

But it still fails - hurroo

The issue now moves on.

Is this a case of performing a full upgrade  via redirecting the root?

Will it need any special or particular mounts to be made? (last time I tried to mount /proc, it complained it was not in fstab)

As always, any help appreciated.


#27 2017-10-08 10:31:15

Registered: 2014-03-31
Posts: 18

Re: [SOLVED] System crash after upgrade

I have fixed my issue by

booting a live USB
mounting my existing system - I chose to use a mount point "mainArch" - note this is on the live USB filesystem which is transient, so you need to repeat the mkdir as well as mounts each attempt

My root partition was sda2, my boot sda1. Boot is typically significantly smaller than root!

mkdir -p /mnt/mainArch/boot
mount /dev/sda2 /mnt/mainArch
mount /dev/sda1 /mnt/mainArch/boot

Before proceeding further do

ls /mnt/mainArch

to confirm you have the mount points right

I then arch-chroot'ed into it, using the shell I am familiar with

arch-chroot /mnt/mainArch /bin/bash

Next, I performed a full system update

pacman -Syu

This still gave me the hang at the zfs dkms, so I waited. And waited. And waited.

Then it finally gave up on hanging, complaining about spi, which is understandable given that spi had not been re-installed by dkms yet...

That hang was an "apple os install" hang...

So I noted down the dkms command that stalled and let the rest of the dkms steps run, including spi.

I then ran the zfs dkms install command I had noted down by hand, which worked.

I then rebooted...and it booted, but still with the microcode issue.

To make it certain, I re-ran the intel-ucode update, in case my previous chroot'd update did not stick.

My system uses systemd-boot, so, I followed the systemd-boot instructions in Arch wiki microcode

For me, my file was called arch.conf, and I added the appropriate line for the intel-code.

Now I boot OK without the microcode complaint.

For me, this is fixed.

Thanks to those who responded to others so that I could make my way to the solution.

I hope all others rapidly achieve their fix.


#28 2017-10-08 13:09:27

Registered: 2014-03-31
Posts: 18

Re: [SOLVED] System crash after upgrade

As a side note, I began to see the following at boot:

DMAR: DRHD: handling fault status reg 2
DMAR: [DMA Write] Request device [00:02.0] fault addr 4bd0992000 [fault reason 05] PTE write access is not set

After a bit of digging, this seems related to intel_iommu defaults changing.



to my options parameter in systemd-boot conf file.


For reference, I have a Gigabyte Z97X-UD7 TH motherboard, with a i7 4790K, which has integrated graphics (even though I do not use them). Stock settings for both CPU and Memory.



#29 2017-10-08 21:49:02

Registered: 2017-10-08
Posts: 1

Re: [SOLVED] System crash after upgrade

I'm on a MacBookAir6,1 (2013) and I ran into the same issue as described in the original post - thanks *so much* for posting everything, Fixed.

Here is what I had to get my machine back up and running:

  • Install intel-ucode (pacman -S intel-ucode)

  • Update refind_linux.conf (i use Refind):
    "Boot using defaut options"     "root=/dev/sda5 rw initrd=/intel-ucode.img initrd=/initramfs-linux.img intel_iommu=off"

    • Notice that I had to add both initrd=/intel-ucode.img *and* initrd=/initramfs-linux.img as per the wiki

    • Notice that I also had to add intel_iommu=off. acpi=off also worked, but the former should disable less functionality so is preferable.

Last edited by DanOConnor (2017-10-08 21:51:28)


#30 2017-10-12 08:02:26

Registered: 2005-08-09
Posts: 208

Re: [SOLVED] System crash after upgrade

After today's update pacman -Syu to kernel  4.13.5-1 there is no need to add


to the linux  Grub line anymore.

XFCE4 under Arch on Honor MagicBook


Board footer

Powered by FluxBB