You are not logged in.

#1 2017-09-22 02:11:00

ronjouch
Member
From: Montreal, QC
Registered: 2014-09-18
Posts: 20
Website

testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Reading r/Kernel linux-4.13.1-1-x86_64 breaks X11 for Lenovo Thinkpad T450s prompted me to test it on my T560.

I'm not affected by the X11 breakage, but with this new testing kernel I'm unable to resume from suspend. I.e. suspend works, but pressing on POWER / Enter / whatever key (which under 4.12 resumes the system) doesn't resume; I have to force shutdown with a long press on POWER, and restart.

I don't see any relevant active bug on the linux package, but before I post one, does that ring a bell to anyone? I'm a complete newbie regarding that kind of breakage, where should I look for debug info?

Note: this was a partial upgrade, I activated the testing repo and only upgraded the linux and linux-headers packages. Could it be problematic?

Thanks for the help.

Note: discussion moved from this reddit thread after discovering this official testing forum.

Last edited by ronjouch (2017-09-22 02:13:14)

Offline

#2 2017-09-22 06:43:47

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 145

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Partial Upgrades are Unsupported to read before to understand why... so is the first thing to do ... and only after that is possible to help you to find the problem and solution ;-)


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#3 2017-09-22 07:19:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 2,894

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

The kernel is one of the few things that you should be able to partial update without issue. One new option enabled in the 4.13 kernel by default is iommu, have you tried the mentioned kernel parameter to turn that off again?

Offline

#4 2017-09-22 15:33:30

ronjouch
Member
From: Montreal, QC
Registered: 2014-09-18
Posts: 20
Website

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

V1del wrote:

The kernel is one of the few things that you should be able to partial update without issue. One new option enabled in the 4.13 kernel by default is iommu, have you tried the mentioned kernel parameter to turn that off again?

Thanks for the sensible feedback. And nicely caught, after setting my grub to boot with intel_mmu=off , my system resumes properly. Reporting the bug. Thanks again!

EDIT filed FS#55705 - [linux] intel_mmu from 4.13.3-1 causes my Thinkpad T560 to fail to resume from suspend

Last edited by ronjouch (2017-09-22 15:39:13)

Offline

#5 2017-09-22 15:48:10

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,181

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Why would reporting a kernel bug to Arch accomplish anything?

Offline

#6 2017-09-22 16:04:41

ronjouch
Member
From: Montreal, QC
Registered: 2014-09-18
Posts: 20
Website

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Why would a contributor with >6000 posts respond to a novice user only trying to help himself and the community by answering him with a rhetorical question?

Now,

1. I'm doing what I can within the range of my current knowledge. I'm testing a kernel, it's broken, I get help, it enables me to start isolating the problem, I try to get more help. Maybe I'm not asking the right shop, as I'm stumbling across a village I don't know much about but I don't mean to be rude; please point me to the correct door and guide me to arrive equipped with the right pieces of information.

And to this you will RTFM me to a probable Arch guide to reporting kernel bugs. However, my *point* of reporting to Arch first is precisely to get human help before going higher:

2. I *think* something is wrong with my kernel, but have been wrong with early diagnosis in the past, may be wrong this time, and will be wrong in the future. Getting confirmation about my diagnosis from the people experts in assembling the system I'm using *before* talking upstream doesn't seem insane, to me it looks like good hygiene.

Scimmia, help welcome.

Last edited by ronjouch (2017-09-22 16:34:55)

Offline

#7 2017-09-22 17:33:20

loqs
Member
Registered: 2014-03-06
Posts: 2,809

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

@Scimmia as it appears to have been triggered by the config change CONFIG_INTEL_IOMMU_DEFAULT_ON=y from # CONFIG_INTEL_IOMMU_DEFAULT_ON is not set is that not a packaging issue as well as an upstream bug?
How else could a user request hetfig consider reverting that change similar to hetfig reverting CONFIG_SCSI_MQ_DEFAULT=y if not filling an issue on the bug tracker?
Edit:
This also assumes upstream agrees it is an upstream bug.
Edit2:
corrected CONFIG_SCSI_MQ_DEFAULT=y from CONFIG_DM_MQ_DEFAULT=y
Edit3:
@ronjouch now that the bug is assigned in the bug tracker I would expect it to just remain there without any response see other issues filed against the linux package for precedent.

Last edited by loqs (2017-09-22 17:40:01)

Offline

#8 2017-09-23 03:23:58

ronjouch
Member
From: Montreal, QC
Registered: 2014-09-18
Posts: 20
Website

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

loqs wrote:

@Scimmia as it appears to have been triggered by the config change CONFIG_INTEL_IOMMU_DEFAULT_ON=y from # CONFIG_INTEL_IOMMU_DEFAULT_ON is not set is that not a packaging issue as well as an upstream bug?
How else could a user request hetfig consider reverting that change similar to hetfig reverting CONFIG_SCSI_MQ_DEFAULT=y if not filling an issue on the bug tracker?
Edit:
This also assumes upstream agrees it is an upstream bug.
Edit2:
corrected CONFIG_SCSI_MQ_DEFAULT=y from CONFIG_DM_MQ_DEFAULT=y
Edit3:
@ronjouch now that the bug is assigned in the bug tracker I would expect it to just remain there without any response see other issues filed against the linux package for precedent.

@loqs okay, thanks for the prompt answer. But putting aside the debate of whether or not iommu should be on or off * by default*, the fact that turning it on breaks resume should reasonably be considered a bug by upstream, shouldn't it? Do you know if upstream is aware of *that* issue (any existing bug)?

  a. If yes, great.
  b. If no, can you give me some advice about debug info to attach to a bug report?

Offline

#9 2017-09-23 09:09:20

loqs
Member
Registered: 2014-03-06
Posts: 2,809

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

ronjouch wrote:

Do you know if upstream is aware of *that* issue (any existing bug)?

  a. If yes, great.
  b. If no, can you give me some advice about debug info to attach to a bug report?

I do not know if upstream is aware.  reporting-bugs is the official guide from upstream on how to report kernel bugs.

Offline

#10 2017-09-23 15:26:44

ronjouch
Member
From: Montreal, QC
Registered: 2014-09-18
Posts: 20
Website

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

loqs wrote:

I do not know if upstream is aware.  reporting-bugs is the official guide from upstream on how to report kernel bugs.

Great, filed Kernel Bug 197029 - intel_iommu=on under 4.13 breaks resume from suspend on my Thinkpad T560. Thanks for the guidance, updating the Arch FS bug and will follow-up there with feedback from the upstream bug.

Offline

#11 2017-09-24 19:11:08

Uriel_Bernhard48
Member
Registered: 2017-08-08
Posts: 20

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

I think this could be related https://bugs.freedesktop.org/show_bug.cgi?id=89360

For a workaround add "intel_iommu=igfx_off" to command line (it keeps iommu on except for graphics which is better than disabling it completely.

You can also try patching kernel as in https://bugs.freedesktop.org/show_bug.cgi?id=89360#c58

Offline

#12 2017-09-25 02:56:33

ronjouch
Member
From: Montreal, QC
Registered: 2014-09-18
Posts: 20
Website

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Uriel_Bernhard48 wrote:

I think this could be related https://bugs.freedesktop.org/show_bug.cgi?id=89360

For a workaround add "intel_iommu=igfx_off" to command line (it keeps iommu on except for graphics which is better than disabling it completely.

Thanks, but no, even "intel_iommu=igfx_off" breaks resume. Adding this piece of info to my bug.

Offline

#13 2017-09-30 18:04:59

yuvadm
Member
From: Tel Aviv-Jaffa, Israel
Registered: 2012-08-08
Posts: 88
Website

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

ronjouch wrote:

Thanks, but no, even "intel_iommu=igfx_off" breaks resume. Adding this piece of info to my bug.

Try `intel_iommu=off` instead?

Offline

#14 2017-09-30 18:43:00

loqs
Member
Registered: 2014-03-06
Posts: 2,809

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

yuvadm wrote:

Try `intel_iommu=off` instead?

post #4

ronjouch wrote:

after setting my grub to boot with intel_mmu=off , my system resumes properly.

Offline

#15 2017-10-01 06:03:46

oconnor663
Member
Registered: 2012-12-16
Posts: 46

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

I think post #4 has a typo? It says "intel_mmu=off", but the setting that works is "intel_iommu=off".

Offline

#16 2017-10-02 11:42:22

vtyulb
Member
Registered: 2013-08-18
Posts: 10

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Kernel 4.13.1 breaks resume on ThinkPad P50 as well. Setting "intel_mmu=off" kernel parameter fixed it, thanks a lot.

Offline

#17 2017-10-05 17:41:27

reading
Member
Registered: 2017-10-05
Posts: 3

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

I had the same problem on an X260, and "intel_iommu=off" fixed it, thanks.

"intel_mmu=off" is indeed a typo

*Edit*

It seems like a fair amount of Thinkpad users are affected by this bug, so to be ultra-clear: as I understand it the temporary fix is to pass the parameter "intel_iommu=off" to your kernel.

Details about how to do that in the wiki: https://wiki.archlinux.org/index.php/kernel_parameters

For GRUB users, that means editing the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line in /etc/default/grub, and then running grub-mkconfig

Last edited by reading (2017-10-05 17:47:37)

Offline

#18 2017-10-08 20:21:49

Kotrfa
Member
Registered: 2012-10-25
Posts: 155

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Hey, yes, I suffer from the same issue on my t460s linux v 4.13.4-1. Adding the parameter "intel_iommu=off" fixed that.

Using systemd-boot, I had to add it into options:

$ cat /boot/loader/entries/arch.conf 
title Arch Linux
linux /vmlinuz-linux
initrd /initramfs-linux.img
initrd /intel-ucode.img
options root=PARTUUID=8d411a1d-fd6b-4916-b21f-f745a70a39d3 rw intel_iommu=off

Last edited by Kotrfa (2017-10-08 20:22:24)

Offline

#19 2017-10-09 01:30:09

lifeafter2am
Member
From: 127.0.0.1
Registered: 2009-06-10
Posts: 1,331

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

Same issue here on both my x240 and my X1 Carbon. Adding "intel_iommu=off" fixed my issue as well.


#binarii @ irc.binarii.net
Matrix Server: https://matrix.binarii.net
-------------
Allan -> ArchBang is not supported because it is stupid.

Offline

#20 2017-10-09 16:54:21

loqs
Member
Registered: 2014-03-06
Posts: 2,809

Re: testing/linux-4.13.3-1-x86_64 breaks resume on my Thinkpad T560

It should not be necessary to add intel_iommu=off for the testing package linux-4.13.5-1
Edit:
added missing =

Last edited by loqs (2017-10-09 16:54:51)

Offline

Board footer

Powered by FluxBB