You are not logged in.

#1 2017-10-10 12:57:08

unixman
Member
Registered: 2015-03-12
Posts: 48

webkit2gtk-2.18.0 introduced gst-plugins-bad as new dependency

Hi. I am not like the situation that webkit2gtk-2.18.0 introduced  gst-plugins-bad  as new mandatory dependency.

gst-plugins-bad  pulls other 60 package  as  dependency and so on:)

Is it possible to revert that decision?

Or package and distribute  webkit2gtk as 2 different package.

One of them is normal build, other is bare build as all compile-time features(so deps.) disabled other than javascript.

Thoughs?

I use my own written webkit2gtk  based web browser to surf on net.

It is only 50 lines of code.

webkit2gtk is too big to compile it my own as it takes hours to built.

Last edited by unixman (2017-10-10 13:09:23)

Offline

#2 2017-10-11 20:25:12

Eschwartz
Bug Wrangler
Registered: 2014-08-08
Posts: 1,176

Re: webkit2gtk-2.18.0 introduced gst-plugins-bad as new dependency

It is already a 117.5 MB package, and you're bothered by another 30 MB in dependencies?

Well, Arch Linux does not split packages like that... you could probably offload your own compilation to e.g. the OpenSUSE Build Server though.

Offline

#3 2017-10-12 08:06:21

unixman
Member
Registered: 2015-03-12
Posts: 48

Re: webkit2gtk-2.18.0 introduced gst-plugins-bad as new dependency

It isn't the case that i am worried about size or bandwidth usage.

I just don't like that i have to depend so many package if i intend to use provided webkit2gtk.

Never mind. I can live with the fact.

Anyway thanks for reply.

Offline

Board footer

Powered by FluxBB