You are not logged in.

#1 2017-10-13 08:28:40

nlern
Member
From: West Bengal, India
Registered: 2015-06-29
Posts: 51

[SOLVED] [KDE] Plasma does not start After 5.11 Update

Hello,

Yesterday I updated my Arch Linux pc.  I use KDE 5 and it was upgraded from 5.10 to 5.11.  But after the upgrade, Plasma DE is not launching, i am stuck at the KDE loading screen.  I then installed 'lxde' group (through "sudo pacman -S lxde") and after than if I select 'LXDE' or 'KDE/Openbox' or 'Openbox' as my DE in SDDM, I can properly login in those DEs.  Today I got update for KDE apps and updated my PC.  But still I cannot start Plasma.  I don't know how to debug the problem.  So if anyone can help me I will be grateful.

Thanks.

Last edited by nlern (2017-10-13 15:39:14)

Offline

#2 2017-10-13 08:57:32

imdn
Member
Registered: 2016-04-12
Posts: 35

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

Are you launching Plasma X11 or the newer Plasma Wayland ? The latter still has bugs that need to be ironed out, so it's safer to stick to the former for time being.

Sometimes updating KDE can sometimes be problematic due to leftover settings and cached files from the old version (provided this was the reason). Check this thread to see which files to remove (make backups first) https://bbs.archlinux.org/viewtopic.php?id=230818.

Offline

#3 2017-10-13 09:27:50

nlern
Member
From: West Bengal, India
Registered: 2015-06-29
Posts: 51

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

I am running Plasma X11.  Everything was running fine till yesterday, till I upgraded my system and logged out and logged in.  I will see if deleting old config files help.

Offline

#4 2017-10-13 09:59:24

nlern
Member
From: West Bengal, India
Registered: 2015-06-29
Posts: 51

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

I moved .cache, .config, .local, .kde4 to some other folder and tried logging in to Plasma, but I saw the same kde loading screen with breeze cursor.

Offline

#5 2017-10-13 10:22:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,919

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

Check your journal if there's any information there. maybe also post an excerpt.

Offline

#6 2017-10-13 15:38:19

nlern
Member
From: West Bengal, India
Registered: 2015-06-29
Posts: 51

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

I removed xf86-video-intel and reinstalled it, then created `/etc/X11/xorg.conf.d/20-intel.conf` with following contents:

Section "Device"
	Identifier	"Intel"
	Driver		"intel"
	Option		"DRI" "2"
	Option		"AccelMethod" "uxa"
EndSection

Finally I changed `~/.config/kwinrc` "OpenGLIsUnsafe=false" to "OpenGLIsUnsafe=true".  Then Plasma launched correctly.

Cheers!

Offline

#7 2017-10-13 16:34:25

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,919

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

xf86-video-intel strikes again. On modern intel GPUs you are usually better off completely removing it (and configurations regarding it), which will make Xorg use a generic modesetting driver, which is where intel puts more resources into these days.

Offline

#8 2017-10-14 19:33:37

infinarchy
Banned
Registered: 2016-09-19
Posts: 73

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

empty

Last edited by infinarchy (2017-11-04 21:32:54)

Offline

#9 2017-11-11 10:52:43

AstroFloyd
Member
Registered: 2013-12-01
Posts: 4
Website

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

@nlern: I tried your three steps (reinstall xf86-video-intel, creating 20-intel.conf and editing ~/.config/kwinrc).  The last one did the trick for me; after undoing step 2 I could still log in.  Thank you for sharing! smile

Offline

#10 2017-11-11 16:12:44

nlern
Member
From: West Bengal, India
Registered: 2015-06-29
Posts: 51

Re: [SOLVED] [KDE] Plasma does not start After 5.11 Update

@AstroFloyd: I'm glad that the post helped you.  Also I think the cause of the problem is OpenGL 2.0+ no support in old Intel integrated graphics driver ( mine is Intel G31 which supports opengl 1.4).  So in Step 3 what I did was to tell KWin to not use opengl 2.0.  I found it out by launching KDE Compositor app which told me to use XRender for composition, instead of OpenGL.  After that I also got compositions in KDE Plasma.

Offline

Board footer

Powered by FluxBB