You are not logged in.

#1 2006-06-30 03:04:10

Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Fix: Entrypoint error with newest ATi drivers on R200 series


It seems that copying the from 8.24.8 works around this problem. I've taken out the middle man, and in the latest (ati-fglrx-utils-8.26.18-2) update to ati-fglrx-utils, I included it as /usr/lib/

If you are affected by this problem, to correct it, simply:
cp /usr/lib/ /usr/lib/


disclaimer: I dont have the hardware to test this, but it seems to work for quite a few people.[/i]


#2 2006-06-30 08:31:28

From: Spain
Registered: 2006-06-02
Posts: 17

Re: Fix: Entrypoint error with newest ATi drivers on R200 series

Thanks iphitus, but still no luck in my laptop.

Good news for the HP-Compaq laptop users: The BIOS hack enabling Sideport+UMA and 128M of aditional memory for the graphics card is not needed anymore (maybe this was solved with the last kernel upgrade to 2.6.17).

Now I'm using the ati-fglrx driver with 3D accel disabled, commenting the Load "dri" line in /etc/X11/xorg.conf and everything is working fine (no hangs when change from X to VC and so on).

Here is my /etc/X11/xorg.conf:

Section "ServerLayout"
        Identifier     " Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/100dpi"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/local"

Section "Module"
        Load  "extmod"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
        Load  "freetype"
        Load  "type1"
        #Load "dri"
        Load  "glx"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option "XkbLayout" "es"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "LPL"
        ModelName    "1776"

Section "Device"
        Identifier  "Card0"
        Driver      "fglrx"
        VendorName  "ATI Technologies Inc"
        BoardName   "ATI Radeon XPRESS 200M 5955 (PCIE)"
        BusID       "PCI:1:5:0"

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultColorDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     24

Section "DRI"
        Mode 0666

Oh! I have tried the following options with no changes (when enabling dri, start the X Window results in a black screen and a full system hang, I have to do a hard reset):

Option "UseInternalAGPGART" "no"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"

I have the following modules loaded (related to graphics card):

fglrx ati_agp agpgart

And here is the output of lspci -v:

01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE) (prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company Unknown device 30a4
        Flags: bus master, 66MHz, medium devsel, latency 255, IRQ 17
        Memory at c8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 9000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at c0120000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2

After the upgrade of ati-fglrx-utils I have executed:

cp /usr/lib/ /usr/lib/ && ldconfig

Any idea or suggestions?

Thanks for your excellent work!

='.'=  <-- Cat powered by Arch Linux


Board footer

Powered by FluxBB