You are not logged in.
I searched over the forum but didn't find answers. Has anyone seen this after updated to systemd v235?
systemd[1]: Failed to populate /etc with preset unit settings, ignoring: Cannot assign requested addressOffline
Mod note: Moving to Applications and DEs.
Offline
Nope. Where are you seeing this?
Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD
Making lemonade from lemons since 2015.
Offline
@WorMzy that'd be interesting. @enihcam, is it just something scratching your mind or you do see some affliction/error in your running system? Right now i can't afford an update, i'm still running systemd 234, but i'd like to understand this.
Offline
I have same issue. It happens on boot within initramfs stage, right after systemd starts:
archlinux systemd[1]: systemd 235 running in system mode. (+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +G
archlinux systemd[1]: Detected architecture x86-64.
archlinux systemd[1]: Running in initial RAM disk.
archlinux systemd[1]: Running with unpopulated /etc.
archlinux systemd[1]: No hostname configured.
archlinux systemd[1]: Set hostname to <archlinux>.
archlinux systemd[1]: Initializing machine ID from random generator.
archlinux systemd[1]: Failed to populate /etc with preset unit settings, ignoring: Cannot assign requested address
archlinux systemd[1]: Reached target Timers.
archlinux systemd[1]: Reached target Local File Systems.Last edited by Uriel_Bernhard48 (2017-10-15 22:23:17)
Offline
I have same issue. It happens on boot within initramfs stage, right after systemd starts:
archlinux systemd[1]: No hostname configured.
If you know what i mean, that's not best practice (i mean, set a hostname properly).
Probably i've got no clue since OP didn't mention It.
Edit: i've been too aggressive. Check if
echo $HOSTNAMEactually give out the hostname you've configured, because there's clearly something wrong about that.
Last edited by lo1 (2017-10-15 22:43:38)
Offline
@lo1 It's message from initramfs, not real system. Don't worry about it.
Offline
@lo1 It's message from initramfs, not real system. Don't worry about it.
Yeah sorry, I was going to re-edit cause actually
archlinux systemd[1]: Running with unpopulated /etc. is the interesting clue, not a consequence as i thought. Better wait the savvy here, though i wish to understand if this is causing issues running your loaded system.
Offline
@WorMzy that'd be interesting. @enihcam, is it just something scratching your mind or you do see some affliction/error in your running system? Right now i can't afford an update, i'm still running systemd 234, but i'd like to understand this.
I'm seeing this from dmesg in my three archlinux-based systems (VM, Router, and laptop):
[ +0.012029] systemd[1]: systemd 235 running in system mode. (+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS
[ +0.000182] systemd[1]: Detected architecture x86-64.
[ +0.000004] systemd[1]: Running in initial RAM disk.
[ +0.000008] systemd[1]: Running with unpopulated /etc.
[ +0.000056] systemd[1]: Initializing machine ID from random generator.
[ +0.016207] systemd[1]: Failed to populate /etc with preset unit settings, ignoring: Cannot assign requested address
[ +0.007292] systemd[1]: Reached target Local File Systems.
[ +0.000104] systemd[1]: Reached target Timers.
[ +0.000228] systemd[1]: Created slice system.slice.
[ +0.000090] systemd[1]: Listening on Journal Socket (/dev/log).Last edited by enihcam (2017-10-16 00:47:37)
Offline
So it happens in the initramfs and makes no difference. Sounds like something to just ignore.
Offline
It's not really an issue, just question what does it mean. It's presented with warning severity in journal.
Offline
Seems it is discussed upstream at https://github.com/systemd/systemd/issues/7100
Mike C
Offline
Maybe we could include /etc/machine-id in the initramfs? That should stop systemd from seeing an unpopulated /etc.
Last edited by progandy (2017-10-26 17:00:51)
| alias CUTF='LANG=en_XX.UTF-8@POSIX ' | alias ENGLISH='LANG=C.UTF-8 ' |
Offline
I would leave this issue to be resolved by upstream or at least resolve 54943 first as it actually causes breakage and being a systemd 234 issue predates this one.
Edit:
Should be fixed in systemd 236 https://github.com/systemd/systemd/pull/7360 / https://github.com/systemd/systemd/comm … fbb8fcc277
Last edited by loqs (2017-11-17 16:56:37)
Offline