You are not logged in.

#1 2017-11-02 18:04:11

LordChaos73
Member
From: .nl
Registered: 2008-11-11
Posts: 126

[SOLVED] Upgrading to 4.13.10-1 breaks acpi_call

After upgrading to kernel 4.13.10-1 the acpi_call module can no longer be loaded:

● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2017-11-02 18:53:59 CET; 3min 29s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 220 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 220 (code=exited, status=1/FAILURE)

nov 02 18:53:59 x1carbon systemd-modules-load[220]: Failed to insert 'acpi_call': Exec format error

Anyone else seeing this?

Last edited by LordChaos73 (2017-11-03 08:55:51)

Offline

#2 2017-11-02 18:16:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,324

Re: [SOLVED] Upgrading to 4.13.10-1 breaks acpi_call

Offline

#3 2017-11-02 18:17:36

judd1
Member
Registered: 2015-09-04
Posts: 29

Re: [SOLVED] Upgrading to 4.13.10-1 breaks acpi_call

$ systemctl status systemd-modules-load.service - Load Kernel Modules
Unit -.service could not be found.
Unit Load.service could not be found.
Unit Kernel.service could not be found.
Unit Modules.service could not be found.
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: active (exited) since Thu 2017-11-02 15:15:44 -03; 7min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 204 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
 Main PID: 204 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/systemd-modules-load.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
$ alsi

                  ##			OS: Arch Linux x86_64
                 ####			Hostname: arch
                ######			Uptime: 10 min, 6 sec
               ########			Kernel: 4.13.10-1-ARCH
              ##########		Shell: /bin/bash
             ############		Packages: 914
            ##############		WM: Openbox
           ################		GTK2 theme: Numix
          ##################		GTK2 icon theme: gnome
         ####################		GTK2 font name: Sans 10
        ######################		RAM: 527M / 7854M (6%)
       #########      #########		CPU: Intel(R) Core(TM) i7-3517U CPU @ 1.90GHz
      ##########      ##########	Efi: 256K / 511M (1%) (vfat)
     ###########      ###########	Home: 16G / 466G (4%) (xfs)
    ##########          ##########	Root: 8,6G / 29G (32%) (ext4)
   #######                  #######	
  ####                          ####	
 ###                              ###	

Last edited by judd1 (2017-11-02 18:20:24)

Offline

#4 2017-11-02 20:40:23

LordChaos73
Member
From: .nl
Registered: 2008-11-11
Posts: 126

Re: [SOLVED] Upgrading to 4.13.10-1 breaks acpi_call

Thanks Scimmia!

Offline

#5 2017-11-03 08:57:54

LordChaos73
Member
From: .nl
Registered: 2008-11-11
Posts: 126

Re: [SOLVED] Upgrading to 4.13.10-1 breaks acpi_call

Solved after upgrade:

linux 4.13.11-1
acpi_call 1.1.0-76
x1carbon :: ~ » lsmod |grep -i acpi_call
acpi_call              16384  0

Offline

Board footer

Powered by FluxBB