You are not logged in.

#1 2017-11-13 12:59:11

Zell_89
Member
From: Italy
Registered: 2010-03-27
Posts: 13
Website

Icu version 60 almost broke my system

Hi, this morning I did a system update, after that almost every application refused to start, the problem is with icu package, the apps point to libicui18n.so.59 that is missing because removed by the update, I tried to create a symlink from version 60 to 59 but didn't worked, "fixed" with a downgrade to version 59. Now, however, plasma crashes at startup, but I'm not sure if it's a problem with the icu package or something broken with other. Anyone had that problems with latest update?

Last edited by Zell_89 (2017-11-13 16:46:36)

Offline

#2 2017-11-13 14:08:42

caskale13c
Member
From: Colleyville, TX, US
Registered: 2008-12-29
Posts: 30

Re: Icu version 60 almost broke my system

I too discovered that icu "broke" my system.  However, since downgrading, my plasma is working fine.

Offline

#3 2017-11-13 14:23:16

caskale13c
Member
From: Colleyville, TX, US
Registered: 2008-12-29
Posts: 30

Re: Icu version 60 almost broke my system

caskale13c wrote:

I too discovered that icu "broke" my system.  However, since downgrading, my plasma is working fine.

oops, I spoke to soon.  Made a slight plasma change and now plasma is hosed.  I get a black screen.  Fortunately, I can start applications via my latte-dock which works fine.  More debugging required...

Offline

#4 2017-11-13 14:37:45

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,265

Re: Icu version 60 almost broke my system

Without specifics here, this is totally useless.

Offline

#5 2017-11-13 14:39:48

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,402
Website

Re: Icu version 60 almost broke my system

Please edit your first post and pick a title that actually represents the issue.

If you are using [testing], you should expect breakage and be prepared to give useful bug reports when it happens, otherwise why on earth are you using testing in the first place.

No one will likely care if you are unhappy with the instability of testing, but they will care about bugs that you help find.  It seems you believe this is related to libicu, so at very least that should be in your title.  As is, the title is just content-free whining.


Resist the GNU world order.

Offline

#6 2017-11-13 15:14:14

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,265

Re: Icu version 60 almost broke my system

If you're using the kde-unstable repo, yes, there is a problem. https://bugs.archlinux.org/task/56314

If so, that's critical information that should have been in your posts.

Offline

#7 2017-11-13 16:46:02

Zell_89
Member
From: Italy
Registered: 2010-03-27
Posts: 13
Website

Re: Icu version 60 almost broke my system

Trilby wrote:

Please edit your first post and pick a title that actually represents the issue.

If you are using [testing], you should expect breakage and be prepared to give useful bug reports when it happens, otherwise why on earth are you using testing in the first place.

No one will likely care if you are unhappy with the instability of testing, but they will care about bugs that you help find.  It seems you believe this is related to libicu, so at very least that should be in your title.  As is, the title is just content-free whining.

Yes, sorry, I was just asking if anyone noticed that problem, I know that testing is unstable but I'm not complaing about that. I know the title is not precise but I was not sure to blame only Icu or also another package. Looking at the bugreport I think the problem is just Icu with the missing links. I'm on windows right now, as soon as possible I'm going to look deep.

Offline

#8 2017-11-13 17:25:11

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,265

Re: Icu version 60 almost broke my system

So are you or are you not using kde-unstable?

Offline

#9 2017-11-15 15:35:34

jonnybarnes
Member
From: Manchester, UK
Registered: 2011-05-11
Posts: 112
Website

Re: Icu version 60 almost broke my system

I tried to manually install icu 60.1 (downloaded the.pkg.tar.gz and ran pacman -U) and it nearly broke my system, even pacman complained about not being able to find the right library!

So I had to manually extract the 59.1-2 icu files, then pacman would let me do a pacman -U icu-59.1-2... --force to clear the system back up.

As for now I’ll wait, I don’t want to enable testing for everything. I’m just trying to do some web development. I’m using Pierre’s custom repo and when I updated to php to 7.2.0RC6 the php-intl module complained it couldn’t find `libicui18n.so.60` so I assume Pierre has testing enabled on his system.

Offline

#10 2017-11-15 15:37:35

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,265

Re: Icu version 60 almost broke my system

jonnybarnes wrote:

I tried to manually install icu 60.1 ...

User error. Partial updates are not supported.

Offline

#11 2017-11-15 15:38:30

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,402
Website

Re: Icu version 60 almost broke my system

jonnybarnes wrote:

I tried to manually install icu 60.1 (downloaded the.pkg.tar.gz and ran pacman -U) ... I don’t want to enable testing for everything.

So you did something idiotic and clearly and emphatically warned against in the documentation for the distro you are using and it did not end well.

Thanks for sharing.


Resist the GNU world order.

Offline

#12 2017-11-15 15:41:31

jonnybarnes
Member
From: Manchester, UK
Registered: 2011-05-11
Posts: 112
Website

Re: Icu version 60 almost broke my system

You live and learn. I assume when icu 60.1 lands in the main repos this error will go away?

php --version
PHP Warning:  PHP Startup: Unable to load dynamic library 'intl.so' (tried: /usr/lib/php/modules/intl.so (libicui18n.so.60: cannot open shared object file: No such file or directory), /usr/lib/php/modules/intl.so.so (/usr/lib/php/modules/intl.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 7.2.0RC6 (cli) (built: Nov 13 2017 16:36:58) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.2.0-dev, Copyright (c) 1998-2017 Zend Technologies

Offline

#13 2017-11-15 15:49:51

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,402
Website

Re: Icu version 60 almost broke my system

No the error will go away when you properly upgrade/downgrade your packages to be in sync with the well-curated set of packages in the repos.

In any case, it's really not relevant to this thread.  Despite having an error with the same library, your problem is purely due to partial upgrading. (edit: I suppose the OPs error probably is to, but due to other repos enabled, not due to explicitly downloading and installing specific packages).

Last edited by Trilby (2017-11-15 15:51:38)


Resist the GNU world order.

Offline

#14 2017-11-16 08:47:48

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 334

Re: Icu version 60 almost broke my system

I never do partial upgrades, nor do I use testing. However, due to the new icu package Thunderbird wouldn't start, nor would Firefox-esr-gtk2.
I updated Firefox-esr-gtk2(AUR) myself, briefly enabled testing, and installed Thunderbird. This solved the problem.
IMHO icu is pushed a bit to fast, with regard to some packages which rely on it.

edit:typos

Last edited by henk (2017-11-16 08:48:32)

Offline

#15 2017-11-16 08:51:33

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,016

Re: Icu version 60 almost broke my system

If you are not using testing but have the new icu installed you are doing partial upgrades, the icu in core is still the old version.

If you use third party repos that link against testing and you aren't aware of it and then try to fix it by partial upgrading icu that is also your fault.

Last edited by V1del (2017-11-16 09:24:04)

Offline

#16 2017-11-16 09:31:39

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 334

Re: Icu version 60 almost broke my system

my apologies, that seems to be the case...

Offline

#17 Yesterday 04:10:04

dviktor
Member
Registered: 2015-10-18
Posts: 72

Re: Icu version 60 almost broke my system

try icu59 from AUR
works perfect with icu60 from repo

Offline

Board footer

Powered by FluxBB