You are not logged in.

#1 2017-11-14 14:16:10

jonnybarnes
Member
From: Manchester, UK
Registered: 2011-05-11
Posts: 112
Website

makepkg doesn’t work, whereas manually running build() commands does

I’m trying to install a git version of `xdebug` as it includes some bugfixes for using it with PHP7.2.0RC6.

I copied the PKGBUILD using `asp`.

My `build()` section currently looks like this:

build() {
  cd "$srcdir"/xdebug
  phpize
  ./configure --prefix=/usr --enable-xdebug
  make

  cd "$srcdir"/xdebug/debugclient
  ./buildconf
  ./configure --prefix=/usr --with-libedit
  make
}

When running `makepkg` I get an error in the debugclient step about the configure command not finding a `Makefile.in` file.

The output of the `./buildconf` step is:

cleaning
buildconf: checking installation...
buildconf: autoconf version 2.69 (ok)
buildconf: automake version 1.15.1 (ok)
buildconf: libtool version 2.4.6.40-6ca5 (ok)
rebuilding aclocal.m4
rebuilding Makefile templates
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
   ./Makefile.in
rebuilding configure
rebuilding config_h.in

However, if I manually go to the debugclient directory in my terminal and invoke `./buildconf` myself the output is as follows:

cleaning
buildconf: checking installation...
buildconf: autoconf version 2.69 (ok)
buildconf: automake version 1.15.1 (ok)
buildconf: libtool version 2.4.6.40-6ca5 (ok)
rebuilding aclocal.m4
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
rebuilding configure
rebuilding config_h.in
rebuilding Makefile templates
   ./Makefile.in

So why isn’t makepkg working correctly?

Last edited by jonnybarnes (2017-11-14 20:57:43)

Offline

#2 2017-11-14 14:25:14

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,449
Website

Re: makepkg doesn’t work, whereas manually running build() commands does

Please provide all changes you made to the PKGBUILD (or just your complete PKGBUILD) so we can actually test and investigate.

Also the error you paraphrase is not present in the output you provided.  The two outputs are identical, though in different order.

Last edited by Trilby (2017-11-14 14:27:10)


Resist the GNU world order.

Offline

#3 2017-11-14 14:35:01

jonnybarnes
Member
From: Manchester, UK
Registered: 2011-05-11
Posts: 112
Website

Re: makepkg doesn’t work, whereas manually running build() commands does

Here’s a barebones version that errors for me:

# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Jonathan Wiersma <arch aur at jonw dot org>
# Contributor: Jonathan Wiersma <arch aur at jonw dot org>
# Contributor: sracker <smb.sac@gmail.com>

pkgname=xdebug-git
pkgver=2.6.0
pkgrel=1
pkgdesc="PHP debugging extension"
arch=('x86_64')
url="http://www.xdebug.org"
license=('GPL')
depends=('php libedit')
conflicts=('xdebug')
replaces=('xdebug')
backup=('etc/php/conf.d/xdebug.ini')
source=('git+https://github.com/xdebug/xdebug')
sha256sums=('SKIP')

build() {
  #cd "$srcdir"/xdebug
  #phpize
  #./configure --prefix=/usr --enable-xdebug
  #make

  cd "$srcdir"/xdebug/debugclient
  ./buildconf
  ./configure --prefix=/usr --with-libedit
  make
}

package() {
  cd "$srcdir"/$pkgname/debugclient
  make DESTDIR="$pkgdir" install

  #cd "$srcdir"/$pkgname
  #make INSTALL_ROOT="$pkgdir" install
  #install -D -m 644 "$srcdir"/xdebug.ini "$pkgdir"/etc/php/conf.d/xdebug.ini
}

The error I get is:

configure: creating ./config.status
config.status: error: cannot find input file: `Makefile.in'

i.e. the buildconf step isnt actually generating the Makefile.in file. Indeed manually going to the folder I don’t see it, but then running `./buildconf` myself its there.

Bear in mind I will definitely need to edit things like `pkgname` before I consider submitting this to the AUR, and explicitly referencing the `xdebug` folder in the build step isn’t the best.

Last edited by jonnybarnes (2017-11-14 19:31:39)

Offline

Board footer

Powered by FluxBB