You are not logged in.

#1 2017-11-11 04:55:09

Batou
Member
Registered: 2017-01-03
Posts: 94

[solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Hi all,

This is a pretty recent issue (I noticed it 3-4 weeks ago) and I believe it's related to the kernel. I have a USB3 hub and it won't recognize any of the external USB3 hard drives that  I plug into it. Everything has worked perfectly before but now it does not. Arch does recognize USB2 devices just fine (dongle for my mouse works just fine and my phone works fine too when I plug it in).

I've noticed the following:

1) Everything works perfectly when I boot Windows 7. Windows sees and mounts the drives just fine
2) If I plug it in without the hub, it can see the drive (that's a pain because my USB3 port is at the back of the PC)
3) I have tried two different external USB3 drives (SSD and HDD) and none of them work (don't have USB2 drives to test)
4) The hub is powered so the drives have enough power and that's not an issue
5) Drives are formatted as FAT32
6) Hub works fine under FreeBSD (on another computer that I have) and it works fine under OS X on my friend's MBP laptop and both of them can see my external drives

My hub shows up as:

 $ lsusb
....
Bus 004 Device 002: ID 05e3:0612 Genesys Logic, Inc. Hub
....

When I plug in the drive and do a lsblk, drives do not show up at all.

For some reason, kernel does not like my hub now even though it was fine before.

Anyone have any suggestions? Thanks!

Last edited by Batou (2017-11-16 04:08:56)

Offline

#2 2017-11-11 06:48:51

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,195

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Does the kernel you are running match the one installed?

Compare the output of uname -a and of pacman -Q linux   (Assuming you are running the stock kernel)
Do the versions numbers match?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
----
How to Ask Questions the Smart Way

Offline

#3 2017-11-11 07:27:20

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

ewaller, yep, they match (I run a stock kernel).

~ $ uname -a
Linux batou 4.13.11-1-ARCH #1 SMP PREEMPT Thu Nov 2 10:25:56 CET 2017 x86_64 GNU/Linux
~ $ pacman -Q linux
linux 4.13.11-1
 

Last edited by Batou (2017-11-11 07:28:55)

Offline

#4 2017-11-11 09:51:51

seth
Member
Registered: 2012-09-03
Posts: 4,704

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

"dmesg -w", do you get any events when plugging sth. into the hub? If not, what happens if you plug in the hub with some device already attached?

Offline

#5 2017-11-11 19:20:27

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

seth, this is what I found:

 
[    2.173381] usb 2-1.8: new full-speed USB device number 5 using ehci-pci
[    7.095361] usb 3-3.1: unable to read config index 0 descriptor/all
[    7.096076] usb 3-3.1: can't read configurations, error -110
[    7.170041] usb 3-3.1: new full-speed USB device number 4 using xhci_hcd
[    7.266445] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.1/3-3.1:1.0/0003:046C:D539.0003/input/input2
[    7.320158] hid-generic 0003:046C:D539.0003: input,hidraw2: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-0000:00:14.0-3.1/input0
[    7.322908] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.1/3-3.1:1.1/0003:046C:D539.0004/input/input3
[    7.376941] hid-generic 0003:046C:D539.0004: input,hiddev0,hidraw3: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:14.0-3.1/input1
[    7.379397] hid-generic 0003:046C:D539.0005: hiddev1,hidraw4: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-3.1/input2

So... these two lines are the issue and are reporting the problem:

[    7.095361] usb 3-3.1: unable to read config index 0 descriptor/all
[    7.096076] usb 3-3.1: can't read configurations, error -110 

If I remove the hub, they do not show up. So this is definitely the only error message I can find.

However, the mouse receiver is plugged into it and it works fine (those are the lines right below the error). And I can plug in all kinds of USB2 devices I have around (including a keyboard).

Any ideas?

Last edited by Batou (2017-11-11 19:21:45)

Offline

#6 2017-11-11 20:07:23

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

I have an old Ubuntu on a USB stick lying around so I booted it to see if it reports any errors.

 $ uname -a
Linux liveubuntu 4.8.0-53-generic #56~16.04.1-Ubuntu SMP Tue May 16 01:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux 
$ lsusb 
....
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05e3:0612 Genesys Logic, Inc. 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 046d:c539 Logitech, Inc. 
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 

So it found the hub just fine. No errors either.

And if I plug in my external SSD, I see:

 $ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sdc      8:32   0 465.8G  0 disk 
└─sdc1   8:33   0 465.8G  0 part /media/mount/500GB SSD 

Works just fine. My Arch install was like this for years too. Not sure what changed.

Offline

#7 2017-11-11 20:44:49

seth
Member
Registered: 2012-09-03
Posts: 4,704

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

"error -110" means "power exceeded" - do you have any power saving tools/usb-autosuspend in place?

Offline

#8 2017-11-11 23:18:54

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

seth wrote:

"error -110" means "power exceeded" - do you have any power saving tools/usb-autosuspend in place?

No. Any ideas what those tools could be? I could check.
Wonder how none of the other OSes and previous kernels don't have this issue...

Last edited by Batou (2017-11-11 23:40:01)

Offline

#9 2017-11-12 07:42:06

seth
Member
Registered: 2012-09-03
Posts: 4,704

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

TLP, laptop-tools, powertop (autotune feature)?
https://wiki.archlinux.org/index.php/Po … utosuspend / "-1" disables autosuspend.

How does the system behave with the lts kernel? (to check whether it's the kernel or the userspace)

Offline

#10 2017-11-12 19:22:01

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 339

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Batou wrote:

This is a pretty recent issue (I noticed it 3-4 weeks ago) and I believe it's related to the kernel.

There have been multiple kernel changes to usb components over the past few weeks. I'm using the latest 4.9.61 lts kernel (under arch and other distros) and have come across similar issues so I agree with you. Using the older kernel via your Ubuntu stick confirms this.

I'm testing a machine using "-1" for usb autosuspend and it's been working so far.

stable kernel usb search...
https://git.kernel.org/pub/scm/linux/ke … grep&q=usb

lts kernel usb search...
https://git.kernel.org/pub/scm/linux/ke … grep&q=usb

Cheers
Paul.

Offline

#11 2017-11-14 00:09:01

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

seth wrote:

TLP, laptop-tools, powertop (autotune feature)?
https://wiki.archlinux.org/index.php/Po … utosuspend / "-1" disables autosuspend.

How does the system behave with the lts kernel? (to check whether it's the kernel or the userspace)

seth, this is a PC so all these power saving tools are a moot point and I don't run any of them. The issue must be with the kernel.

I haven't tried the lts kernel yet. Can I install it beside the current one? Never tried running another kernel and the Wiki isn't that explicit as to how to install another one...

paulkerry wrote:
Batou wrote:

This is a pretty recent issue (I noticed it 3-4 weeks ago) and I believe it's related to the kernel.

There have been multiple kernel changes to usb components over the past few weeks. I'm using the latest 4.9.61 lts kernel (under arch and other distros) and have come across similar issues so I agree with you. Using the older kernel via your Ubuntu stick confirms this.

I'm testing a machine using "-1" for usb autosuspend and it's been working so far.

stable kernel usb search...
https://git.kernel.org/pub/scm/linux/ke … grep&q=usb

lts kernel usb search...
https://git.kernel.org/pub/scm/linux/ke … grep&q=usb

Cheers
Paul.

Thanks Paul!

Yes, something has definitely changed with the USB in the new kernel. USB is a lot less reliable and I've noticed that I'm getting erratic speeds when transferring over USB3.

Last edited by Batou (2017-11-14 00:10:16)

Offline

#12 2017-11-14 06:14:22

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Well, just booted lts.

$ uname -a
Linux batou 4.9.61-1-lts #1 SMP Wed Nov 8 17:49:38 CET 2017 x86_64 GNU/Linux 

and everything seems to work perfectly!

 $ lsusb
...
Bus 004 Device 002: ID 05e3:0612 Genesys Logic, Inc. Hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and the drive is detected properly and it mounts just fine:

$ lsblk
NAME              MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT

sdc                 8:32   0 465.8G  0 disk  
└─sdc1              8:33   0 465.8G  0 part  /run/media/batou/500GB SSD 

So it is the kernel issue. How do we fix this bug in the mainline kernel?

Edit: When I plug in the USB3 drive while running the 4.9 LTS kernel, I see the following:

 
[  127.989347] usb 4-3.2: new SuperSpeed USB device number 3 using xhci_hcd
[  128.024035] usb-storage 4-3.2:1.0: USB Mass Storage device detected
[  128.024312] scsi host6: usb-storage 4-3.2:1.0
[  130.340116] scsi 6:0:0:0: Direct-Access     SAMSUNG D SMD5050B1A17 2    PQ: 0 ANSI: 6
[  130.340509] sd 6:0:0:0: Attached scsi generic sg3 type 0
[  130.340850] sd 6:0:0:0: [sdc] 976773168 512-byte logical blocks: (500 GB/466 GiB)
[  130.341329] sd 6:0:0:0: [sdc] Write Protect is off
[  130.341330] sd 6:0:0:0: [sdc] Mode Sense: 3b 00 00 00
[  130.341768] sd 6:0:0:0: [sdc] No Caching mode page found
[  130.341771] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  130.414179]  sdc: sdc1
[  130.415711] sd 6:0:0:0: [sdc] Attached SCSI disk

and when I plug it in with 4.13 kernel running, I don't see any messages with dmesg (except for that -110 error message at the boot).

Last edited by Batou (2017-11-14 08:22:52)

Offline

#13 2017-11-14 13:00:57

seth
Member
Registered: 2012-09-03
Posts: 4,704

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Did you try to disable autosuspend? (Makes little to no sense on an stationary PC anyway)

Offline

#14 2017-11-14 18:09:20

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

seth wrote:

Did you try to disable autosuspend? (Makes little to no sense on an stationary PC anyway)

Gave that a try:

$ cat /sys/module/usbcore/parameters/autosuspend
-1

Made no difference. After I plug in an HDD, dmesg shows nothing.

Offline

#15 2017-11-15 08:28:03

Batou
Member
Registered: 2017-01-03
Posts: 94

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Okay, I'm not sure what happened but when I reinstalled the kernel and added usbcore.autosuspend=-1 on the Grub command line, I now have USB3 functionality back!

Thank you seth and Paul! I'm so happy! smile I hope this lasts and doesn't break in the next kernel update and I hope this doesn't cause some other side-effects.

Offline

#16 2017-11-15 21:55:59

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 339

Re: [solved]My USB 3 hub doesn't see my USB 3 external hard drives anymore

Glad it's working for you now. Given the amount of recent kernel changes to usb, it might be worth keeping an eye on those kernel change log links that I posted earlier.
Don't forget to prepend "[solved]" to your first message.

Offline

Board footer

Powered by FluxBB