You are not logged in.

#1 2017-11-17 20:46:43

obelix1502
Member
Registered: 2017-11-17
Posts: 4

Lancer Plexmediaserver

Bonsoir,

J'ai acheté pour ma fille (et pour moi aussi wink ) un Plex Pass.

J'ai donc installé Plex-Media-Server-plexpass depuis AUR. L'installation s'est très bien passée.

Je suis donc allé sur le Wiki : Plex
Là, je lis :

Enable and start plexmediaserver.service.

To begin configuring PMS, browse to http://localhost:32400/web/.

To configure PMS remotely, you must first create an SSH tunnel (setup can only be done from localhost)

ssh ip.address.of.server -L 8888:localhost:32400

and then browse to http://localhost:8888/web/.

Je veux donc démarrer les services de plex et pour le trouver :

pacman -Qql plex-media-server-plexpass | grep -Fe .service -e .socket

qui me renvoie :

/usr/lib/systemd/system/plexmediaserver.service

Donc, je le démarre et là :

[bruno@bruno ~]$ sudo systemctl start /usr/lib/systemd/system/plexmediaserver.service
[sudo] Mot de passe de bruno : 
Failed to start usr-lib-systemd-system-plexmediaserver.service.mount: Unit usr-lib-systemd-system-plexmediaserver.service.mount not found.

Vous y comprenez quelque chose ?? sad

J'essaie donc d'une autre façon :

sudo /opt/plexmediaserver/Plex\ Media\ Server

Réponse :

/opt/plexmediaserver/Plex Media Server: error while loading shared libraries: libboost_atomic.so.1.59.0: cannot open shared object file: No such file or directory

Or, libboost_atomic.so est bien présent :

lrwxrwxrwx   1 root root       25 10 sep 00:59 libboost_atomic.so -> libboost_atomic.so.1.65.1

Je n'y comprends plus rien...

Pouvez-vous m'aider ?

Merci smile

Last edited by obelix1502 (2017-11-17 20:50:39)

Offline

#2 2017-11-18 16:43:08

ayekat
Member
Registered: 2011-01-17
Posts: 1,134

Re: Lancer Plexmediaserver

obelix1502 wrote:

Vous y comprenez quelque chose ?? sad

Oui. Tu as passé tout le chemin à `systemctl start`, alors qu'il faut seulement mettre le nom du service:

sudo systemctl start plexmediaserver.service

Pour l'erreur de la bibliothèque boost, il te demande libboost_atomic.so.1.59.0, qui n'est pas installé sur ton système.
En regardant le PKGBUILD de plex-media-server-plexpass, ça a l'air de juste installer une version précompilé (qui a probablement été compilé avec une ancienne version de boost), d'où cette erreur. Je ne trouve pas de paquêt pour boost 1.59 dans l'AUR, donc je pense que la seule option là serait d'écrire un PKGBUILD pour 1.59 (comme celui pour boost 1.63).

--edit
Ou bien de contacter le mainteneur du paquêt plex-media-server-plexpass smile

Last edited by ayekat (2017-11-19 08:50:02)

Offline

#3 2017-11-28 14:26:35

obelix1502
Member
Registered: 2017-11-17
Posts: 4

Re: Lancer Plexmediaserver

Merci à toi ayekat,

C'est résolu.

Offline

#4 2017-11-28 15:25:32

ayekat
Member
Registered: 2011-01-17
Posts: 1,134

Re: Lancer Plexmediaserver

Bon à savoir! smile

Par curiosité, tu l'as résolu comment?

Offline

#5 2017-11-29 02:28:37

obelix1502
Member
Registered: 2017-11-17
Posts: 4

Re: Lancer Plexmediaserver

Exactement comme tu me l'avais conseillé :

sudo systemctl start plexmediaserver.service
sudo systemctl enable plexmediaserver.service

Démarrage sans soucis. smile

Offline

Board footer

Powered by FluxBB