You are not logged in.

#1 2010-01-15 09:34:42

lessthanjake
Member
From: Norway
Registered: 2005-11-09
Posts: 319
Website

[yaourt] update only packages from aur

I just switched from my own aur_update script to yaourt, because it handles dependencies.. But how to only update packages from aur?

Last edited by lessthanjake (2010-01-15 09:37:35)

Offline

#2 2010-01-15 18:27:02

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,073
Website

Re: [yaourt] update only packages from aur

I don't think it is possible. You have to use a program that separates pacman and the AUR. For example, aurget or slurpy.

Offline

#3 2010-01-16 07:36:33

Ape
Member
From: Finland
Registered: 2009-10-15
Posts: 46
Website

Re: [yaourt] update only packages from aur

I'd also like to know how to do this.

Offline

#4 2010-01-16 08:06:38

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,535
Website

Re: [yaourt] update only packages from aur

Can you do something like this (assuming yaourt supports pacman's "--needed" flag):

yaourt -S --needed $(pacman -Qqm)

If not, you can try bauerbill which does (or at least should) recognize the "--needed" flag.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#5 2010-01-16 09:19:59

Ape
Member
From: Finland
Registered: 2009-10-15
Posts: 46
Website

Re: [yaourt] update only packages from aur

Xyne wrote:

Can you do something like this (assuming yaourt supports pacman's "--needed" flag):

yaourt -S --needed $(pacman -Qqm)

If not, you can try bauerbill which does (or at least should) recognize the "--needed" flag.

That just tries to reinstall (and rebuild as we are talking about AUR) all the AUR packages that are installed. Even the ones that doesn't need any updates.

Offline

#6 2010-01-16 09:23:13

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,535
Website

Re: [yaourt] update only packages from aur

Ape wrote:
Xyne wrote:

Can you do something like this (assuming yaourt supports pacman's "--needed" flag):

yaourt -S --needed $(pacman -Qqm)

If not, you can try bauerbill which does (or at least should) recognize the "--needed" flag.

That just tries to reinstall (and rebuild as we are talking about AUR) all the AUR packages that are installed. Even the ones that doesn't need any updates.

Xyne wrote:

(assuming yaourt supports pacman's "--needed" flag)

Obviously it doesn't. You're welcome to try bauerbill, which should do what you want using the code above.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#7 2010-05-10 14:54:09

cautha
Member
From: Kingston, Ontario
Registered: 2008-06-02
Posts: 115
Website

Re: [yaourt] update only packages from aur

I'm aware that this is a seriously old thread, but, for the sake of posterity... the correct way to update all (old) packages installed from the AUR with yaourt is "yaourt -Sbu --aur".

Last edited by cautha (2010-05-10 15:00:50)

Offline

#8 2010-11-03 00:23:26

nXqd
Member
Registered: 2010-07-01
Posts: 173
Website

Re: [yaourt] update only packages from aur

cautha wrote:

I'm aware that this is a seriously old thread, but, for the sake of posterity... the correct way to update all (old) packages installed from the AUR with yaourt is "yaourt -Sbu --aur".

Thanks for a great answer, I'm looking for a way to update my aur packages smile


When you live for a strong purpose, then hard work isn't an option. It's a necessity. - Steve Pavlina
dotFiles

Offline

#9 2010-11-03 20:31:07

akurei
Member
From: Bochum, NRW, Germany
Registered: 2009-05-25
Posts: 152
Website

Re: [yaourt] update only packages from aur

nXqd wrote:
cautha wrote:

I'm aware that this is a seriously old thread, but, for the sake of posterity... the correct way to update all (old) packages installed from the AUR with yaourt is "yaourt -Sbu --aur".

Thanks for a great answer, I'm looking for a way to update my aur packages smile

+1
Thank you! @cautha

Offline

#10 2017-12-04 11:52:33

sachakantor
Member
Registered: 2017-12-04
Posts: 1

Re: [yaourt] update only packages from aur

cautha wrote:

I'm aware that this is a seriously old thread, but, for the sake of posterity... the correct way to update all (old) packages installed from the AUR with yaourt is "yaourt -Sbu --aur".

for the sake of posterity!!!! Thanks a lot! big_smile

Offline

#11 2017-12-04 12:06:58

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,027
Website

Re: [yaourt] update only packages from aur

Please do not necrobump, sachakantor.

Please take a moment and familiarise yourself with our community code of conduct.

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB