You are not logged in.

#1 2017-12-07 21:32:04

kamelie1706
Member
Registered: 2014-02-19
Posts: 97

F1 2015 / KDE / AMD / Steam

Hi,

Has anyone managed to run F1 2015 on arch with AMD on steam?

This is the errors I get

ERROR: ld.so: object '/home/xxxx/xxxx/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
home/xxxx/xxxx/Steam/SteamApps/common/F1 2015/bin/F12015: /usr/lib/libldap_r-2.4.so.2: no version information available (required by /home/xxxx/xxxx/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4)
/home/xxxx/xxxx/Steam/SteamApps/common/F1 2015/bin/F12015: /usr/lib/liblber-2.4.so.2: no version information available (required by /home/xxxx/xxxx/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4)

The related libraries on my system

lrwxrwxrwx   1 root root        21 26 août  13:43 libldap-2.4.so.2 -> libldap-2.4.so.2.10.8
-rwxr-xr-x   1 root root    302120 26 août  13:43 libldap-2.4.so.2.10.8
lrwxrwxrwx   1 root root        23 26 août  13:43 libldap_r-2.4.so.2 -> libldap_r-2.4.so.2.10.8
-rwxr-xr-x   1 root root    326760 26 août  13:43 libldap_r-2.4.so.2.10.8
lrwxrwxrwx   1 root root        23 26 août  13:43 libldap_r.so -> libldap_r-2.4.so.2.10.8
lrwxrwxrwx   1 root root        21 26 août  13:43 libldap.so -> libldap-2.4.so.2.10.8
lrwxrwxrwx   1 root root        10 26 août  13:43 libldap.so.2 -> libldap.so
lrwxrwxrwx   1 root root        21 26 août  13:43 liblber-2.4.so.2 -> liblber-2.4.so.2.10.8
-rwxr-xr-x   1 root root     59248 26 août  13:43 liblber-2.4.so.2.10.8
lrwxrwxrwx   1 root root        21 26 août  13:43 liblber.so -> liblber-2.4.so.2.10.8
lrwxrwxrwx   1 root root        10 26 août  13:43 liblber.so.2 -> liblber.so

Same log on native or runtime mode.

Could not find any entry on wiki pages for this game ....

I tried to enforce using runtime directory

cd /home/xxxx/xxxx/Steam
find . -name 'libldap_r-2.4.so.2'

returns

./ubuntu12_32/steam-runtime.old/i386/usr/lib/i386-linux-gnu/libldap_r-2.4.so.2
./ubuntu12_32/steam-runtime.old/amd64/usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2
./ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libldap_r-2.4.so.2
./ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2

So I tried to set the path

LD_LIBRARY_PATH="$HOME/xxxx/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu:$HOME/xxxx/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu:$LD_LIBRARY_PATH" %command%

or

LD_LIBRARY_PATH="/usr/lib:$LD_LIBRARY_PATH" %command%

Now it seems that no error about lib in the log but still crashes and creates a dump

ERROR: ld.so: object '/home/xxxx/xxxx/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 7038 for game ID 286570
>>> Adding process 7041 for game ID 286570
>>> Adding process 7045 for game ID 286570
pid 7043 != 7036, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/xxxx/xxxx/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 7044 for game ID 286570
F12015: crash reporter initialised with path "/home/xxxx/.local/share/feral-interactive/F1 2015/crashes"
>>> Adding process 7046 for game ID 286570
F12015: dumped to "/home/xxxx/.local/share/feral-interactive/F1 2015/crashes/314680af-0819-5184-3fffe867-015aa246.dmp"
F12015: crash reporter "/home/xxxx/xxxx/Steam/SteamApps/common/F1 2015/bin/feral_linux_crash_reporter" launching

Thx

Last edited by kamelie1706 (2017-12-07 23:22:45)

Offline

#2 2017-12-12 18:16:34

kamelie1706
Member
Registered: 2014-02-19
Posts: 97

Re: F1 2015 / KDE / AMD / Steam

My config according to Steam

 
Computer Information:
Manufacturer: Unknown
Model: Unknown
Form Factor: Desktop
No Touch Input Detected

Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD Phenom(tm) II X6 1055T Processor
CPU Family: 0x10
CPU Model: 0xa
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 2800 Mhz
6 logical processors
6 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Unsupported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported
AES: Unsupported
AVX: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Linux 4.x (64 bit)
Kernel Name: Linux
Kernel Version: 4.14.4-1-ARCH
X Server Vendor: The X.Org Foundation
X Server Release: 11905000
X Window Manager: KWin
Steam Runtime Version: steam-runtime-beta-release_2017-07-24

Video Card:
Driver: X.Org AMD Radeon (TM) RX 460 Graphics (AMD POLARIS11 / DRM 3.19.0 / 4.14.4-1-ARCH, LLVM 5.0.0)
Driver Version: 3.0 Mesa 17.2.6
OpenGL Version: 3.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x1002
DeviceID: 0x67ef
Revision Not Detected
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 2560 x 1080
Desktop Resolution: 2560 x 1080
Primary Display Size: 26,50" x 11,18" (28,74" diag)
67,3cm x 28,4cm (73,0cm diag)
Primary VRAM: 2022 MB

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 12017 Mb

Miscellaneous:
UI Language: English
LANG: fr_FR.UTF-8
Total Hard Disk Space Available: 461882 Mb
Largest Free Hard Disk Block: 227835 Mb
VR Headset: None detected

Recent Failure Reports:

This is weird as Mesa 17.2.6 is supposed to support OpenGL 4.5 .... while Steam says 3.0 on my system
https://www.mesa3d.org/relnotes/17.2.6.html

This is very confusing!

glxinfo | grep OpenGL

OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 460 Graphics (AMD POLARIS11 / DRM 3.19.0 / 4.14.4-1-ARCH, LLVM 5.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.2.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

Last edited by kamelie1706 (2017-12-12 18:23:21)

Offline

#3 Yesterday 13:30:25

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,131

Re: F1 2015 / KDE / AMD / Steam

The keyword is core profile version. OpenGL 4.5 support is only enabled if requested at context creation, steam (as in the client) has no reason to request a 4.5 context (relying on a 4.5 context would mean being incompatible with older cards). This won't stop F1 from requesting 4.5 if necessary.

Something you should try before doing anything else is get  rid of the LD_LIBRARY attempts you posted so far and instead install steam-native-runtime and starting steam via

steam-native

This will do most of the things you are trying to do here automatically and correctly. If it works with that, great simply use steam-native from now on, if it doesn't see if you can post that crash dump and or if you get a coredump

Offline

#4 Yesterday 23:31:33

kamelie1706
Member
Registered: 2014-02-19
Posts: 97

Re: F1 2015 / KDE / AMD / Steam

Thanks,

few extra information
objdump -x bin/F12015 | grep RPATH

RPATH                $ORIGIN/../lib

ldd bin/F12015

bin/F12015: /usr/lib/libldap_r-2.4.so.2: no version information available (required by /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4)
bin/F12015: /usr/lib/liblber-2.4.so.2: no version information available (required by /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4)
        linux-vdso.so.1 (0x00007ffc7b36e000)
        libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007f927f4c6000)
        libCoreFoundation.so.476 => /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libCoreFoundation.so.476 (0x00007f927f123000)
        libcurl.so.4 => /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4 (0x00007f927eeb8000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007f927ec8b000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f927ea6d000)
        librt.so.1 => /usr/lib/librt.so.1 (0x00007f927e865000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f927e661000)
        libSDL2-2.0.so.0 => /usr/lib/libSDL2-2.0.so.0 (0x00007f927e355000)
        libSDL2_image-2.0.so.0 => /usr/lib/libSDL2_image-2.0.so.0 (0x00007f927e132000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00007f927df1b000)
        libcef.so => /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcef.so (0x00007f9279f5c000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f9279c6d000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f92799a7000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f9279762000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f92793db000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007f927908f000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f9278e78000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007f9278ac0000)
        /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f927f93b000)
        libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f92788b9000)
        libicui18n.so.51 => /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libicui18n.so.51 (0x00007f92784a2000)
        libicuuc.so.51 => /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libicuuc.so.51 (0x00007f9278111000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0x00007f9277edd000)
        librtmp.so.0 => /usr/lib/librtmp.so.0 (0x00007f9277cc2000)
        libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007f9277a55000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f9277808000)
        liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0x00007f92775f9000)
        libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2 (0x00007f92773a7000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0x00007f92771a0000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007f9276f4a000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f9276c2b000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00007f9276a1e000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00007f9276700000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00007f92764b1000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f9276172000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f9275f61000)
        libnss3.so => /usr/lib/libnss3.so (0x00007f9275c37000)
        libnssutil3.so => /usr/lib/libnssutil3.so (0x00007f9275a07000)
        libsmime3.so => /usr/lib/libsmime3.so (0x00007f92757e0000)
        libplc4.so => /usr/lib/libplc4.so (0x00007f92755db000)
        libnspr4.so => /usr/lib/libnspr4.so (0x00007f927539d000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00007f927519a000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f9274f88000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f9274d85000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f9274b7f000)
        libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007f9274979000)
        libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0x00007f9274747000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f927453d000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f9274332000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00007f9274127000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f9273ef5000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f9273ca4000)
        libcups.so.2 => /usr/lib/libcups.so.2 (0x00007f9273a16000)
        libcap.so.2 => /usr/lib/libcap.so.2 (0x00007f9273812000)
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f9273602000)
        libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f92733cc000)
        libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f927312d000)
        libicudata.so.51 => /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libicudata.so.51 (0x00007f92719e3000)
        libgnutls.so.30 => /usr/lib/libgnutls.so.30 (0x00007f9271678000)
        libhogweed.so.4 => /usr/lib/libhogweed.so.4 (0x00007f9271442000)
        libnettle.so.6 => /usr/lib/libnettle.so.6 (0x00007f927120b000)
        libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007f9270f78000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f9270c92000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f9270a5f000)
        libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f927085b000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f927064e000)
        libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007f927044a000)
        libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f9270233000)
        libsasl2.so.3 => /usr/lib/libsasl2.so.3 (0x00007f9270016000)
        libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x00007f926fdac000)
        libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x00007f926f92f000)
        libffi.so.6 => /usr/lib/libffi.so.6 (0x00007f926f726000)
        libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f926f4b3000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00007f926f29f000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f926eff7000)
        libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0x00007f926edf3000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f926ebca000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x00007f926e9bc000)
        libthai.so.0 => /usr/lib/libthai.so.0 (0x00007f926e7b2000)
        libplds4.so => /usr/lib/libplds4.so (0x00007f926e5ae000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007f926e3aa000)
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00007f926e183000)
        libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007f926df04000)
        libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0x00007f926dcf7000)
        libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0x00007f926dae6000)
        libcrypt.so.1 => /usr/lib/libcrypt.so.1 (0x00007f926d8ae000)
        libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f926d682000)
        libp11-kit.so.0 => /usr/lib/libp11-kit.so.0 (0x00007f926d352000)
        libunistring.so.2 => /usr/lib/libunistring.so.2 (0x00007f926cfe1000)
        libtasn1.so.6 => /usr/lib/libtasn1.so.6 (0x00007f926cdce000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f926cbca000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f926c9c4000)
        libdatrie.so.1 => /usr/lib/libdatrie.so.1 (0x00007f926c7bc000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007f926c412000)
        libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007f926c0f6000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007f926bed0000)
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007f926bcbb000)
        libmount.so.1 => /usr/lib/libmount.so.1 (0x00007f926ba65000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f926b850000)
        libblkid.so.1 => /usr/lib/libblkid.so.1 (0x00007f926b603000)

ls -l /usr/lib | grep libldap_r-2.4.so.2

lrwxrwxrwx   1 root root        23 26 août  13:43 libldap_r-2.4.so.2 -> libldap_r-2.4.so.2.10.8                 
-rwxr-xr-x   1 root root    326760 26 août  13:43 libldap_r-2.4.so.2.10.8                                       
lrwxrwxrwx   1 root root        23 26 août  13:43 libldap_r.so -> libldap_r-2.4.so.2.10.8

ls -l /usr/lib | grep liblber-2.4.so.2

lrwxrwxrwx   1 root root        21 26 août  13:43 liblber-2.4.so.2 -> liblber-2.4.so.2.10.8                     
-rwxr-xr-x   1 root root     59248 26 août  13:43 liblber-2.4.so.2.10.8                                         
lrwxrwxrwx   1 root root        21 26 août  13:43 liblber.so -> liblber-2.4.so.2.10.8

I believe I still have a library issue even when running steam-native (LD_LIBRARY empty)

Game update: AppID 286570 "F1 2015", ProcID 2182, IP 0.0.0.0:0
>>> Adding process 2182 for game ID 286570
GameAction [AppID 286570, ActionID 1] : LaunchApp changed task to WaitingGameWindow with ""
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
pid 2184 != 2183, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
GameAction [AppID 286570, ActionID 1] : LaunchApp changed task to Completed with ""
>>> Adding process 2183 for game ID 286570
pid 2186 != 2183, skipping destruction (fork without exec?)
pid 2187 != 2183, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Generating new string page texture 137: 128x256, total string texture memory is 5,87 MB
pid 2189 != 2183, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>> Adding process 2185 for game ID 286570
pid 2190 != 2183, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
/home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/F12015: /usr/lib/libldap_r-2.4.so.2: no version information available (required by /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4)
/home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/F12015: /usr/lib/liblber-2.4.so.2: no version information available (required by /home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/../lib/x86_64/libcurl.so.4)
F12015: crash reporter initialised with path "/home/cyril/.local/share/feral-interactive/F1 2015/crashes"
F12015: dumped to "/home/cyril/.local/share/feral-interactive/F1 2015/crashes/2f8efa77-3e95-0cc5-3e121ede-690e78d0.dmp"
F12015: crash reporter "/home/cyril/home_extra/Steam/SteamApps/common/F1 2015/bin/feral_linux_crash_reporter" launching
ERROR: ld.so: object '/home/cyril/home_extra/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Game crashed, if possible email [support@feralinteractive.com] with the crash file [/home/cyril/.local/share/feral-interactive/F1 2015/crashes/2f8efa77-3e95-0cc5-3e121ede-690e78d0.dmp] and details

GRID AUtopsport complains about the same missing libraries but no issue there. I had to set

LANG=C %command%

for that game to work ... but did not help for F1 2015

Last edited by kamelie1706 (Today 00:14:23)

Offline

Board footer

Powered by FluxBB