You are not logged in.

#1 2017-12-08 00:07:39

r00tr4t
Member
Registered: 2013-01-16
Posts: 16

No module named 'vtkOpenGLKitPython'

Hi there.

I hope this is the right place to ask this or else i kindly asks the moderators to move it where it should be.

So i'm in the need to make some 3D graphics for a robotic arm simulation and was considering to use VTK/python package to generate the graphics. How ever i ran in to some problems. 
As i prefer python3 before python2 i tried to get that to work first and used the vtk-py3-qt4 package from AUR. The installation went fine but when i try to import vtk i get the following error:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/vtk/vtkOpenGLKit.py", line 5, in <module>
    from .vtkOpenGLKitPython import *
ImportError: libvtkOpenGLKitPython36D-8.1.so.1: cannot open shared object file: No such file or directory

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python3.6/site-packages/vtk/__init__.py", line 46, in <module>
    from .vtkOpenGLKit import *
  File "/usr/lib/python3.6/site-packages/vtk/vtkOpenGLKit.py", line 9, in <module>
    from vtkOpenGLKitPython import *
ModuleNotFoundError: No module named 'vtkOpenGLKitPython'

I tried to fix that with installing mayavi from AUR but that didn't help.
So then i tough a f..k i have to use python 2.7 then and installed that with pacman -S vtk.
But no luck there ether.

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/vtk/__init__.py", line 127, in <module>
    from .vtkIOExport import *
  File "/usr/lib/python2.7/site-packages/vtk/vtkIOExport.py", line 9, in <module>
    from vtkIOExportPython import *
ImportError: No module named vtkIOExportPython

#python3.6.3,#python2.7.14,#vtk,

Any one have any ideas how to work around this and preferably get it to work in python3?

Edit: changed subject to better reflect the problem.
Edit2: Fixed a language typo.

Last edited by r00tr4t (2017-12-08 09:56:03)

Offline

Board footer

Powered by FluxBB