You are not logged in.

#1 2017-12-13 21:59:16

Ravenman
Member
Registered: 2009-07-03
Posts: 233

[Solved] Linux 4.14.5-1 does not load virtualbox 5.2.2-2 modules

Hi to everyone:

Recently, I updated my system and it shows me messages about kernel modules load failure. I found this checking it:

-- Unit systemd-modules-load.service has begun starting up.
dic 13 16:02:35 archlinux systemd-modules-load[1467]: Failed to insert 'vboxdrv': Exec format error
dic 13 16:02:35 archlinux kernel: vboxdrv: disagrees about version of symbol module_layout
dic 13 16:02:35 archlinux systemd-modules-load[1467]: Failed to insert 'vboxpci': Exec format error
dic 13 16:02:35 archlinux kernel: vboxdrv: disagrees about version of symbol module_layout
dic 13 16:02:35 archlinux systemd-modules-load[1467]: Failed to insert 'vboxnetadp': Exec format error
dic 13 16:02:35 archlinux kernel: vboxdrv: disagrees about version of symbol module_layout
dic 13 16:02:35 archlinux systemd-modules-load[1467]: Failed to insert 'vboxnetflt': Exec format error
dic 13 16:02:35 archlinux systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
dic 13 16:02:35 archlinux systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
dic 13 16:02:35 archlinux systemd[1]: Failed to start Load Kernel Modules.
-- Subject: Unit systemd-modules-load.service has failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit systemd-modules-load.service has failed.
-- 
-- The result is RESULT.
dic 13 16:02:35 archlinux kernel: vboxdrv: disagrees about version of symbol module_layout 

I am trying to do it manually and I get these messages:

[root@archlinux ~]# modprobe -v vboxdrv
insmod /lib/modules/4.14.5-1-ARCH/extramodules/vboxdrv.ko.gz 
modprobe: ERROR: could not insert 'vboxdrv': Exec format error
[root@archlinux ~]# modprobe -v vboxpci
insmod /lib/modules/4.14.5-1-ARCH/extramodules/vboxdrv.ko.gz 
modprobe: ERROR: could not insert 'vboxpci': Exec format error
[root@archlinux ~]# modprobe -v vboxnetadp
insmod /lib/modules/4.14.5-1-ARCH/extramodules/vboxdrv.ko.gz 
modprobe: ERROR: could not insert 'vboxnetadp': Exec format error
[root@archlinux ~]# modprobe -v vboxnetflt
insmod /lib/modules/4.14.5-1-ARCH/extramodules/vboxdrv.ko.gz 
modprobe: ERROR: could not insert 'vboxnetflt': Exec format error
[root@archlinux ~]# 

What am I doing wrong? hmm

Last edited by Ravenman (2017-12-13 23:22:34)

Offline

#2 2017-12-13 22:06:57

graysky
Member
From: :wq
Registered: 2008-12-01
Posts: 9,440
Website

Re: [Solved] Linux 4.14.5-1 does not load virtualbox 5.2.2-2 modules

Are you up-to-date?  It looks like 5.2.2-10 was rebuilt against this kernel: https://git.archlinux.org/svntogit/comm … ca98fbef6b

EDIT:  You're using 5.2.2-2???  That is nearly 3 weeks old.  Check that your mirror is in sync... it is puzzling to me that you have the latest kernel and not the latest module package.  Are you manually pulling the kernel?

Last edited by graysky (2017-12-13 22:09:00)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs • 1.21 JIGOWATTS!

Offline

#3 2017-12-13 23:20:57

Ravenman
Member
Registered: 2009-07-03
Posts: 233

Re: [Solved] Linux 4.14.5-1 does not load virtualbox 5.2.2-2 modules

graysky wrote:

Are you up-to-date?  It looks like 5.2.2-10 was rebuilt against this kernel: https://git.archlinux.org/svntogit/comm … ca98fbef6b

EDIT:  You're using 5.2.2-2???  That is nearly 3 weeks old.  Check that your mirror is in sync... it is puzzling to me that you have the latest kernel and not the latest module package.  Are you manually pulling the kernel?

You are right!

I changed the mirror and I downloaded virtualbox-host-modules-arch from 5.2.2-6 to 5.2.2-10 ... and everything is working right now.

A lot of thanks by your patience and help!.

Offline

Board footer

Powered by FluxBB