You are not logged in.

#1 2004-03-05 20:54:49

The Analog Kid
Member
From: Pennsylvania, USA
Registered: 2004-01-05
Posts: 27

Firefox does not run as normal user

I installed firefox but it won't run unless I su. This is obviously a problem for me, and just about anyone. I tried deleting the .mozilla-firefox folder. I also tried reinstalling it. Nothing I tried has worked.

Offline

#2 2004-03-08 16:19:50

Win
Member
Registered: 2004-03-04
Posts: 155

Re: Firefox does not run as normal user

Did you install firefox via pacman or from a binary or source package from Mozilla?  How and where did you run firefox (i.e., did you log in as a  normal user and start the software from the home directory as that user)?  Do you have configuration files in home directory with the right permissions and ownership?

Win

Offline

#3 2004-03-08 17:36:59

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: Firefox does not run as normal user

Ack, there is something wrong with mozilla in arch. I had the same results on several machines and installations. Some files, at least one would be enough, is placed in the wrong place, I guess (considered to be placed in ~/.mozilla, but is in /opt/mozilla/ f.e.), and is set to be root's when you run mozilla for the first time as root. I never took the time to explore it, but I believe to remember I solved this, back yonks, twice by recursive changing permissions of the whole mozilla trees. Would be worth to give it a closer look... Anyway, since then I never touched mozilla based browsers as su, if in need to do such things I use 'links'. Furthermore, if you tweak your users permissions, there is no need to run a gui browser as root (*), as far as I am concerned. Give sticky permission for a "staff" group to write to /usr/src/incoming, f.e, and add your account to the group, will give you what you need to fetch sources as a user, and compile them as root in place. For whatever you will have to fetch, there will be a solution using aglp, acl, what ever you use and name it.

(*) Exception:
I found out epiphany frequently locks up fetching http://www.archlinux.org if you are a user, but not if you are root. Funny, isn't it?


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#4 2004-03-08 17:54:07

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Firefox does not run as normal user

So there's a suggested solution:

1. pacman -R mozilla-firefox
2. rm -rf /opt/mozilla-firefox
3. rm -r ~/.mozilla-firefox
4. pacman -S mozilla-firefox


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

Board footer

Powered by FluxBB