You are not logged in.

#51 2016-11-21 12:42:35

Busata
Member
From: Belgium
Registered: 2010-04-04
Posts: 28
Website

Re: Few issues with Asus UX501VW

ladrik wrote:

For those interested, there is a recent solution for the multi-touch issue:

A new kernel driver is being developed by Victor Vlasenko and others that is intended to be submitted to the kernel branch once it is fully tested.

Here is the repository: https://github.com/vlasenko/hid-asus-fte-dkms

It is working for me, either with synaptics or libinput Xorg driver, doing the following, in the directory where you want to download the code.

$ git clone https://github.com/vlasenko/hid-asus-fte-dkms
$ cd hid-asus-fte-dkms
$ ./dkms-add.sh

To make the module load permanent, i've added a .conf file in /etc/modules-load.d. Here is mine:

$ cat /etc/modules-load.d/touchpad.conf 
# Load hid_asus_fte 
hid_asus_fte

awesome! works for me. (Don't forget to install linux-headers & dkms to get this working)

Offline

#52 2016-11-22 03:55:11

FallenSnow
Member
Registered: 2014-04-07
Posts: 14

Re: Few issues with Asus UX501VW

The audio white noise always comes back after suspending... sad

Offline

#53 2016-11-24 09:53:37

2bluesc
Member
Registered: 2014-02-18
Posts: 9
Website

Re: Few issues with Asus UX501VW

Considering this laptop and am curious if anyone knows if it'll charge over USB 3.1 Type-C connector at 60W or 100W? After scouring the Internet I fear the answer is no. sad

Offline

#54 2016-11-28 22:19:14

BlissfulChoreography
Member
Registered: 2008-12-19
Posts: 7

Re: Few issues with Asus UX501VW

karlospv94 wrote:

Have you installed nvidia drivers? I cannot get working the fn buttons with nvidia and nvidia-utils instead of the acpi_osi=

But are you also disabling the nVidia card through bswitch at the same time? If so, please let us know how you got both to work.

Offline

#55 2017-03-29 03:27:20

zkanda
Member
Registered: 2015-06-27
Posts: 6

Re: Few issues with Asus UX501VW

Hey guys, anyone able to run this laptop with kernel 4.10?

It boots up for me but when I open any settings, everything would freeze, I can't even go to other TTY.

Offline

#56 2017-04-20 18:15:23

riX2000
Member
Registered: 2013-09-11
Posts: 11

Re: Few issues with Asus UX501VW

zkanda wrote:

Hey guys, anyone able to run this laptop with kernel 4.10?

It boots up for me but when I open any settings, everything would freeze, I can't even go to other TTY.

I'm running 4.10.8, no freezes.
However I still have the headphone noise problem, and also the sd card reader is not working. (Both problems have been present since I got the laptop).

Regarding the headphones, I just noticed that the sound gets way worse when I calculate md5sums of files.. maybe this will give someone a clue.
I've saved the original windows partition, and if i boot windows everything works.

Offline

#57 2017-04-21 07:22:27

zkanda
Member
Registered: 2015-06-27
Posts: 6

Re: Few issues with Asus UX501VW

riX2000 wrote:
zkanda wrote:

Hey guys, anyone able to run this laptop with kernel 4.10?

It boots up for me but when I open any settings, everything would freeze, I can't even go to other TTY.

I'm running 4.10.8, no freezes.
However I still have the headphone noise problem, and also the sd card reader is not working. (Both problems have been present since I got the laptop).

Regarding the headphones, I just noticed that the sound gets way worse when I calculate md5sums of files.. maybe this will give someone a clue.
I've saved the original windows partition, and if i boot windows everything works.

It works for me if I don't have nvidia installed. So that means I can't play with it, I guess I can just revert back to lts linux and nvidia driver.

Offline

#58 2017-04-22 20:16:20

riX2000
Member
Registered: 2013-09-11
Posts: 11

Re: Few issues with Asus UX501VW

zkanda wrote:
riX2000 wrote:
zkanda wrote:

Hey guys, anyone able to run this laptop with kernel 4.10?

It boots up for me but when I open any settings, everything would freeze, I can't even go to other TTY.

I'm running 4.10.8, no freezes.
However I still have the headphone noise problem, and also the sd card reader is not working. (Both problems have been present since I got the laptop).

Regarding the headphones, I just noticed that the sound gets way worse when I calculate md5sums of files.. maybe this will give someone a clue.
I've saved the original windows partition, and if i boot windows everything works.

It works for me if I don't have nvidia installed. So that means I can't play with it, I guess I can just revert back to lts linux and nvidia driver.

I have nvidia 378.13, seems to work. I'm not playing a lot though. I have a vague memory of having some problems getting it to work at first, but now I haven't noticed any problem.

Offline

#59 2017-07-03 17:02:33

dakatapetrov
Member
From: Sofia, Bulgaria
Registered: 2012-01-15
Posts: 9
Website

Re: Few issues with Asus UX501VW

Hey guys,

I made a script that fixes the issues with audio after suspend. You can check it out here.

Any feedback is appreciated!

Offline

#60 2017-08-17 17:49:57

MaikuMori
Member
From: Latvia
Registered: 2013-05-29
Posts: 13
Website

Re: Few issues with Asus UX501VW

dakatapetrov wrote:

Hey guys,

I made a script that fixes the issues with audio after suspend. You can check it out here.

Any feedback is appreciated!

Will give it a try, thank you!

Offline

#61 2017-08-20 12:54:23

Epoxyc
Member
From: Japan
Registered: 2016-03-01
Posts: 18

Re: Few issues with Asus UX501VW

Thank you! I will give a try too. smile

Offline

#62 2017-11-08 05:54:43

ngkaho1234
Member
Registered: 2016-05-05
Posts: 3

Re: Few issues with Asus UX501VW

The current way I workaround the issue of white noise reappearing after suspend is to restart the audio card by first typing "sudo tee /sys/bus/pci/devices/0000:00:1f.3/remove <<< 1" in shell, and follow by "sudo tee /sys/bus/pci/rescan <<< 1"

EDIT: Please do not consider the above method. It doesn't work on linux 4.13.11. dakatapetrov's scripts work on linux 4.13.11 here, but they do not work on linux-lts.

Last edited by ngkaho1234 (2017-11-08 16:48:18)

Offline

#63 2017-12-31 06:38:49

Epoxyc
Member
From: Japan
Registered: 2016-03-01
Posts: 18

Re: Few issues with Asus UX501VW

Hey guys,
Today I bought a new SSD (WD Blue 1To) and it works perfectly. To keep using the old one I bought an external case with USB type C port.
So it was time to test the USB type C port that I never used before and it doesn't work.
It's not a problem because I can use the external disk with a regular usb port as well.
I cannot see the disk at all with an lsblk or fdisk, I will post the output of dmesg at the end of the post

Also, after reinstalling my system, I had some problem with high CPU usage by kworker. After few researches, I identified the interruption that cause this problem and
found a workaround :

echo "disable" > /sys/firmware/acpi/interrupts/gpe61

However, it works only for the current session and the problem happens randomly after boot (maybe one third of the time). It don't want to create a systemd service for a "workaround", but I will if I don't have a solution.
I haven't yet started and configured tlp and bumblebee, so the problem does not come from here.

Finally, I installed Windows as dual boot and I could test the SD card reader that works on Windows but not on Linux.

Do you have any idea for the high CPU usage by kworker (and the other things that could be fixed ?)


dmesg output when I plug the external SSD by USB type C :

[ 1315.975268] pci 0000:04:00.0: [8086:1576] type 01 class 0x060400
[ 1315.975322] pci 0000:04:00.0: enabling Extended Tags
[ 1315.975391] pci 0000:04:00.0: supports D1 D2
[ 1315.975392] pci 0000:04:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 1315.975543] iommu: Adding device 0000:04:00.0 to group 14
[ 1315.985065] pci 0000:05:00.0: [8086:1576] type 01 class 0x060400
[ 1315.985123] pci 0000:05:00.0: enabling Extended Tags
[ 1315.985213] pci 0000:05:00.0: supports D1 D2
[ 1315.985215] pci 0000:05:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 1315.985317] iommu: Adding device 0000:05:00.0 to group 15
[ 1315.985355] pci 0000:05:01.0: [8086:1576] type 01 class 0x060400
[ 1315.985413] pci 0000:05:01.0: enabling Extended Tags
[ 1315.985496] pci 0000:05:01.0: supports D1 D2
[ 1315.985497] pci 0000:05:01.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 1315.985586] iommu: Adding device 0000:05:01.0 to group 16
[ 1315.985616] pci 0000:05:02.0: [8086:1576] type 01 class 0x060400
[ 1315.985674] pci 0000:05:02.0: enabling Extended Tags
[ 1315.985759] pci 0000:05:02.0: supports D1 D2
[ 1315.985760] pci 0000:05:02.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 1315.985858] iommu: Adding device 0000:05:02.0 to group 17
[ 1315.985912] pci 0000:04:00.0: PCI bridge to [bus 05-3c]
[ 1315.985922] pci 0000:04:00.0:   bridge window [mem 0xc4000000-0xda0fffff]
[ 1315.985928] pci 0000:04:00.0:   bridge window [mem 0x80000000-0xa1ffffff 64bit pref]
[ 1315.986003] pci 0000:05:00.0: PCI bridge to [bus 06]
[ 1315.986012] pci 0000:05:00.0:   bridge window [mem 0xda000000-0xda0fffff]
[ 1315.986064] pci 0000:05:01.0: PCI bridge to [bus 07-3b]
[ 1315.986072] pci 0000:05:01.0:   bridge window [mem 0xc4000000-0xd9efffff]
[ 1315.986079] pci 0000:05:01.0:   bridge window [mem 0x80000000-0xa1ffffff 64bit pref]
[ 1315.986156] pci 0000:3c:00.0: [8086:15b5] type 00 class 0x0c0330
[ 1315.986192] pci 0000:3c:00.0: reg 0x10: [mem 0xd9f00000-0xd9f0ffff]
[ 1315.986274] pci 0000:3c:00.0: enabling Extended Tags
[ 1315.986384] pci 0000:3c:00.0: supports D1 D2
[ 1315.986386] pci 0000:3c:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 1315.986510] iommu: Adding device 0000:3c:00.0 to group 17
[ 1315.986596] pci 0000:05:02.0: PCI bridge to [bus 3c]
[ 1315.986606] pci 0000:05:02.0:   bridge window [mem 0xd9f00000-0xd9ffffff]
[ 1315.986639] pci_bus 0000:05: Allocating resources
[ 1315.986674] pci 0000:05:01.0: bridge window [io  0x1000-0x0fff] to [bus 07-3b] add_size 1000
[ 1315.986693] pci 0000:04:00.0: bridge window [io  0x1000-0x0fff] to [bus 05-3c] add_size 1000
[ 1315.986698] pci 0000:04:00.0: BAR 13: assigned [io  0x2000-0x2fff]
[ 1315.986702] pci 0000:05:01.0: BAR 13: assigned [io  0x2000-0x2fff]
[ 1315.986704] pci 0000:05:00.0: PCI bridge to [bus 06]
[ 1315.986711] pci 0000:05:00.0:   bridge window [mem 0xda000000-0xda0fffff]
[ 1315.986721] pci 0000:05:01.0: PCI bridge to [bus 07-3b]
[ 1315.986724] pci 0000:05:01.0:   bridge window [io  0x2000-0x2fff]
[ 1315.986730] pci 0000:05:01.0:   bridge window [mem 0xc4000000-0xd9efffff]
[ 1315.986735] pci 0000:05:01.0:   bridge window [mem 0x80000000-0xa1ffffff 64bit pref]
[ 1315.986743] pci 0000:05:02.0: PCI bridge to [bus 3c]
[ 1315.986749] pci 0000:05:02.0:   bridge window [mem 0xd9f00000-0xd9ffffff]
[ 1315.986758] pci 0000:04:00.0: PCI bridge to [bus 05-3c]
[ 1315.986762] pci 0000:04:00.0:   bridge window [io  0x2000-0x2fff]
[ 1315.986767] pci 0000:04:00.0:   bridge window [mem 0xc4000000-0xda0fffff]
[ 1315.986772] pci 0000:04:00.0:   bridge window [mem 0x80000000-0xa1ffffff 64bit pref]
[ 1315.986933] pcieport 0000:04:00.0: enabling device (0006 -> 0007)
[ 1315.987518] pcieport 0000:05:01.0: enabling device (0006 -> 0007)
[ 1315.988269] xhci_hcd 0000:3c:00.0: xHCI Host Controller
[ 1315.988278] xhci_hcd 0000:3c:00.0: new USB bus registered, assigned bus number 3
[ 1315.989599] xhci_hcd 0000:3c:00.0: hcc params 0x200077c1 hci version 0x110 quirks 0x00009810
[ 1315.989976] hub 3-0:1.0: USB hub found
[ 1315.989989] hub 3-0:1.0: 2 ports detected
[ 1315.990426] xhci_hcd 0000:3c:00.0: xHCI Host Controller
[ 1315.990432] xhci_hcd 0000:3c:00.0: new USB bus registered, assigned bus number 4
[ 1315.990436] xhci_hcd 0000:3c:00.0: Host supports USB 3.1 Enhanced SuperSpeed
[ 1315.990807] hub 4-0:1.0: USB hub found
[ 1315.990820] hub 4-0:1.0: 2 ports detected

Offline

Board footer

Powered by FluxBB