You are not logged in.

#1 2018-01-04 13:35:15

d7
Member
Registered: 2017-12-23
Posts: 11

systemd reboot/shutdown messages

Hello guys! How to completely disable systemd messages during shutdown or reboot, like "reboot: Restarting system" and "reboot: Power down" ?

Offline

#2 2018-01-04 13:38:10

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,380

Re: systemd reboot/shutdown messages

Have you done everything mentioned here?

I know the article is for silent boot but the methods it contains effect shutdown messages as well.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2018-01-04 13:59:09

d7
Member
Registered: 2017-12-23
Posts: 11

Re: systemd reboot/shutdown messages

slithery wrote:

Have you done everything mentioned here?

Yes, but "reboot: Restarting system" and "reboot: Power down" messages are displayed anyway.

Offline

#4 2018-01-04 22:24:41

d7
Member
Registered: 2017-12-23
Posts: 11

Re: systemd reboot/shutdown messages

"reboot: Restarting system", "reboot: Power down"

systemd 233 don't have this messages.
This messages disable plymouth splash, and I need to know how disable them.

Maybe, exists solution to ignore systemd messages for plymouth (sorry for offtop) ?

Last edited by d7 (2018-01-04 22:30:54)

Offline

#5 2018-01-05 16:13:45

c00ter
Member
From: Alaskan in Washington State
Registered: 2014-08-28
Posts: 269

Re: systemd reboot/shutdown messages

d7 wrote:

systemd 233 don't have this messages.

What? Arch has been on Systemd 236 since mid-December. Either: A) your system is badly out of date, or  B) you're not running Archlinux, or  C) you downgraded and held 233 quite some time ago and, if so, this may be leading into your woes. Probably not, given your (less than) descriptive posts.

EDIT: After re-reading the posts, I defer to the very experienced interpretive powers of @slithery. Post amended.

OP, please be more detailed in your descriptions, if possible, so that I can better help. Logs would be helpful.

Last edited by c00ter (2018-01-05 16:21:28)


UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things. -- Doug Gwyn

Offline

#6 2018-01-05 16:15:21

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,380

Re: systemd reboot/shutdown messages

I believe what the OP is saying is that this wasn't an issue with 233, but has been with all later versions. Not that they are running 233.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2018-01-05 16:55:43

d7
Member
Registered: 2017-12-23
Posts: 11

Re: systemd reboot/shutdown messages

slithery wrote:

I believe what the OP is saying is that this wasn't an issue with 233, but has been with all later versions

Yes, in new versions systemd got "reboot: Restarting system" and "reboot: Power down" messаges, which can not be disabled. I'm just need to know how to disable them.

Offline

#8 2018-03-15 10:36:07

Malzbier
Member
Registered: 2018-03-15
Posts: 1

Re: systemd reboot/shutdown messages

I have the same issue and did not find out how to disable those messages so far.
Did you find the solution yet? If you did would you mind posting it?

Offline

Board footer

Powered by FluxBB