You are not logged in.

#1 2018-01-08 08:57:49

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 9

gpg: keyserver receive failed: No name

pacman fails to download keys

$ pacman -Syu
...
:: Proceed with installation? [Y/n] 
(24/24) checking keys in keyring                                [##################################] 100%
downloading required keys...
error: key "CEB167EFB5722BD6" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

The problem seems to be gpg, but I don't know what to make of this "no name" error.

$ gpg --debug-level guru --keyserver hkp://keys.gnupg.net --search-keys CEB167EFB5722BD6
gpg: enabled debug flags: packet mpi crypto filter iobuf memory cache memstat trust hashing ipc clock lookup extprog
gpg: DBG: [not enabled in the source] start
gpg: DBG: chan_3 <- # Home: /home/walz/.gnupg
gpg: DBG: chan_3 <- # Config: /home/walz/.gnupg/dirmngr.conf
gpg: DBG: chan_3 <- OK Dirmngr 2.2.4 at your service
gpg: DBG: connection to the dirmngr established
gpg: DBG: chan_3 -> GETINFO version
gpg: DBG: chan_3 <- D 2.2.4
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> KEYSERVER --clear hkp://keys.gnupg.net
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> KS_SEARCH -- CEB167EFB5722BD6
gpg: DBG: chan_3 <- ERR 167772380 No name <Dirmngr>
gpg: error searching keyserver: No name
gpg: keyserver search failed: No name
gpg: DBG: chan_3 -> BYE
gpg: DBG: [not enabled in the source] stop
gpg: keydb: handles=0 locks=0 parse=0 get=0
gpg:        build=0 update=0 insert=0 delete=0
gpg:        reset=0 found=0 not=0 cache=0 not=0
gpg: kid_not_found_cache: count=0 peak=0 flushes=0
gpg: sig_cache: total=0 cached=0 good=0 bad=0
gpg: random usage: poolsize=600 mixed=0 polls=0/0 added=0/0
              outmix=0 getlvl1=0/0 getlvl2=0/0
gpg: rndjent stat: collector=0x0000000000000000 calls=0 bytes=0
gpg: secmem usage: 0/32768 bytes in 0 blocks

Last edited by walz (2018-01-08 17:14:24)

Offline

#2 2018-01-08 09:34:05

a821
Member
From: My Location
Registered: 2012-10-31
Posts: 70

Re: gpg: keyserver receive failed: No name

Did you search the key "abc" instead of "CEB167EFB5722BD6"? It works for me.

can you run "pacman -Syu" again? and post full output. maybe is a temporary issue with the server.

check also the wiki https://wiki.archlinux.org/index.php/Pa … leshooting

Last edited by a821 (2018-01-08 09:41:20)

Offline

#3 2018-01-08 10:59:23

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 9

Re: gpg: keyserver receive failed: No name

Yes, I searched for the key as well, and it doesn't seem to be a temporary issue.
I added all relevant lines of "pacman -Syu" above.

Offline

#4 2018-01-08 11:21:08

Eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 1,418

Re: gpg: keyserver receive failed: No name

You can try changing the gpg.conf of your pacman-key keyring in /etc/pacman.d/gnupg/ to use the hkps:// keyserver instead of the hkp:// keyserver, since hkps runs over the common 443 port also used for HTTPS.

Alternatively, install the archlinux-keyring package from testing as it contains my new signing key also.

Last edited by Eschwartz (2018-01-08 12:11:21)

Offline

#5 2018-01-08 11:55:53

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 9

Re: gpg: keyserver receive failed: No name

I got the same uninformative "gpg: error searching keyserver: No name" error with hkps:// keyserver specified in /etc/pacman.d/gnupg/gpg.conf and via --keyserver

Installing archlinux-keyring from testing fixed my pacman issue.
Thanks!

Offline

#6 2018-01-08 14:33:34

rogorido
Member
Registered: 2009-08-17
Posts: 105

Re: gpg: keyserver receive failed: No name

is there a way to solve this problem without installing the package from testing?

Offline

#7 2018-01-08 14:43:21

slithery
Member
Registered: 2013-12-01
Posts: 2,203

Re: gpg: keyserver receive failed: No name

You can install the package from testing without having to enable the [testing] repo, archlinux-keyring is one of the few packages where this is safe to do.

pacman -U http://mirror2.f4st.host/archlinux/testing/os/x86_64/archlinux-keyring-20180108-1-any.pkg.tar.xz

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan

aur - dotfiles

Offline

#8 2018-01-08 14:54:07

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,430

Re: gpg: keyserver receive failed: No name

The real fix is to fix gpg. I have no idea what the "No name" error is, you'd probably want to talk to upstream.

Offline

#9 2018-01-08 15:02:58

jdevelop
Member
Registered: 2014-04-18
Posts: 23

Re: gpg: keyserver receive failed: No name

for me - the problem was solved after I re-enabled IPv6 once I realized that
`pacman-key --refresh-keys`

fails with the error

`keyserver refresh failed: Address family not supported by protocol`

Offline

#10 2018-01-08 15:30:28

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 9

Re: gpg: keyserver receive failed: No name

That's a different problem from mine

$ pacman-key --refresh-keys 
gpg: refreshing 100 keys from hkps://pool.sks-keyservers.net
gpg: keyserver refresh failed: No name
==> ERROR: A specified local key could not be updated from a keyserver.

Offline

#11 2018-01-08 15:41:24

rogorido
Member
Registered: 2009-08-17
Posts: 105

Re: gpg: keyserver receive failed: No name

slithery wrote:

You can install the package from testing without having to enable the [testing] repo, archlinux-keyring is one of the few packages where this is safe to do.

pacman -U http://mirror2.f4st.host/archlinux/testing/os/x86_64/archlinux-keyring-20180108-1-any.pkg.tar.xz

Thanks. This works.

Offline

#12 2018-01-08 15:56:46

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,430

Re: gpg: keyserver receive failed: No name

Yeah, it works until the next time. Fix gpg.

Offline

#13 2018-01-08 17:10:36

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 161

Re: gpg: keyserver receive failed: No name


I don't really know what I'm doing.

Offline

#14 2018-01-08 17:13:44

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 9

Re: gpg: keyserver receive failed: No name

opened upstream https://dev.gnupg.org/T3722

Offline

#15 2018-01-08 21:21:48

maxchaos
Member
Registered: 2017-09-24
Posts: 6

Re: gpg: keyserver receive failed: No name

Hi,

I also get the exact same error when running "pacman -Syu" on one of my machines (strangely, my desktop was updated without an issue), though, in my case, the error message I get from running "pacman-key --refresh-keys" complains that no keyserver is available:

# pacman-key --refresh-keys
gpg: refreshing 99 keys from hkp://ipv4.pool.sks-keyservers.net:11371
gpg: keyserver refresh failed: No keyserver available
==> ERROR: A specified local key could not be updated from a keyserver.

Using keyring from testing also resolved my case.

Last edited by maxchaos (2018-01-08 21:22:31)

Offline

#16 2018-01-09 00:50:22

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,430

Re: gpg: keyserver receive failed: No name

walz,  can you post your nsswitch.conf?

Offline

#17 2018-01-09 00:58:09

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,333

Re: gpg: keyserver receive failed: No name

I had the exact same error during -Syu

downloading required keys...
error: key "CEB167EFB5722BD6" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)

So I switched keyserver to keyserver hkp://pgp.mit.edu:11371 as suggested in the wiki
And the -Syu completed successfully

downloading required keys...
:: Import PGP key 4096R/BD27B07A5EF45C2ADAF70E0484818A6819AF4A9B, "Eli Schwartz <eschwartz93@gmail.com>", created: 2016-05-04? [Y/n] Y

Online

#18 2018-01-09 01:40:32

372046933
Member
Registered: 2016-04-22
Posts: 1

Re: gpg: keyserver receive failed: No name

Same issue here.

~~~~
downloading required keys...
error: key "CEB167EFB5722BD6" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
~~~~

Offline

#19 2018-01-09 02:52:05

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 24,127
Website

Re: gpg: keyserver receive failed: No name

Rather than bumping the thread with an empty post, did you try changing the keyserver?
https://wiki.archlinux.org/index.php/Co … mpty_posts


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#20 2018-01-09 04:36:08

cappuccino
Member
Registered: 2012-12-26
Posts: 71

Re: gpg: keyserver receive failed: No name

For me hkps://hkps.pool.sks-keyservers.net:443 works fine

Offline

#21 2018-01-09 07:08:27

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 9

Re: gpg: keyserver receive failed: No name

Scimmia wrote:

walz,  can you post your nsswitch.conf?

Nothing special here.

$ cat /etc/nsswitch.conf
passwd: files mymachines systemd
group: files mymachines systemd
shadow: files

publickey: files

hosts: files mymachines resolve [!UNAVAIL=return] dns myhostname
networks: files

protocols: files
services: files
ethers: files
rpc: files

netgroup: files

Offline

#22 2018-01-09 08:57:22

kayaman
Member
Registered: 2012-09-03
Posts: 11

Re: gpg: keyserver receive failed: No name

Hey,
Didn't help:
* reinstall keyering
* refreshing keys
* changing Keyserver

shifted the brokeness one space to the right (Did fix it):

slithery wrote:

You can install the package from testing without having to enable the [testing] repo, archlinux-keyring is one of the few packages where this is safe to do.

pacman -U http://mirror2.f4st.host/archlinux/testing/os/x86_64/archlinux-keyring-20180108-1-any.pkg.tar.xz

Offline

#23 2018-01-09 14:33:57

pittix
Member
Registered: 2017-10-04
Posts: 3

Re: gpg: keyserver receive failed: No name

cappuccino wrote:

For me hkps://hkps.pool.sks-keyservers.net:443 works fine

This worked for me: almost certainly I had an old keyserver.

Thanks cappuccino and everybody else!

my gpg.conf

no-greeting
no-permission-warning
lock-never
#keyserver hkp://pool.sks-keyservers.net
keyserver  hkps://hkps.pool.sks-keyservers.net:443

Last edited by pittix (2018-01-09 14:36:19)

Offline

#24 2018-01-09 18:58:52

Eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 1,418

Re: gpg: keyserver receive failed: No name

Funnily enough, hkps://hkps.pool.sks-keyservers.net:443 is the default if keyserver is not specified. See https://bugs.archlinux.org/task/55278

Offline

#25 2018-01-13 14:13:27

2ion
Member
Registered: 2013-04-19
Posts: 86

Re: gpg: keyserver receive failed: No name

hkps://hkps.pool.sks-keyservers.net:443 works fine

This setting in /etc/pacman.d/gnupg/gpg.conf, a subsequent `pacman-key --refresh-keys` and a final `pacman -Syu` resolved the issue for me; the last pacman command then asked whether to import key BD27B07A5EF45C2ADAF70E0484818A6819AF4A9B and proceeded normally. No sideloading of the testing package needed.

Offline

Board footer

Powered by FluxBB