You are not logged in.

#1 2017-12-22 22:13:49

Moret84
Member
Registered: 2014-02-27
Posts: 11

Network Manager does not autoconnect to wifi

Hello,

I use KDE5 (Plasma) and I have recently upgraded my laptop (I hadn't upgraded for a longtime). I have an issue with network manager that does not auto connect to my wifi network. I have to click on connect in the nm-applet every time I log in. This laptop is used as a desktop PC: he never moves and therefore is always connected to te same wifi network. Once "connect" is clicked, the connection works fine.
I looked at the network manager logs and it seems the connection attempt right after login is failing becaue NM can't retrieve password from keyring system.

déc. 22 22:51:52 vieuxmort NetworkManager[342]: <info>  [1513979512.4683] device (wlp3s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')

But I don't understand why because I use kwallet and it should unlock the keyring as soon as I log in.  Also, all was working fine before the upgrade.

Could someone help ?

Offline

#2 2017-12-23 12:29:58

hopimet
Member
Registered: 2013-09-01
Posts: 5

Re: Network Manager does not autoconnect to wifi

Hello,

There is a bug, for KDE users, in the last version of networkmanager. You can downgrade to the previous version and wait for a bug fix (this is a workaround, not a solution)
https://bugs.archlinux.org/task/56746?

Offline

#3 2017-12-23 12:44:48

Moret84
Member
Registered: 2014-02-27
Posts: 11

Re: Network Manager does not autoconnect to wifi

Hi thanks for your reply. I didn't know for the bug. I will follow for any fix.
I managed to workaround by selecting "all users (no encryption") for the security type of my Wifi key.

Offline

#4 2018-01-25 11:07:50

kosmosoahc
Member
Registered: 2018-01-25
Posts: 1

Re: Network Manager does not autoconnect to wifi

I found a solution that worked for me -- 1 Go to the Setting ; 2 Go Network,Connection ; 3 Find General configuration, Set All users may connect to this network on ; 4 And Wi-Fi Security, Change Store password for this user only (encrypted) To Store password for all users (not encrypted) ; 5 Apply, Reboot and should be autoconnect again.

Offline

Board footer

Powered by FluxBB