You are not logged in.

#1 2018-02-12 08:03:21

i_love_r34
Member
From: Mexico
Registered: 2016-02-14
Posts: 77

[SOLVED] No sound with waterfox

Hello to everyone!

Recently I plug in a HDMI cable but after that, the sound of waterfox doesn't work anymore with pulseaudio, before that everything worked fine. The only way I found to play sound is disabling the card on pavucontrol and the sound is so ugly (lag and noise). I don't know what is happening here.
I'm using the latest version of waterfox from aur (waterfox-bin).
This only happens with waterfox because firefox and vlc works fine.
And I'm using the default config files of pulseaudio.

This is the output of fuser in /dev/snd when waterfox use the card:

fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  duran      5751 F.... pulseaudio
                     duran      8823 F.... Web Content
/dev/snd/pcmC0D0c:   duran      5751 F...m pulseaudio
/dev/snd/pcmC0D0p:   duran      8823 F...m Web Content
/dev/snd/pcmC0D3p:   duran      5751 F...m pulseaudio
/dev/snd/timer:      duran      8823 f.... Web Content

The output of fuser without waterfox with the card enabled:

fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  duran      5751 F.... pulseaudio
/dev/snd/pcmC0D0p:   duran      5751 F...m pulseaudio

I tried reinstalling waterfox, changing profiles, deleting the ~/.config/pulse directory, rebooting and reinstalling pulseaudio; but nothing worked.

Regards!

Last edited by i_love_r34 (2018-02-16 05:09:22)

Offline

#2 2018-02-12 09:19:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,596

Re: [SOLVED] No sound with waterfox

It looks like the bin version doesn't have pulse support compiled in, you will have to make it use the ALSA -> pulse redirection and install pulseaudio-alsa in order to set up an /etc/asound.conf to that effect.

Can you post the contents of

about:buildconfig

?

Mod note: Moving to AUR issues.

Last edited by V1del (2018-02-12 09:38:28)

Offline

#3 2018-02-12 09:29:15

robg
Member
Registered: 2015-03-05
Posts: 142

Re: [SOLVED] No sound with waterfox

I am not using a HDMI cable for sound output myself, but this suggests that - depending on your graphics stack - it might not be quite as straight-forward as one would assume. I suggest the following.

1. Consult the linked wiki entry, if you haven't already; see if the situation applies to you (and if so, try the suggested solution).
2. If sound worked before, identify the point in time where things started turning sour and post the corresponding entries of your pacman log.

Offline

#4 2018-02-12 09:40:01

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,596

Re: [SOLVED] No sound with waterfox

@robg It looks like that works fine, the problem right now is that Waterfox isn't using pulseaudio.

Offline

#5 2018-02-12 09:56:05

robg
Member
Registered: 2015-03-05
Posts: 142

Re: [SOLVED] No sound with waterfox

I was not aware of that, thank you for pointing this out (I missed your first post). In this case I wholeheartedly support your suggested solution via pulseaudio-alsa.

Offline

#6 2018-02-13 03:13:24

i_love_r34
Member
From: Mexico
Registered: 2016-02-14
Posts: 77

Re: [SOLVED] No sound with waterfox

V1del wrote:

It looks like the bin version doesn't have pulse support compiled in, you will have to make it use the ALSA -> pulse redirection and install pulseaudio-alsa in order to set up an /etc/asound.conf to that effect.

Can you post the contents of

about:buildconfig

?

Mod note: Moving to AUR issues.

The package of pulseaudio-alsa is already installed in my system, and I never touched that file so the contents are the same like the asound.conf provided by the package.

[duran@illuminati ~]$ pacman -Qe | grep pulseaudio
pulseaudio 11.1-1
pulseaudio-alsa 2-3
pulseaudio-bluetooth 11.1-1

On the other hand, this is the output of about:buildconfig:

target
x86_64-pc-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
/usr/bin/ccache /usr/bin/clang -std=gnu99 	3.8.1 	-Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wclass-varargs -Wloop-analysis -Wstring-conversion -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wno-gnu-zero-variadic-macro-arguments -Wformat-security -fno-strict-aliasing -fno-math-errno -pthread -pipe
/usr/bin/ccache /usr/bin/clang++ -std=gnu++11 	3.8.1 	-Qunused-arguments -Qunused-arguments -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wloop-analysis -Wc++11-compat-pedantic -Wc++14-compat -Wc++14-compat-pedantic -Wc++1z-compat -Wimplicit-fallthrough -Wstring-conversion -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wno-gnu-zero-variadic-macro-arguments -Wformat-security -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-exceptions -fno-strict-aliasing -static-libstdc++ -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -O3 -fomit-frame-pointer
Configure options

--target=x86_64-pc-linux-gnu --enable-application=browser --enable-update-channel=release --disable-tests --with-ccache=ccache CC=clang CXX=clang++ MAKE=/usr/bin/make --enable-alsa --disable-crashreporter --disable-maintenance-service --enable-optimize --enable-pulseaudio --disable-signmar --enable-updater --disable-verify-mar --with-app-basename=Waterfox --with-app-name=waterfox --with-branding=browser/branding/unofficial --with-distribution-id=org.waterfoxproject

I think that if I compile waterfox without alsa the things will go nice?

Offline

#7 2018-02-13 07:39:38

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,596

Re: [SOLVED] No sound with waterfox

No it technically should already have pulse support, but maybe something went wrong on their buildbot, or there is some strange config on your system. Are you starting waterfox in a startup script somewhere that might run before pulse has started? What are the outputs of

loginctl show-session $XDG_SESSION_ID
systemctl --user status pulseaudio

Offline

#8 2018-02-13 20:23:43

i_love_r34
Member
From: Mexico
Registered: 2016-02-14
Posts: 77

Re: [SOLVED] No sound with waterfox

I don't have any script in my system that uses waterfox.
These are the outputs:

[duran@illuminati ~]$ loginctl show-session $XDG_SESSION_ID
Id=2
User=1000
Name=duran
Timestamp=Tue 2018-02-13 00:16:16 PST
TimestampMonotonic=94835164
VTNr=7
Seat=seat0
Display=:0
Remote=no
Service=sddm
Desktop=XFCE
Scope=session-2.scope
Leader=1050
Audit=2
Type=x11
Class=user
Active=yes
State=active
IdleHint=no
IdleSinceHint=1518551852622300
IdleSinceHintMonotonic=42170934129
LockedHint=no
[duran@illuminati ~]$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-02-13 00:16:20 PST; 11h ago
 Main PID: 1084 (pulseaudio)
   CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
           └─1084 /usr/bin/pulseaudio --daemonize=no

Feb 13 00:16:19 illuminati systemd[1051]: Starting Sound Service...
Feb 13 00:16:20 illuminati systemd[1051]: Started Sound Service.
Feb 13 00:16:20 illuminati pulseaudio[1084]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.

I will try to compile and old version of waterfox-git from aur, maybe that will work.

Offline

#9 2018-02-14 03:50:01

i_love_r34
Member
From: Mexico
Registered: 2016-02-14
Posts: 77

Re: [SOLVED] No sound with waterfox

Recently trying to find something I see that everytime waterfox start when pulseaudio is using the sound card, pulseaudio crash, this is the output from journalctl:

Feb 13 19:44:02 illuminati systemd[1051]: pulseaudio.service: Main process exited, code=killed, status=6/ABRT
Feb 13 19:44:02 illuminati systemd[1051]: pulseaudio.service: Failed with result 'signal'.
Feb 13 19:44:02 illuminati systemd[1051]: pulseaudio.service: Service hold-off time over, scheduling restart.
Feb 13 19:44:02 illuminati systemd[1051]: pulseaudio.service: Scheduled restart job, restart counter is at 2.
Feb 13 19:44:02 illuminati systemd[1051]: Stopped Sound Service.
Feb 13 19:44:02 illuminati systemd[1051]: Starting Sound Service...
Feb 13 19:44:02 illuminati rtkit-daemon[1085]: Successfully made thread 7281 of process 7281 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level -11.
Feb 13 19:44:02 illuminati rtkit-daemon[1085]: Supervising 1 threads of 1 processes of 1 users.
Feb 13 19:44:02 illuminati pulseaudio[7281]: W: [pulseaudio] pid.c: Stale PID file, overwriting.
Feb 13 19:44:02 illuminati systemd-coredump[7264]: Process 6932 (pulseaudio) of user 1000 dumped core.
                                                   
                                                   Stack trace of thread 7168:
                                                   #0  0x00007f2c13c00860 raise (libc.so.6)
                                                   #1  0x00007f2c13c01ec9 abort (libc.so.6)
                                                   #2  0x00007f2c0afd7135 n/a (libalsa-util.so)
                                                   #3  0x00007f2c14cdf81c n/a (libpulsecommon-11.1.so)
                                                   #4  0x00007f2c1418e08c start_thread (libpthread.so.0)
                                                   #5  0x00007f2c13cc1e7f __clone (libc.so.6)
                                                   
                                                   Stack trace of thread 6932:
                                                   #0  0x00007f2c13cb7a76 ppoll (libc.so.6)
                                                   #1  0x00007f2c14f31c53 pa_mainloop_poll (libpulse.so.0)
                                                   #2  0x00007f2c14f32271 pa_mainloop_iterate (libpulse.so.0)
                                                   #3  0x00007f2c14f32301 pa_mainloop_run (libpulse.so.0)
                                                   #4  0x000055b010d19d76 main (pulseaudio)
                                                   #5  0x00007f2c13becf4a __libc_start_main (libc.so.6)
                                                   #6  0x000055b010d1a44a _start (pulseaudio)
Feb 13 19:44:03 illuminati dbus-daemon[796]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service' requested by ':1.10967' (uid=1000 pid=7281 comm="/usr/bin/
Feb 13 19:44:03 illuminati dbus-daemon[796]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service not found.
Feb 13 19:44:03 illuminati pulseaudio[7281]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.
Feb 13 19:44:03 illuminati systemd[1051]: Started Sound Service.

Offline

#10 2018-02-16 05:08:53

i_love_r34
Member
From: Mexico
Registered: 2016-02-14
Posts: 77

Re: [SOLVED] No sound with waterfox

After some try and failure I found a solution!

Here is the solution that worked for me:
First delete the directory pulse in $HOME/.config/, after that remove pulseaudio and alsa-lib without their dependencies, then kill the pulseaudio daemon and unload all the modules or reboot, deny waterfox to read and write /dev/snd (I used apparmor), then install pulseaudio and alsa-lib and finally start pulseaudio.

I would like to add like an observation that waterfox try to use /dev/snd after I unplug the HDMI cable and I don't know why; and without the step of deny waterfox to write and read /dev/snd, the behavior of using directly the card keeps going.

Thanks for the help guys.
And don't use waterfox when you unplug the hdmi cable!

Offline

#11 2018-02-16 07:53:10

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,596

Re: [SOLVED] No sound with waterfox

That... reads weird, why does it even try to do that? Very strange.

Offline

Board footer

Powered by FluxBB