You are not logged in.

#1 2018-02-13 07:48:59

shved
Member
Registered: 2012-12-11
Posts: 52

[SOLVED] Apulse: unable to open slave

After new system upgrade I have next issue with apulse and firefox:

>  apulse /usr/bin/firefox
ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
[apulse] [error] do_connect_pcm: can't open playback device "default". Error code -2 (No such file or directory)
[apulse] [error] do_connect_pcm: can't open playback device "default". Error code -2 (No such file or directory)
[apulse] [error] do_connect_pcm: failed to open ALSA device. Apulse does no resampling or format conversion, leaving that task to ALSA plugins. Ensure that selected device is capable of playing a particular sample format at a particular rate. They have to be supported by either hardware directly, or by "plug" and "dmix" ALSA plugins which will perform required conversions on CPU.
[apulse] [error] do_connect_pcm: failed to open ALSA device. Apulse does no resampling or format conversion, leaving that task to ALSA plugins. Ensure that selected device is capable of playing a particular sample format at a particular rate. They have to be supported by either hardware directly, or by "plug" and "dmix" ALSA plugins which will perform required conversions on CPU.
[Child 23662, MediaPlayback #2] WARNING: 7fad467e0880 OpenCubeb() failed to init cubeb: file /build/firefox/src/mozilla-unified/dom/media/AudioStream.cpp, line 387
[Child 23662, MediaPlayback #3] WARNING: Decoder=7fad45ef6800 [OnMediaSinkAudioError]: file /build/firefox/src/mozilla-unified/dom/media/MediaDecoderStateMachine.cpp, line 3642
[Child 23662, MediaPlayback #3] WARNING: Decoder=7fad45ef6800 Decode error: NS_ERROR_DOM_MEDIA_MEDIASINK_ERR (0x806e000b) - OnMediaSinkAudioError: file /build/firefox/src/mozilla-unified/dom/media/MediaDecoderStateMachine.cpp, line 3365

other applications works fine:

>  speaker-test -c2

speaker-test 1.1.5

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2229 to 4458
Period size range from 1114 to 1115
Using max buffer size 4456
Periods = 4
was set period_size = 1114
was set buffer_size = 4458
 0 - Front Left
 1 - Front Right

Here is packages info:

>  pacman -Qi apulse alsa-lib
Name            : apulse
Version         : 0.1.10-1
Description     : PulseAudio emulation for ALSA
Architecture    : x86_64
URL             : https://github.com/i-rinat/apulse
Licenses        : custom:MIT
Groups          : None
Provides        : None
Depends On      : alsa-lib  glib2
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 143.00 KiB
Packager        : Unknown Packager
Build Date      : Thu 08 Feb 2018 04:36:54 PM MSK
Install Date    : Thu 08 Feb 2018 04:37:05 PM MSK
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : None

Name            : alsa-lib
Version         : 1.1.5-1
Description     : An alternative implementation of Linux sound support
Architecture    : x86_64
URL             : http://www.alsa-project.org
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : glibc
Optional Deps   : python2: for python smixer plugin [installed]
Required By     : alsa-plugins  alsa-utils  apulse  bluez  chromium  ffmpeg  ffmpeg2.8  gst-plugins-base  lib32-alsa-lib  libao  libcanberra  libsndfile  lirc  mpg123  qt4  skypeforlinux-bin  steam-native-runtime  thunderbird  wildmidi  zita-alsa-pcmi
Optional For    : gimp  jre8-openjdk  sdl  sdl2  v4l-utils  wine  xmms2
Conflicts With  : None
Replaces        : None
Installed Size  : 1954.00 KiB
Packager        : Anatol Pomozov <anatol.pomzov@gmail.com>
Build Date      : Wed 15 Nov 2017 01:20:44 AM MSK
Install Date    : Thu 14 Dec 2017 11:42:10 AM MSK
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

And here is my .asoundrc:

>  cat ~/.asoundrc
#The default device:
pcm.!default {
        type plug
        slave.pcm "asymed"
}

#The controlled device
ctl.!default {
        type hw
        card PCH
}

#Make two channels to work together
pcm.asymed {
    type asym
    playback.pcm "dmixer"
    capture.pcm "microphone"
}

#The audio output
pcm.dmixer {
        type dmix
        ipc_key 1024
        slave {
                pcm "hw:PCH,0"
                period_time 0
                period_size 1024
                buffer_size 4096
                rate 44100
        }
        bindings {
                0 0
                1 1
        }
}

#The audio input
pcm.microphone
{
    type hw
    card PCH
}

The config was prepared by me a couple of years ago, so I hardly can explain some of its places.

Can some one explain me how to debug this issue (e.g. make alsa-lib to be more verbose). Or have someone good thoughts on subject?

Thank you!

Last edited by shved (2018-02-19 08:54:23)


Sorry for my english

Offline

#2 2018-02-19 08:53:45

shved
Member
Registered: 2012-12-11
Posts: 52

Re: [SOLVED] Apulse: unable to open slave

Fixed by another upgrade


Sorry for my english

Offline

Board footer

Powered by FluxBB