You are not logged in.

#1 2018-03-08 12:44:49

thelongdivider
Member
Registered: 2013-11-09
Posts: 50

Gnome on wayland with modeline configuration

I have a Qnix 27 inch 2560x1440 monitor that I have been using with my Intel powered laptop.  I can get it to be recognized with the following xorg.conf:

Section "Monitor"
    Identifier     "HDMI1"
    VendorName     "QNIX"
    ModelName      "2710"
    HorizSync       88.8
    VertRefresh     59.5
    # 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
    Modeline "2560x1440"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
    # Modeline       "2560x1440_60"  312.25 2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
    DisplaySize 597 336
    Option         "DPMS"
    Option "LeftOf" "eDP1"
    Option "UseEDID" "False"
    Option "UseEDIDDPI" "False"
    Option "UseEDIDFreqs" "False"
    Option "ExactModeTimingsDVI" "True
EndSection

However, this only works when setting /etc/gdm/custom.conf to force wayland to be disabled.

So my question is can you apply a modeline operation in a wayland configuration?

Offline

#2 2018-03-08 12:57:12

progandy
Member
Registered: 2012-05-17
Posts: 3,080

Re: Gnome on wayland with modeline configuration

Most likely you have to create an edid file and load it during boot:
https://wiki.archlinux.org/index.php/Ke … s_and_EDID

To create the edid file, this might help:
https://askubuntu.com/a/973582

Last edited by progandy (2018-03-08 12:59:22)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#3 2018-03-08 14:53:02

thelongdivider
Member
Registered: 2013-11-09
Posts: 50

Re: Gnome on wayland with modeline configuration

progandy wrote:

Most likely you have to create an edid file and load it during boot:
https://wiki.archlinux.org/index.php/Ke … s_and_EDID

To create the edid file, this might help:
https://askubuntu.com/a/973582

I followed the procedure, but I am having no luck booting into gdm on wayland.

Offline

Board footer

Powered by FluxBB