You are not logged in.

#1 2018-03-08 01:18:11

wandel
Member
Registered: 2018-03-07
Posts: 2

[SOLVED] Dead Keys don't work on Libreoffice when using plasma Desktop

Hello there,

I can't use dead keys to add accentuation in libreoffice. The problem appear only when libreoffice is used, in all other applications it works just fine.
Here it works as expected and I can type "ã" and "ê". These are the characteres I miss the most, because the only alternative is the insert special character in libreoffice. I can add other characteres in alternative ways, for example "é" can be typed by alt+e, but  "ã" and "ê" are the real problems, very important to write in my language.

The strangest thing is that it happens when I'm using KDE plasma, but I tried Gnome and it worked normally. But man, I really would like to keep using plasma.

I'm running Arch Linux in a Dell XPS 13 laptop, and KDE plasma on X11. The issue happens when using both libreoffice-fresh and libreoffice-still.

Here what I've tried so far:

- First of all, I also have Arch installed on other laptop, and it works just fine. The keyboard layout of the laptop is different though.
- I tried setting the keyboard using the KDE system setting. I choose "US english international with dead keys".
- I tried setting the keyboard layout using loadkeys and choosing de-latin1. It loaded the layout, but didn't work as well.
- I installed gnome desktop, which I didn't want to do, but as I have it in the other laptop (that works) I decided to give it a shot. As I said, works when I use Gnome, but changes nothing when I use KDE.
- Tried to change the locale. As I like to use my leisure time to practice english, I like to keep my computer in english, but I found many suggestions to set the system and libreoffice to portuguese. Altought I thought it was kind nonsense, I tried and it didn't work.
- I Searched the web a lot. I saw many topics about this in a lot of forums, but most were abandoned with no solutions.
- The most relevant discussion about this issue I found was this one: https://bugs.documentfoundation.org/sho … d_from=fdo
I tried the solution describe on comment 6 (unset XMODIFIERS && libreoffice4.2 &), changed the libreoffice4.2 to just libreoffice, and I've got the following output:

[1] 3630
[wandeledani@wandeledani ~]$ I18N: Operating system doesn't support locale ""
I18N: Operating system doesn't support locale "en_US"

After that openoffice opens, but the problem persists.

My /etc/X11/xorg.conf.d/00-keyboard.conf says the following:
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbVariant" "intl"
EndSection

Can anybody point me a way to solve this? Any help will be much appreciated, as I really enjoy using KDE and don't want to go back to Gnome. And sorry for the bad english.

Last edited by wandel (2018-03-08 22:13:40)

Offline

#2 2018-03-08 08:46:02

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,676

Re: [SOLVED] Dead Keys don't work on Libreoffice when using plasma Desktop

Which libreoffice UI backend are you using? Afaik on KDE/Plasma libreoffice still defaults to the Qt4 UI which hasn't been maintained in ages, change that to GTK3 or so: https://wiki.archlinux.org/index.php/LibreOffice#Theme

But that locale error also reads weird, is it properly set? What's the output of

locale
locale -a

And please post these using [ code ] tags.

Last edited by V1del (2018-03-08 08:48:32)

Offline

#3 2018-03-08 22:10:58

wandel
Member
Registered: 2018-03-07
Posts: 2

Re: [SOLVED] Dead Keys don't work on Libreoffice when using plasma Desktop

Hi V1del,
Thank you very much!

The issue was solved by changing the UI backend.

What I did was the following:

sudo nano /etc/profile.d/libreoffice-fresh.sh

and the uncommented the line

export SAL_USE_VCLPLUGIN=gtk3

After a reboot, it was working nice!

Regarding the locale, here it goes the outputs:

$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
en_US.utf8

In the /etc/locale.conf, it appears as "LANG=en_US.UTF-8".

Thanks very much for your support!

Offline

Board footer

Powered by FluxBB