You are not logged in.

#1 2018-02-14 08:04:41

rogorido
Member
Registered: 2009-08-17
Posts: 107

Error building ndiswrapper for new kernels

Hi, kernel 4.15.2 and 4.15.3 were not able to build ndiswrapper because of the following error: http://ix.io/HaY

Basically:

/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c: En la función ‘wrap_init_timer’:
/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c:455:2: error: implicit declaration of function ‘init_timer’; did you mean ‘init_timers’? [-Werror=implicit-function-declaration]
  init_timer(&wrap_timer->timer);
  ^~~~~~~~~~
  init_timers
/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c:456:19: error: ‘struct timer_list’ no tiene un miembro llamado ‘data’
  wrap_timer->timer.data = (unsigned long)wrap_timer;
                   ^
/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c:457:29: error: asignación desde un tipo de puntero incompatible [-Werror=incompatible-pointer-types]
  wrap_timer->timer.function = timer_proc;
                             ^
/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c: En la función ‘ntoskernel_init’:
/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c:2563:29: error: asignación desde un tipo de puntero incompatible [-Werror=incompatible-pointer-types]
  shared_data_timer.function = update_user_shared_data_proc;
                             ^
/var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.c:2564:19: error: ‘struct timer_list’ no tiene un miembro llamado ‘data’
  shared_data_timer.data = 0;
                   ^
cc1: algunos avisos se tratan como errores
make[2]: *** [scripts/Makefile.build:316: /var/lib/dkms/ndiswrapper/1.61/build/ntoskernel.o] Error 1
make[2]: *** Se espera a que terminen otras tareas....
make[1]: *** [Makefile:1508: _module_/var/lib/dkms/ndiswrapper/1.61/build] Error 2
make[1]: se sale del directorio '/usr/lib/modules/4.15.3-1-ARCH/build'
make: *** [Makefile:183: modules] Error 2

Any ideas?

Offline

#2 2018-02-14 10:52:27

jarvisai
Member
From: Tokyo | Berlin
Registered: 2017-01-18
Posts: 5
Website

Re: Error building ndiswrapper for new kernels

hmm did that say the function call init_timer must have s letter at end of word.

Did that make this error ?


$> whoami -- Jarvis Mercer | My GitHub - My email address - Telegram-ID - Discord = #0839 - ArchLinux+AsusN552VW-A+MacbookPro2017(TB)

Offline

#3 2018-02-14 20:49:50

rogorido
Member
Registered: 2009-08-17
Posts: 107

Re: Error building ndiswrapper for new kernels

jarvisai wrote:

hmm did that say the function call init_timer must have s letter at end of word.

Did that make this error ?

It seems so, but I did not change this file... Am I the only one with this error?

Offline

#4 2018-02-14 23:53:46

loqs
Member
Registered: 2014-03-06
Posts: 6,001

Re: Error building ndiswrapper for new kernels

https://sources.debian.org/patches/ndis … .15.patch/
File a bug report asking for ndiswrapper to be patched for linux 4.15.

Offline

#5 2018-03-05 06:24:08

drjbananas
Member
Registered: 2018-03-05
Posts: 3

Re: Error building ndiswrapper for new kernels

rogorido wrote:
jarvisai wrote:

hmm did that say the function call init_timer must have s letter at end of word.

Did that make this error ?

It seems so, but I did not change this file... Am I the only one with this error?

I also have this same problem on kernel 4.15.6

Last edited by drjbananas (2018-03-05 06:37:03)

Offline

#6 2018-03-05 11:25:47

loqs
Member
Registered: 2014-03-06
Posts: 6,001

Re: Error building ndiswrapper for new kernels

Welcome to the arch linux forums drjbananas.

loqs wrote:

https://sources.debian.org/patches/ndis … .15.patch/
File a bug report asking for ndiswrapper to be patched for linux 4.15.

drjbananas wrote:

I also have this same problem on kernel 4.15.6

Did you try the patch I linked or file a but report on the arch bug tracker against ndiswrapper-dkms asking for the patch to be applied?

Offline

#7 2018-03-10 01:28:33

drjbananas
Member
Registered: 2018-03-05
Posts: 3

Re: Error building ndiswrapper for new kernels

loqs wrote:

Welcome to the arch linux forums drjbananas.

loqs wrote:

https://sources.debian.org/patches/ndis … .15.patch/
File a bug report asking for ndiswrapper to be patched for linux 4.15.

drjbananas wrote:

I also have this same problem on kernel 4.15.6

Did you try the patch I linked or file a but report on the arch bug tracker against ndiswrapper-dkms asking for the patch to be applied?

I have not tried to apply the patch you linked. This is my first time reporting an issue with Arch Linux. I read the reporting bug guidelines and I wasn't sure where exactly to bring this up. I flagged the package out of date because the patch hasn't been applied to Arch and I linked this thread.  I think that might've been the wrong place to do it. Do I need to file an actual bug report with Arch Linux or should I notify the ndiswrapper people on their sourceforge website? Thanks for your help loqs!

Last edited by drjbananas (2018-03-10 01:31:10)

Offline

#8 2018-03-10 12:17:52

loqs
Member
Registered: 2014-03-06
Posts: 6,001

Re: Error building ndiswrapper for new kernels

drjbananas wrote:

I have not tried to apply the patch you linked. This is my first time reporting an issue with Arch Linux. I read the reporting bug guidelines and I wasn't sure where exactly to bring this up.

drjbananas wrote:

I flagged the package out of date because the patch hasn't been applied to Arch and I linked this thread.  I think that might've been the wrong place to do it. Do I need to file an actual bug report with Arch Linux or should I notify the ndiswrapper people on their sourceforge website?

When you flagged the package out of date you did not see the following message?

Note: Do not use this facility if the package is broken! The package will be unflagged and the report will be ignored! Use the bugtracker to file a bug instead.

As the latest upstream release is 1.61 the package is not out of date.
File a bug report on both the arch bug tracker and the upstream bug tracker or at least the arch bug tracker if you want arch to fix the issue.
Reporting_bug_guidelines#Opening_a_bug covers how each field should be filled in of the bug report.
Project: Community Packages
Title: [ndiswrapper-dkms] 1.61-3 does not build for linux 4.15
Severity:High (all functionality is broken under 4.15)
Description: ndiswrapper requires patching for linux 4.15 compatibility.
include the dkms.log of a failed build under 4.15 and link to the patch from debian
you could also include a link to this thread.
As I do not use the package I left filing the bug report to those who do as they can test the patch and updated package.
Edit:
Thank you for opening https://bugs.archlinux.org/task/57784

Last edited by loqs (2018-03-10 20:28:33)

Offline

#9 2018-03-10 21:18:26

drjbananas
Member
Registered: 2018-03-05
Posts: 3

Re: Error building ndiswrapper for new kernels

loqs wrote:
drjbananas wrote:

I have not tried to apply the patch you linked. This is my first time reporting an issue with Arch Linux. I read the reporting bug guidelines and I wasn't sure where exactly to bring this up.

drjbananas wrote:

I flagged the package out of date because the patch hasn't been applied to Arch and I linked this thread.  I think that might've been the wrong place to do it. Do I need to file an actual bug report with Arch Linux or should I notify the ndiswrapper people on their sourceforge website?

When you flagged the package out of date you did not see the following message?

Note: Do not use this facility if the package is broken! The package will be unflagged and the report will be ignored! Use the bugtracker to file a bug instead.

As the latest upstream release is 1.61 the package is not out of date.
File a bug report on both the arch bug tracker and the upstream bug tracker or at least the arch bug tracker if you want arch to fix the issue.
Reporting_bug_guidelines#Opening_a_bug covers how each field should be filled in of the bug report.
Project: Community Packages
Title: [ndiswrapper-dkms] 1.61-3 does not build for linux 4.15
Severity:High (all functionality is broken under 4.15)
Description: ndiswrapper requires patching for linux 4.15 compatibility.
include the dkms.log of a failed build under 4.15 and link to the patch from debian
you could also include a link to this thread.
As I do not use the package I left filing the bug report to those who do as they can test the patch and updated package.
Edit:
Thank you for opening https://bugs.archlinux.org/task/57784

Thank you for your help loqs! I didn't get that message when I flagged the package as out of date. I reported it as an Arch bug and I also reported it upstream. Thanks again!

Offline

#10 2018-03-10 22:15:00

loqs
Member
Registered: 2014-03-06
Posts: 6,001

Re: Error building ndiswrapper for new kernels

To build a patched package

$ git clone git://git.archlinux.org/svntogit/community.git --single-branch --branch "packages/ndiswrapper-dkms"
$ cd community/trunk/ #you could cp -r community/trunk to ndiswrapper-dkms and cd to that instead if you wanted
$ wget https://sources.debian.org/data/main/n/ndiswrapper/1.60-6/debian/patches/0008-Build-fixes-for-Linux-4.15.patch

Edit the PKGBUILD add 0008-Build-fixes-for-Linux-4.15.patch the sources array and a line to the bottom of prepare applying the patch

$ updpkgsums
$ makepkg -rsi # make the package installing any needed dependencies,  install the package then remove any dependencies installed by makepkg.

Offline

Board footer

Powered by FluxBB