You are not logged in.

#1 2018-02-21 17:46:40

joelk
Member
Registered: 2017-04-16
Posts: 5

geany-plugins package omits debugger

Why is the debugger omitted from geany-plugins?

Offline

#2 2018-02-21 18:14:59

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,565
Website

Re: geany-plugins package omits debugger

Offline

#3 2018-03-12 14:51:17

damnbug
Member
Registered: 2012-09-18
Posts: 38

Re: geany-plugins package omits debugger

After upgrading geany (1.32.0-2 -> 1.33.0-1 -> 1.33.0-2) and geany-plugins (1.32-4 -> 1.33-1), there is no spell checker in Plugin Manager. How to fix this?

(I didn't want to start a new thread related to geany-plugins)

Offline

#4 2018-03-12 17:05:59

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,522

Re: geany-plugins package omits debugger

From the configure log:

checking for enchant >= 1.5... no
checking for enchant >= 2.0... no
checking for enchant >= 1.3... no
[...]
  Plugins:
[...]
    Spellcheck:                   no

The problem is that after adding enchant 2.x support, they did not also add support for detecting enchant >= 2.1.3 which does parallel, versioned installs. Please file an upstream bugreport for geany-plugins, and once they fix it, if they do not release a fixed version immediately you can open an Arch bugreport to backport the fix.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#5 2018-03-16 14:06:23

damnbug
Member
Registered: 2012-09-18
Posts: 38

Re: geany-plugins package omits debugger

Eschwartz wrote:

From the configure log:

checking for enchant >= 1.5... no
checking for enchant >= 2.0... no
checking for enchant >= 1.3... no
[...]
  Plugins:
[...]
    Spellcheck:                   no

The problem is that after adding enchant 2.x support, they did not also add support for detecting enchant >= 2.1.3 which does parallel, versioned installs. Please file an upstream bugreport for geany-plugins, and once they fix it, if they do not release a fixed version immediately you can open an Arch bugreport to backport the fix.

eht16 @ https://github.com/geany/geany-plugins/issues/728

This is only partly an issue with ArchLinux.
For the 1.33 release we can't do anything to fix it but for the future. Enchant bump their library version number recently including the pkgconfig name (enchant vs enchant-2) and so G-P's configure checks for the wrong package name.

I'll prepare a patch to support building against the new and old package name.

Offline

#6 2018-03-16 14:10:16

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,522

Re: geany-plugins package omits debugger

s/only partly/not at all/

That's kind of the definition of "another upstream changed things and now we depend on specific old releases of stuff". Arch Linux is just the messenger. wink


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#7 2018-03-22 15:01:27

damnbug
Member
Registered: 2012-09-18
Posts: 38

Re: geany-plugins package omits debugger

Hello again.

eth16 @ https://github.com/geany/geany-plugins/issues/728

#729 adds support for both the old and new Enchant package names and so should solve the issue for future releases.

For the current release, please ping the ArchLinux package maintainers to backport the patch.

link to the patch https://github.com/geany/geany-plugins/ … 60861e6fe8

Should I open a bug report now? If yes, you can do it for me if you like. smile

Done.

Last edited by damnbug (2018-03-22 15:12:51)

Offline

#8 2018-03-22 18:48:57

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,522

Re: geany-plugins package omits debugger

Thanks, looks great.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB