You are not logged in.

#1 2018-03-17 13:32:52

moopmoop
Member
Registered: 2018-03-17
Posts: 6

[solved] error while loading shard libraries: libpsl.so.5

Hi there,


I am updating Arch regularly using pacman and I have installed spotify using yaourt. It has run for a long time. Today I cannot start spotify but I get the following error message:

usr/share/spotify/spotify: error while loading shared libraries: libpsl.so.5: cannot open shared object file: No such file or directory

Any ideas?


Thanks!

Last edited by moopmoop (2018-03-17 13:54:10)

Offline

#2 2018-03-17 13:46:24

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,028

Re: [solved] error while loading shard libraries: libpsl.so.5

$ pacman -Fs libpsl.so
core/libpsl 0.20.0-1
    usr/lib/libpsl.so
multilib/lib32-libpsl 0.20.0-1
    usr/lib32/libpsl.so
$
$ pacman -Ql libpsl | grep libpsl.so
libpsl /usr/lib/libpsl.so
libpsl /usr/lib/libpsl.so.6
libpsl /usr/lib/libpsl.so.6.2.0
$ 

Looks like libpsl was recenlty upgraded and had a soname bump .
Try rebuilding spotify .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2018-03-17 13:53:55

moopmoop
Member
Registered: 2018-03-17
Posts: 6

Re: [solved] error while loading shard libraries: libpsl.so.5

Yes, it works! Just running yaourt -S spotify
Thanks!

Offline

Board footer

Powered by FluxBB