You are not logged in.

#1 2018-03-17 07:16:25

boban_dj
Member
Registered: 2015-03-17
Posts: 115

[SOLVED]Maybe wrong info about installing PECL on archwiki?

I was looking for the pecl binary. On the PHP and Drupal archwiki pages:
https://wiki.archlinux.org/index.php/PHP#using_pecl and https://wiki.archlinux.org/index.php/Dr … ot_enabled is explained how to get it.
In the AUR php-pear package there is no pecl binary.
Online I could not find any info about the PECL binary and where to get it for archlinux.
Does anyone know where PECL is?

Last edited by boban_dj (2018-03-17 16:53:49)

Offline

#2 2018-03-17 08:57:25

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 610

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

I just built the package and it contains /usr/bin/pecl.

Offline

#3 2018-03-17 13:24:25

boban_dj
Member
Registered: 2015-03-17
Posts: 115

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

@lahwaacz, thanks for checking. Also succeeded to compile the package php-imagick (I had to remove hardening-wrapper first see the comments: https://aur.archlinux.org/packages/icu57/)

After running php -v:

PHP Warning:  PHP Startup: Unable to load dynamic library 'imagick' (tried: /usr/lib/php/modules/imagick
 (/usr/lib/php/modules/imagick: cannot open shared object file: No such file or directory), /usr/lib/php/modules/imagick.so 
(/usr/lib/php/modules/imagick.so: undefined symbol: spl_ce_Countable)) in Unknown on line 0
$ pecl
-bash: pecl: command not found

could you check where the Pecl binary is in your system?

Last edited by boban_dj (2018-03-17 13:24:52)

Offline

#4 2018-03-17 13:37:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,266

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

boban_dj wrote:

I had to remove hardening-wrapper

hardening-wrapper was always a dirty hack and removed from repositories around july 2017 because default building flags protect better now then hardening-wrapper ever did.
I suggest you run pacman -Qm and pacman -Qdt to see what other obsolete stuff you have.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2018-03-17 13:48:51

boban_dj
Member
Registered: 2015-03-17
Posts: 115

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

@Lone_Wolf, yep its a complete "beerput". Next week will have a new system, so I can start fresh again.
php-imagick installed fine but still no trace of pecl.

Offline

#6 2018-03-17 14:01:10

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 610

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

pecl is provided by the php-pear package, as the two wiki pages linked from your first post say.

Offline

#7 2018-03-17 14:28:42

boban_dj
Member
Registered: 2015-03-17
Posts: 115

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

Can you tell me where in your system it exists?
I installed php-pear, no trace of pecl

Offline

#8 2018-03-17 15:07:29

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 610

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

I already said it's in /usr/bin/pecl

How did you install the package and what does "pacman -Ql php-pear" show?

Offline

#9 2018-03-17 15:26:20

boban_dj
Member
Registered: 2015-03-17
Posts: 115

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

$ ls /usr/bin/pe*

/usr/bin/peas-demo*  /usr/bin/pencil2d*  /usr/bin/permview*
/usr/bin/pedump*     /usr/bin/perl*      /usr/bin/perror*
/usr/bin/peekfd*     /usr/bin/perltex@   /usr/bin/peverify*

$ pacman -Qi php-pear

Name            : php-pear
Version         : 1:1.10.1-3
Description     : PHP Extension and Application Repository.
Architecture    : any
URL             : http://pear.php.net/
Licenses        : PHP
Groups          : None
Provides        : None
Depends On      : php
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 4.00 KiB
Packager        : Levon Kayan <noptrix@nullsecurity.net>
Build Date      : Sat 31 Dec 2016 07:32:20 PM CET
Install Date    : Sat 17 Mar 2018 03:20:31 PM CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

$ php -v
PHP 7.2.3 (cli) (built: Mar  1 2018 16:50:09) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

Offline

#10 2018-03-17 15:29:33

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,025

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

So are you on blackarch or are you just using the blackarch repo?

Edit: Either way, that package is both old and broken.

Last edited by Scimmia (2018-03-17 15:38:27)

Offline

#11 2018-03-17 16:02:03

boban_dj
Member
Registered: 2015-03-17
Posts: 115

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

@Scimmia, just using blackarch repo.
yes its old I needed it for some project. Thanks everyone, consider it solved, as I will not use it anymore.

Offline

#12 2018-03-17 16:44:55

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,256
Website

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

Once you remove the repo, remember to do a full system update to replace the blackarch versions with their Arch counterparts. Also, check your pacman -Qm output to see which other packages will now be stale.

Please remember to mark your thread as solved.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#13 2018-03-17 16:53:09

boban_dj
Member
Registered: 2015-03-17
Posts: 115

Re: [SOLVED]Maybe wrong info about installing PECL on archwiki?

@WorMzy great tip!

Offline

Board footer

Powered by FluxBB