You are not logged in.
Pages: 1
Topic closed
I have followed the xen installation instructions on https://wiki.archlinux.org/index.php/Xen
However the GRUB option for Xen with Arch as dom0 fails to boot.
From previous troubleshooting I added
xenfs /proc/xen xenfs defaults 0 0to /etc/fstab
However when I do the native Arch install fails to boot. But with different errors (it seems) than when I try to boot Xen with Arch dom0.
I am unable to reach even a command line when booting to Xen under any circumstance.
When booting to native Arch I am left with a recovery login to root.
Below is what I was able to gather about xen from there.
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_evtchn': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_gntdev': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_gntalloc': No such device
Mar 25 20:43:37 castle mount[328]: mount: /proc/xen: mount point does not exist.
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_blkback': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_netback': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_pciback': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_acpi_processor': No such device
Mar 25 20:43:37 castle systemd-networkd[393]: xenbr0: netdev ready
Mar 25 20:43:37 castle systemd-networkd[393]: xenbr0: Link is not managed by us
Mar 25 20:43:37 castle systemd-networkd[393]: xenbr0: IPv6 successfully enabled
Mar 25 20:43:37 castle kernel: IPv6: ADDRCONF(NETDEV_UP): xenbr0: link is not ready
Mar 25 20:43:38 castle kernel: xenbr0: port 1(eno1) entered blocking state
Mar 25 20:43:38 castle kernel: xenbr0: port 1(eno1) entered disabled state
Mar 25 20:43:38 castle kernel: xenbr0: port 1(eno1) entered blocking state
Mar 25 20:43:38 castle kernel: xenbr0: port 1(eno1) entered forwarding state
Mar 25 20:43:38 castle kernel: IPv6: ADDRCONF(NETDEV_CHANGE): xenbr0: link becomes ready
Mar 25 20:43:38 castle kernel: xenbr0: port 1(eno1) entered disabled state
Mar 25 20:43:37 castle systemd-networkd[393]: xenbr0: Gained carrier
Mar 25 20:43:39 castle systemd-networkd[393]: xenbr0: Gained IPv6LL
Mar 25 20:43:39 castle systemd-networkd[393]: xenbr0: Lost carrier
Mar 25 20:43:41 castle systemd-networkd[393]: xenbr0: Gained carrier
Mar 25 20:43:41 castle kernel: xenbr0: port 1(eno1) entered blocking state
Mar 25 20:43:41 castle kernel: xenbr0: port 1(eno1) entered forwarding state
Mar 25 20:43:53 castle systemd-networkd[393]: xenbr0: Configured● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Sun 2018-03-25 20:43:37 UTC; 1min 37s ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 320 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 320 (code=exited, status=1/FAILURE)
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_evtchn': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_gntdev': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_gntalloc': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_blkback': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_netback': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_pciback': No such device
Mar 25 20:43:37 castle systemd-modules-load[320]: Failed to insert 'xen_acpi_processor': No such device
Mar 25 20:43:37 castle systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Mar 25 20:43:37 castle systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Mar 25 20:43:37 castle systemd[1]: Failed to start Load Kernel Modules.[ 2.616881] IPv6: ADDRCONF(NETDEV_UP): xenbr0: link is not ready
[ 2.735478] xenbr0: port 1(eno1) entered blocking state
[ 2.735480] xenbr0: port 1(eno1) entered disabled state
[ 2.983177] xenbr0: port 1(eno1) entered blocking state
[ 2.983179] xenbr0: port 1(eno1) entered forwarding state
[ 2.983207] IPv6: ADDRCONF(NETDEV_CHANGE): xenbr0: link becomes ready
[ 3.423168] xenbr0: port 1(eno1) entered disabled state
[ 6.348134] xenbr0: port 1(eno1) entered blocking state
[ 6.348137] xenbr0: port 1(eno1) entered forwarding state● proc-xen.mount - /proc/xen
Loaded: loaded (/etc/fstab; generated)
Active: failed (Result: exit-code) since Sun 2018-03-25 20:43:37 UTC; 44min ago
Where: /proc/xen
What: xenfs
Docs: man:fstab(5)
man:systemd-fstab-generator(8)
Process: 328 ExecMount=/usr/bin/mount xenfs /proc/xen -t xenfs (code=exited, status=32)
Mar 25 20:43:37 castle mount[328]: mount: /proc/xen: mount point does not exist.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.● proc-xen.mount - /proc/xen
Loaded: loaded (/etc/fstab; generated)
Active: failed (Result: exit-code) since Sun 2018-03-25 21:41:39 UTC; 51s ago
Where: /proc/xen
What: xenfs
Docs: man:fstab(5)
man:systemd-fstab-generator(8)
Process: 647 ExecMount=/usr/bin/mount xenfs /proc/xen -t xenfs (code=exited, status=32)
Mar 25 21:41:39 castle systemd[1]: Mounting /proc/xen...
Mar 25 21:41:39 castle mount[647]: mount: /proc/xen: mount point does not exist.
Mar 25 21:41:39 castle systemd[1]: proc-xen.mount: Mount process exited, code=exited status=32
Mar 25 21:41:39 castle systemd[1]: proc-xen.mount: Failed with result 'exit-code'.
Mar 25 21:41:39 castle systemd[1]: Failed to mount /proc/xen.Without the fstab entry active Arch native boots normally and works.
With the fstab entry active Arch native does not boot. Drops to an emergency prompt.
With or without the fstab entry Xen with Arch dom0 does not boot.
In all cases the Xen will stop after initial loading of the system. Somewhere between the kernel loading and LightDM coming up.
I had another thread ( https://bbs.archlinux.org/viewtopic.php?id=235539 ) that was my initial attempt.
I have since re-installed Arch from scratch and modified the GRUB config to
XEN_HYPERVISOR_CMDLINE="dom0_mem=4G xsave=1"Offline
How is this different to your original thread?
https://bbs.archlinux.org/viewtopic.php?id=235539
Please continue any discussions there, I'm going to close this duplicate thread.
Offline
Pages: 1
Topic closed