You are not logged in.

#1 2018-04-12 23:54:54

wangcow
Member
Registered: 2018-04-12
Posts: 2

TouchPad 2 Finger Scrolling Rubberbanding

Hello there. I'm having a new issuewith my Synaptics TouchPad. I'm having this issue on my Thinkpad T420 and X201T. The issue - when two finger scrolling, when I let go of the TouchPad after scrolling, the page will scroll the opposite direction a bit, almost like a 'rubber band' effect..not sure how else to explain it.

I've tried downgrading my kernel, tried a different DE (cinnamon), tried using xorg instead of wayland, and I'm kind of at a loss as to how to diagnose this problem. Maybe try a lts kernel and see if that's it? I can't pinpoint exactly when the issue started, but it's persistent across my two devices. I would like to diagnose the issue and create a bug report, but I'm not sure the culprit.

Any ideas on how to delve into this issue? I've attached my libinput list-devices output. Will provide whatever else is needed.

Thank you!

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event9
Group:            9
Seat:             seat0, default
Size:             51x18mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

Offline

#2 2018-04-15 20:08:39

wangcow
Member
Registered: 2018-04-12
Posts: 2

Re: TouchPad 2 Finger Scrolling Rubberbanding

Shameless self bump. Any ideas? Can I downgrade Wayland without breaking Gnome to see if that's the issue? But then again, Gnome on Xorg is giving me the same issues, so I guess that would rule that one out.. Maybe a Gnome downgrade? But then again, I tried on Cinnamon (on my T420) with the same issues. Maybe a sensitivity setting with my touchpad?

Offline

Board footer

Powered by FluxBB