You are not logged in.

#1 2018-04-17 00:34:37

Lanz
Member
From: Ontario, Canada
Registered: 2015-01-24
Posts: 7

Speakers popping

I had my PulseAudio version pinned for quite some time and finally let it upgrade today on 3 machines I administrate. There was random popping of sound from the speakers on boot and when doing seemingly random things like opening apps or switching tabs.

It turns out that the problem is due to PulseAudio going idle. The fix is:

Edit /etc/pulse/daemon.conf and add:
  exit-idle-time = -1
  allow-exit = no

Edit /etc/pulse/default.pa and comment:
  # load-module module-suspend-on-idle

Edit /etc/pulse/system.conf and comment:
  # load-module module-suspend-on-idle

Given that this happened on three of my machines, and also happened to my friend on his Dell XPS 13 a couple months ago or so when he let PulseAudio upgrade, it has probably happened to many people. I'm blown away that such an annoying issue was allowed into production.

Offline

#2 2018-04-17 04:07:01

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,544
Website

Re: Speakers popping

Lanz wrote:

I'm blown away that such an annoying issue was allowed into production.

The forums are not the best place to criticize upstream practices, because it's unlikely that they'll be reading our forums for feedback.

Offline

#3 2018-04-17 08:11:18

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,410

Re: Speakers popping

And if we really want to be pedantic here, the actual fault lies in the kernel config of 4.15 which has enabled power saving on snd-hda-intel by default. You are simply sidestepping by letting pulseaudio not release the device.

And even as it stands this is a configuration option you can opt to do if you do not care about power saving, what's "production relevant" is entirely up to your system and preferences. Which you can adjust just the same.

Offline

Board footer

Powered by FluxBB