You are not logged in.

#1 2018-04-09 03:21:12

alimoabd2127
Member
Registered: 2018-04-09
Posts: 1

Grub stuck at "Loading Initial Ramdisk"

I have just installed arch on two different systems side by side.  My Asus laptop is working properly and loads up Arch just fine with a SATA ssd.  My new Lenovo uses an NVME drive and it is stuck at "Loading Initial Ramdisk".  I used the exact same steps on both laptops.  I have made sure to disable any security in the BIOS and both of them are in UEFI mode.  The Lenovo is a Yoga 720-13IKB.

Offline

#2 2018-04-30 16:43:35

d_fajardo
Member
Registered: 2017-07-28
Posts: 175

Re: Grub stuck at "Loading Initial Ramdisk"

Can you access the grub configuration?

Last edited by d_fajardo (2018-04-30 16:45:59)

Offline

#3 2018-05-01 05:27:25

d_fajardo
Member
Registered: 2017-07-28
Posts: 175

Re: Grub stuck at "Loading Initial Ramdisk"

https://wiki.archlinux.org/index.php/Ta … 2347447.22
Seems there might be an issue booting on NVME using grub but the site doesn't lead to a solution.

Last edited by d_fajardo (2018-05-01 05:29:24)

Offline

#4 2018-05-01 09:02:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,410

Re: Grub stuck at "Loading Initial Ramdisk"

That was 2 years ago, GRUB has been long since updated and has no problems booting from NVME

However what GRUB also does is messing with the video mode during startup try setting GRUB_GFXPAYLOAD_LINUX=keep or GRUB_GFXPAYLOAD_LINUX=text in your grub.cfg

If that doesn't help post details on your partition layout, your fstab and your grub config.

Offline

Board footer

Powered by FluxBB