You are not logged in.

#1 2018-05-01 19:55:59

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

[SOLVED]WiFi card blocked by rfkill every boot

Hi! So every time I boot I have to run

# rfkill unblock all

or otherwise I can't use WiFi. After running that everything works perfectly.

Network controller: Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01)
	Subsystem: Hewlett-Packard Company BCM4312 802.11b/g Wireless LAN Controller
	Kernel driver in use: wl
	Kernel modules: ssb, wl

  I am using broadcom-wl. The same issue occurs with broadcom-wl-dkms. I installed using pacman, so I didn't blacklist any other modules.
  I am using Wicd. Disabled every other network management services.
  dmesg:
https://pastebin.com/raw/9HA3cLky

Last edited by CarterCox (2018-05-09 20:02:20)


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#2 2018-05-07 00:51:37

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

Re: [SOLVED]WiFi card blocked by rfkill every boot

Humpty bumpty.

https://askubuntu.com/questions/55868/i … ss-drivers

I followed that but rfkill changes are not persistent.

from the link wrote:

IMPORTANT NOTE - After September 2014, if you follow this answer and still you have problems installing the correct driver, please try the firmware-b43-installer package and notify us via comments. There were some changes and some drivers will only work with this package. Remember to have a clean system before installing it:

sudo apt install firmware-b43-installer
In some particular cases, after installing the firmware-b43-installer you need to remove the b43 module, enable it again and even proceed to unblock with rfkill:

sudo modprobe -r b43
sudo modprobe b43   
sudo rfkill unblock all 
If you have a Broadcom card that has a different pci.id, please ask a new question. Once solved, the solution will be added to this howto.

Last edited by CarterCox (2018-05-07 00:57:16)


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#3 2018-05-08 10:01:08

radiomike
Member
Registered: 2013-12-19
Posts: 32

Re: [SOLVED]WiFi card blocked by rfkill every boot

Have a look at adding

 rfkill.default_state=1 

to your boot options. This should set rfkill to default to unblocked. Theres some other options in the kernel parameters too which may help.

You may also want to look at the wmi module(s) being loaded and possible configuration options for these. Could be wrong module being loaded, or wrong configuration being applied. There's also a possibilty that this may be overiding the rfkill option.

Offline

#4 2018-05-08 10:05:49

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

Re: [SOLVED]WiFi card blocked by rfkill every boot

Hmm. Yeah I'll try that. I'll also try blacklisting possibly conflicting modules.

Thanks for the answer!


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#5 2018-05-09 00:03:17

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

Re: [SOLVED]WiFi card blocked by rfkill every boot

Ok I added this

/etc/modprobe.d/blacklist.conf

blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist bcma
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist ssb

because when I install "broadcom-wl-dkms" I get this message:

To load the new module, run the following commands as root:

  rmmod b43 b43legacy bcm43xx bcma brcm80211 brcmfmac brcmsmac ssb wl
  modprobe wl

Or just reboot the system.

which makes me think this are conflicting modules.

Also

/etc/default/grub

...
GRUB_CMDLINE_LINUX_DEFAULT="quiet rfkill.default_state=1"
...

Sadly the problem is still there.

Maybe some modules I don't know about?

Output of mkinitcpio -M:

==> Modules autodetected
ac
acpi_cpufreq
ahci
amd64_edac_mod
ata_generic
atkbd
battery
ehci_pci
evdev
ext4
firewire_ohci
fjes
forcedeth
hid_generic
hp_wmi
i2c_nforce2
i8042
input_leds
joydev
k8temp
kvm_amd
mac_hid
mousedev
nouveau
ohci_pci
pata_acpi
pata_amd
pcc_cpufreq
pcspkr
powernow_k8
psmouse
r592
r852
rtc_cmos
sdhci_pci
sd_mod
serio_raw
shpchp
snd_hda_codec_conexant
snd_hda_intel
sr_mod
ssb
usbcore
usbhid
uvcvideo
wdat_wdt
wl
wmi
wmi_bmof

I don't know what else I could try.


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#6 2018-05-09 01:13:59

artesano
Member
Registered: 2018-03-02
Posts: 8

Re: [SOLVED]WiFi card blocked by rfkill every boot

Maybe one of the suggestions in [SOLVED] Wireless hard blocked could help... smile

Offline

#7 2018-05-09 01:22:55

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,075
Website

Re: [SOLVED]WiFi card blocked by rfkill every boot

If running `rfkill unblock all` works, then why not just enable the rfkill-unblock service?  (Of course also check that you haven't actually enabled the rfkill-block service which would itself explain your symptoms).


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#8 2018-05-09 02:51:09

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

Re: [SOLVED]WiFi card blocked by rfkill every boot

@artesano: I have tried removing /dev/rfkill, nothing. However, the topic is about a hard block, this is a soft block. I'll try removing the battery later though, althoug my hopes are not up.

@Trilby: Good thinking. However, the service fails:

$systemctl --type=service
...
rfkill-unblock@multi-user.service loaded failed failed ...

Is this strange? Should I have other services availebla other than "rfkill-unblock@.service"?


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#9 2018-05-09 18:49:38

loqs
Member
Registered: 2014-03-06
Posts: 4,510

Re: [SOLVED]WiFi card blocked by rfkill every boot

systemctl cat rfkill-unblock@.service
# /usr/lib/systemd/system/rfkill-unblock@.service
[Unit]
Description=RFKill-Unblock %I
After=rfkill-block@all.service

[Service]
Type=oneshot
ExecStart=/usr/bin/rfkill unblock %I

[Install]
WantedBy=multi-user.target

rfkill-unblock@multi-user.service

is executing

/usr/bin/rfkill unblock multi-user

Offline

#10 2018-05-09 18:59:51

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

Re: [SOLVED]WiFi card blocked by rfkill every boot

So I should create a new service or do I have to enable rfkill-unblock@all.service?


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#11 2018-05-09 19:05:41

progandy
Member
Registered: 2012-05-17
Posts: 2,786

Re: [SOLVED]WiFi card blocked by rfkill every boot

You can either enable rfkill-unblock@all, ...@wlan or ...@YOUR_DEVICE.
If you run rfkill without any arguments, you get a list of all switches with their device names and types.

Edit: grammar...

Last edited by progandy (2018-05-09 20:17:54)

Offline

#12 2018-05-09 20:02:04

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 79

Re: [SOLVED]WiFi card blocked by rfkill every boot

It lives! Thanks everyone!


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

Board footer

Powered by FluxBB