You are not logged in.

#1 2018-05-09 19:32:25

jbenge1
Member
Registered: 2018-04-09
Posts: 33

[SOLVED]No option to boot existing os

After attempting to install arch on a second laptop when I finish and reboot, I am not prompted with the option to reboot existing os, only to boot from the usb or some other options, (none of which do anything but take me back to the screen to choose what to boot from)

options for booting (all exluding Arch Linux do nothing but take me back to this screen

Arch Linux archiso x86_64 UEFI CD
UEFI Shell x86_64 v1
UEFI Shell x86_64 v2
EFI Default Loader
Reboot Into Frimware Interface

I followed the wiki on installation and at no point did I see any error messages.


The only weird thing I saw was in fdisk -l there seemed to be an extra drive under /dev/sdb that was only like 8G? I don't know what it is but one of the partitions has the boot flag turned on.
EDIT: (I feel a little dumb now, but is this the usb that I'm booting from?? **facepalm**)

fdisk -l 

Disk /dev/sdb: 7.6 GiB, 8... bytes, 15974400 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector Size ....
I/O size....
Disklabel type: dos
Disk identifier...

Device ...

/dev/sdb1   *   0   1146879  ...   560M  0  Empty
/dev/sdb2       164 131235   ...   64M    ef  EFI (FAT-12/16/32)

Also I aplogize if there are any typo's in the output of fdisk -l or if I missed some crucial information

these are the exact steps I followed

fdisk -l
  
fdisk /dev/sda   
  # IN FDISK #
	o   
	n 
	<enter> 
	<enter> 
	+30G    
	a	
        n
	<enter> #number
	<enter> #first sector
	+8G	# swap space
	type 	# set type to swap
	<enter> # chooses partition we just created
	82	# The type we want
	n	#
	<enter>
	<enter>
	<enter> # last sector should be remainder of drive
	w
 # END FDISK #

fdisk -l #check we made our partitions

mkfs.ext4 /dev/sda1  

mkfs.ext4 /dev/sda3 

cp /etc/netctl/example/wireless-wpa /etc/netctl/wirelessname

ip a  

nano /etc/netctl/wirelessname
	#In NANO
		#change interface to wireless device name
		#change ESSID to the name of the wifi network to use
		#change KEY to the password for wifi
		#ctrl O ctrl X
	#END NANO

rfkill unblock wifi

ip link set wlp1s0 up

ip link set wlp1s0 down

netctl start wirelessname

#Mount root partition
mount /dev/sda1 /mnt   #name of bootable parition

mkdir /mnt/home

mount /dev/sda3 /mnt/home

mount # check to see that the two new ones are mounted

pacstrap -i /mnt base  #install base distibution
<enter> 
<enter> 


genfstab -U -p /mnt >> /mnt/etc/fstab #generates system configuration file

arch-chroot /mnt

pacman -S 
	openssh 
	gurb-bios
	linux-headers 
	linux-lts 
	linux-lts-headers 
	wpa_supplicant 
	wireless_tools 
        vim


vim /etc/locale.gen  #Uncomment en US UTF-8


hwclock --systohc --utc  

systemctl enable sshd.service 

passwd  # used to create a new password for root

grub-install --target=i386-pc --recheck /dev/sda  

grub-mkconfig -o /boot/grub/grub.cfg  

exit   

umount /mnt/home

umount /mnt

reboot

EDIT:
when I reboot I see a message (very breifly)

[FAILED] Failed unmounting /run/archiso/bootmount

Last edited by jbenge1 (2018-05-10 01:11:05)

Offline

#2 2018-05-09 19:47:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,433

Re: [SOLVED]No option to boot existing os

You installed GRUB in BIOS mode, but are booting UEFI, check if you have a switch to allow booting in BIOS mode in your UEFI, otherwise  you will have to add a FAT formated ESP and install GRUB in UEFI mode

https://wiki.archlinux.org/index.php/GRUB#UEFI_systems

Last edited by V1del (2018-05-09 19:48:13)

Offline

#3 2018-05-09 22:57:12

Nostradamus
Member
Registered: 2018-05-05
Posts: 6

Re: [SOLVED]No option to boot existing os

If you see this, you boot into USB. Also it's why your whole /dev/sdb is 8GB.

Arch Linux archiso x86_64 UEFI CD
UEFI Shell x86_64 v1
UEFI Shell x86_64 v2
EFI Default Loader
Reboot Into Frimware Interface

Additionally I'd suggest you reinstall and use systemd-boot (bootctl) instead of GRUB.

bootctl install

vim /boot/loader/loader.conf
default archlinux
timeout 3

vim /boot/loader/entries/archlinux.conf
title archlinux
linux /vmlinuz-linux
initrd /initramfs-linux.img
options root=PARTUUID=/* PARTUUID of your / partititon which is /dev/sda2 probably */ rw

Offline

#4 2018-05-10 01:11:59

jbenge1
Member
Registered: 2018-04-09
Posts: 33

Re: [SOLVED]No option to boot existing os

thanks for the quick responses/feedback, I tried bootctl but for whatever reason it would just always send me to an emergency shell. I have grub working now finally.

Offline

Board footer

Powered by FluxBB