You are not logged in.

#1 2018-05-16 09:15:57

fap
Member
Registered: 2018-05-16
Posts: 3

Diablo II not displaying properly when using glide wrapper

Hi everyone, I first want to thank this awesome community. Documentation is everywhere, detailed and people seem to be very helpful and dedicated. I recently moved to arch merely for the fun of expermenting and I really liked the feeling of building a customized system out of a very barebone disto. Learned a lot of stuff on how things work !

So to the issue itself. I have been playing Diablo II on linux for quite some time now. It's only really my first attempt with arch so I merely repeated what used to work flawlessly elsewhere and ... it works ! Well, almost.

The game installs just fine. I can run the default client without problem. The only thing that remains to fix is this neat little glide3 to opengl wrapper (http://www.svenswrapper.de/english/) that is very handful to resize the game window, among other eye candy features.

I can install and set it up everything looks normal until I fire up the game. When the wrapper is enabled, game windows basically goes all black with a few color speckles. Sounds play just fine and client does not crash, so from what I can tell it just looks like a rendering problem.

My not-super-expert-but-kind-of-experimented-linux-user guts feeling is there is something still missing that would come by default in other distros I used before because it just worked straight out of the box.

So I started installing every other package I could see mentionned in various relevant wiki entries (wine, xorg, video drivers, etc) in hope I can eventually narrow it down to the actual missing component. I am out of luck so far.

I thus turn to you, advanced users, maybe you guys have an idea what could be missing. I know I should probably give more details on the system, just not sure what exactly would be requiredm just ask me what you need so I can help you help me x

NOTE : Before anyone points this out, I know glide wrapper will not work on the latest (v1,14+) version of the game and this is not the issue since I use v1.13c to play on private servers.

Offline

#2 2018-05-16 09:33:23

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,433

Re: Diablo II not displaying properly when using glide wrapper

Do you get any useful terminal output? Can you post it in [ code ] tags FWIW? Are your 32bit graphics drivers properly installed, which driver/card are we talking?

Last edited by V1del (2018-05-16 09:33:55)

Offline

#3 2018-05-16 09:39:08

fap
Member
Registered: 2018-05-16
Posts: 3

Re: Diablo II not displaying properly when using glide wrapper

Nothing particularly scary, I was getting a few fixme things on other systems as well but here it is :

[mike@arch Diablo II]$ wine Game.exe -w -3dfx &
[1] 2579
[mike@arch Diablo II]$ 0009:fixme:dwmapi:DwmIsCompositionEnabled 0x266ced1
0009:fixme:dwmapi:DwmEnableComposition (0) stub
0009:fixme:ver:GetCurrentPackageId (0x32eca0 (nil)): stub
0009:fixme:ver:GetCurrentPackageId (0x32eec0 (nil)): stub
0009:fixme:wgl:X11DRV_wglBindTexImageARB partial stub!

[1]+  Done                    wine Game.exe -w -3dfx

As for video card

]$ lspci -v | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8280 / R3 Series] (prog-if 00 [VGA controller])

xorg relevant section

Section "Device"
        Identifier  "Card0"
        Driver      "radeon"
        BusID       "PCI:0:1:0"
        Option     "TearFree"   "3"
        Option     "TearFree" "on"
        Option     "AccelMethod" "glamor"
        Option "ColorTiling" "on"
        Option "ColorTiling2D" "on"
EndSection

Not sure how I can print all relevant installed packages but here's some

$ pacman -Qi xf86-video-ati
Name            : xf86-video-ati
Version         : 1:18.0.1-1
Description     : X.org ati video driver
Architecture    : x86_64
URL             : https://xorg.freedesktop.org/
Licenses        : custom
Groups          : xorg-drivers
Provides        : None
Depends On      : libsystemd  mesa
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : xorg-server<1.19.0  X-ABI-VIDEODRV_VERSION<23  X-ABI-VIDEODRV_VERSION>=24
Replaces        : None
Installed Size  : 516.00 KiB
Packager        : Laurent Carlier <lordheavym@gmail.com>
Build Date      : Fri Mar 16 06:16:05 2018
Install Date    : Tue May 15 22:44:07 2018
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

$ pacman -Qi mesa          
Name            : mesa
Version         : 18.0.3-1
Description     : An open-source implementation of the OpenGL specification
Architecture    : x86_64
URL             : https://www.mesa3d.org/
Licenses        : custom
Groups          : None
Provides        : ati-dri  intel-dri  nouveau-dri  svga-dri  mesa-dri  mesa-libgl  opengl-driver
Depends On      : libdrm  wayland  libxxf86vm  libxdamage  libxshmfence  libelf  libomxil-bellagio  libunwind  llvm-libs  lm_sensors  libglvnd
Optional Deps   : opengl-man-pages: for the OpenGL API man pages
                  mesa-vdpau: for accelerated video playback [installed]
                  libva-mesa-driver: for accelerated video playback
Required By     : gst-plugins-base-libs  gtk3  lib32-mesa  libglvnd  xf86-video-ati
Optional For    : None
Conflicts With  : ati-dri  intel-dri  nouveau-dri  svga-dri  mesa-dri  mesa-libgl
Replaces        : ati-dri  intel-dri  nouveau-dri  svga-dri  mesa-dri  mesa-libgl
Installed Size  : 56.38 MiB
Packager        : Andreas Radke <andyrtr@archlinux.org>
Build Date      : Tue May 8 13:22:38 2018
Install Date    : Sat May 12 18:45:38 2018
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

$ pacman -Qi lib32-mesa
Name            : lib32-mesa
Version         : 18.0.2-1
Description     : An open-source implementation of the OpenGL specification (32-bit)
Architecture    : x86_64
URL             : http://mesa3d.sourceforge.net
Licenses        : custom
Groups          : None
Provides        : lib32-ati-dri  lib32-intel-dri  lib32-nouveau-dri  lib32-mesa-dri  lib32-mesa-libgl  lib32-opengl-driver
Depends On      : lib32-libdrm  lib32-libxxf86vm  lib32-libxdamage  lib32-libxshmfence  lib32-lm_sensors  lib32-libelf  lib32-llvm-libs  lib32-wayland  lib32-libglvnd  mesa
Optional Deps   : opengl-man-pages: for the OpenGL API man pages
                  lib32-mesa-vdpau: for accelerated video playback [installed]
Required By     : lib32-libglvnd
Optional For    : None
Conflicts With  : lib32-ati-dri  lib32-intel-dri  lib32-nouveau-dri  lib32-mesa-dri  lib32-mesa-libgl
Replaces        : lib32-ati-dri  lib32-intel-dri  lib32-nouveau-dri  lib32-mesa-dri  lib32-mesa-libgl
Installed Size  : 53.35 MiB
Packager        : Laurent Carlier <lordheavym@gmail.com>
Build Date      : Sun Apr 29 07:35:27 2018
Install Date    : Sun May 13 00:23:02 2018
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Last edited by fap (2018-05-16 09:50:23)

Offline

#4 2018-05-16 15:14:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,433

Re: Diablo II not displaying properly when using glide wrapper

Some weird TearFree definitions there. What's the output of

glxinfo32 | grep OpenGL #Needs lib32-mesa-demos

And update your system, your lib32-mesa is out of sync with normal mesa.

Last edited by V1del (2018-05-16 15:19:13)

Offline

#5 2018-05-16 17:47:51

fap
Member
Registered: 2018-05-16
Posts: 3

Re: Diablo II not displaying properly when using glide wrapper

I ran a 

 pacman -Syu 

shortly after I posted as I was trying other things and it updated lib32-mesa. However it did not help this specific issue but I guess it was asking for trouble. Thanks for noticing it.

Here's the output of your command :

$ glxinfo32 | grep OpenGL #Needs lib32-mesa-demos
OpenGL vendor string: X.Org
OpenGL renderer string: AMD KABINI (DRM 2.50.0 / 4.16.8-1-ARCH, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.3
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

Offline

Board footer

Powered by FluxBB