You are not logged in.

#1 2018-05-17 08:29:12

beroal
Member
From: Ukraine
Registered: 2009-06-07
Posts: 262
Website

a man page is not available after installing by "texlive-localmanager"

I need documentation for "latexmk", so I ran "tllocalmgr installdoc latexmk" from "texlive-localmanager-git" as recommended in the wiki. I rejected the package "texlive-most-doc" because it is huge. After running the command, a package "texlive-local-latexmk-doc" appeared. It contains the file "/usr/local/share/texmf/doc/man/man1/latexmk.1". I guess that this is the desired man page. However,

>man latexmk
No manual entry for latexmk

I tried to relogin. I guess that "/usr/local/share/texmf/doc/man/man1" should be added to some environment variable?

BTW, "tllocalmgr" can't be run as root, but it requires root password somewhere in the middle. It does not make sense to me. Why not run it as root? It can reduce privileges for its subprocesses.


we are not condemned to write ugly code

Offline

#2 2018-05-17 18:14:14

Sauron
Member
Registered: 2016-03-17
Posts: 8

Re: a man page is not available after installing by "texlive-localmanager"

Maybe something went wrong with tllocalmgr, the easiest solution is to copy latexmk.1 to /usr/local/share/man/man1, then run mandb as root. Alternatively you could try adding the file's path to MANPATH, although as far as I know that shouldn't be necessary.

The reason it requires a root password is probably to run mandb, and the reason you can't run the whole command as root is probably that it needs to access some of your user's environment variables - I could be wrong though.


M-x butterfly

Offline

Board footer

Powered by FluxBB