You are not logged in.

#1 2018-05-16 19:30:16

chrisdb
Member
Registered: 2018-05-16
Posts: 3

Permissions on /var/lib/machines

Hello,

I've been playing with systemd-nspawn on Gnome for a while now and everything works as espected.
But for some reason, I always have to change the permissions on the /var/lib/machines folder from 700 to 755 so I can access it with my sudo user.
After I reboot, the permissions are somehow reset to 700....

I've been looking in journalctl, but I can't seem to find which process is resetting these permissions and why.

Does anyone have a clue?

Thx

Last edited by chrisdb (2018-05-16 19:31:31)

Offline

#2 2018-05-16 19:39:09

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,591

Re: Permissions on /var/lib/machines

Welcome to the forums chrisdb smile

chrisdb wrote:

But for some reason, I always have to change the permissions on the /var/lib/machines folder from 700 to 755 so I can access it with my sudo user.

This doesn't make any sense - unless you aren't using sudo.

After I reboot, the permissions are somehow reset to 700....

I've been looking in journalctl, but I can't seem to find which process is resetting these permissions and why.

Does anyone have a clue?

Thx

/usr/lib/tmpfiles.d/systemd-nspawn.conf

https://bbs.archlinux.org/viewtopic.php?id=233191


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2018-05-17 19:07:42

chrisdb
Member
Registered: 2018-05-16
Posts: 3

Re: Permissions on /var/lib/machines

Thank you very much Slithery!!
If found it:

Q /var/lib/machines 0700 - - -

Just one more question, do you think containers should be run as root?
Maybe that's why this option exists?

Offline

Board footer

Powered by FluxBB