You are not logged in.

#1 2018-05-18 10:45:18

luken
Member
Registered: 2014-06-26
Posts: 27

[SOLVED]No background and no windows on the second monitor after upgra

I have a strange problem after the recent update. I have two monitors setup, after the login the second monitor is black, but the mouse cursor is visible. No background and no windows though. I can fix this by switching to a virtual console with "Ctrl+Alt+F3" and going back with "Ctrl+Alt+F2" - background and windows will reappear on the second screen then. Anyone have any idea of how to check what is going on here and fix it?

Environment:
Linux Luken-Desktop 4.16.9-1-ARCH #1 SMP PREEMPT Thu May 17 02:10:09 UTC 2018 x86_64 GNU/Linux
Gnome 3.28.2

UPDATE:
Actually it's worse than that. Sometimes everything just freeze right after login, it seems to be random.

Last edited by luken (2018-05-18 19:05:50)

Offline

#2 2018-05-18 11:08:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,240

Re: [SOLVED]No background and no windows on the second monitor after upgra

Which hardware, which driver, journal/xorg logs, what is "the recent upgrade", which packages were installed/updated?

General statement into the room, if you are on xorg and are using a driver specific xf86- package., try removing it and using the xorg modesetting driver instead.

Offline

#3 2018-05-18 12:50:01

luken
Member
Registered: 2014-06-26
Posts: 27

Re: [SOLVED]No background and no windows on the second monitor after upgra

Thanks! Removing xf86-video-ati fixed the problem. But does it mean that no more 2d acceleration for me? hmm

"The recent upgrade" was yesterday. Upgraded packages:

[2018-05-17 20:21] [ALPM] upgraded libdrm (2.4.91-3 -> 2.4.92-1)
[2018-05-17 20:21] [ALPM] upgraded krb5 (1.16-1 -> 1.16.1-1)
[2018-05-17 20:21] [ALPM] upgraded wayland (1.14.0-1 -> 1.15.0-1)
[2018-05-17 20:21] [ALPM] upgraded mesa (18.0.3-1 -> 18.0.3-4)
[2018-05-17 20:21] [ALPM] upgraded gstreamer (1.14.0-1 -> 1.14.1-1)
[2018-05-17 20:21] [ALPM] upgraded gst-plugins-base-libs (1.14.0-1 -> 1.14.1-1)
[2018-05-17 20:21] [ALPM] upgraded wayland-protocols (1.13-1 -> 1.14-1)
[2018-05-17 20:21] [ALPM] upgraded audacity (2.2.2-1 -> 2.2.2-2)
[2018-05-17 20:21] [ALPM] upgraded bluez (5.49-3 -> 5.49-4)
[2018-05-17 20:21] [ALPM] upgraded bluez-libs (5.49-3 -> 5.49-4)
[2018-05-17 20:21] [ALPM] upgraded xdg-utils (1.1.2-2 -> 1.1.3-1)
[2018-05-17 20:21] [ALPM] upgraded chromium (66.0.3359.170-1 -> 66.0.3359.181-1)
[2018-05-17 20:21] [ALPM] upgraded curl (7.59.0-2 -> 7.60.0-1)
[2018-05-17 20:21] [ALPM] upgraded deepin-wallpapers (1:1.7-1 -> 1:1.7.2-1)
[2018-05-17 20:21] [ALPM] upgraded deepin-desktop-base (1:2017.11.1-1 -> 1:2018.5.15-1)
[2018-05-17 20:21] [ALPM] upgraded deepin-icon-theme (15.12.56-1 -> 15.12.57-1)
[2018-05-17 20:21] [ALPM] upgraded libinput (1.10.6-1 -> 1.10.7-1)
[2018-05-17 20:21] [ALPM] upgraded deepin-qt-dbus-factory (1.0.1-1 -> 1.0.2-1)
[2018-05-17 20:21] [ALPM] upgraded gst-plugins-base (1.14.0-1 -> 1.14.1-1)
[2018-05-17 20:21] [ALPM] upgraded python (3.6.5-2 -> 3.6.5-3)
[2018-05-17 20:21] [ALPM] upgraded gnupg (2.2.6-1 -> 2.2.7-1)
[2018-05-17 20:21] [ALPM] upgraded deepin-daemon (3.2.13.4-1 -> 3.2.15-1)
[2018-05-17 20:21] [ALPM] upgraded docker (1:18.04.0-1 -> 1:18.05.0-2)
[2018-05-17 20:21] [ALPM] upgraded gimp (2.10.0-5 -> 2.10.0-6)
[2018-05-17 20:21] [ALPM] upgraded gnome-online-accounts (3.27.92+3+gdde33649-1 -> 3.28.0-1)
[2018-05-17 20:21] [ALPM] upgraded go-ethereum (1.8.7-1 -> 1.8.8-1)
[2018-05-17 20:21] [ALPM] upgraded gst-libav (1.14.0-2 -> 1.14.1-1)
[2018-05-17 20:21] [ALPM] upgraded gst-plugins-bad (1.14.0-2 -> 1.14.1-1)
[2018-05-17 20:21] [ALPM] upgraded gst-plugins-good (1.14.0-1 -> 1.14.1-1)
[2018-05-17 20:21] [ALPM] upgraded libmagick (7.0.7.31-1 -> 7.0.7.33-1)
[2018-05-17 20:21] [ALPM] upgraded imagemagick (7.0.7.31-1 -> 7.0.7.33-1)
[2018-05-17 20:21] [ALPM] upgraded libdmx (1.1.3-1 -> 1.1.4-1)
[2018-05-17 20:21] [ALPM] upgraded libmagick6 (6.9.9.43-1 -> 6.9.9.45-1)
[2018-05-17 20:21] [ALPM] upgraded libnetfilter_conntrack (1.0.6-1 -> 1.0.7-1)
[2018-05-17 20:21] [ALPM] upgraded lsscsi (0.28-1 -> 0.29-1)
[2018-05-17 20:21] [ALPM] upgraded mesa-vdpau (18.0.3-1 -> 18.0.3-4)
[2018-05-17 20:21] [ALPM] upgraded nano (2.9.6-1 -> 2.9.7-1)
[2018-05-17 20:21] [ALPM] upgraded opera (53.0.2907.37-1 -> 53.0.2907.57-1)
[2018-05-17 20:21] [ALPM] upgraded python2-attrs (17.4.0-1 -> 18.1.0-1)
[2018-05-17 20:21] [ALPM] upgraded sudo (1.8.22-1 -> 1.8.23-2)
[2018-05-17 20:21] [ALPM] upgraded unrar (1:5.6.3-1 -> 1:5.6.4-1)
[2018-05-17 20:21] [ALPM] upgraded xf86-video-ati (1:18.0.1-1 -> 1:18.0.1-2)
[2018-05-17 20:21] [ALPM] upgraded xorg-server-common (1.19.6+13+gd0d1a694f-2 -> 1.20.0-2)
[2018-05-17 20:21] [ALPM] upgraded xorg-server (1.19.6+13+gd0d1a694f-2 -> 1.20.0-2)
[2018-05-17 20:21] [ALPM] upgraded xorg-server-xvfb (1.19.6+13+gd0d1a694f-2 -> 1.20.0-2)
[2018-05-17 20:21] [ALPM] upgraded xorg-server-xwayland (1.19.6+13+gd0d1a694f-2 -> 1.20.0-2)

So I guess it's something worth reporting to the xf86-video-ati maintainer? I see no source code has been changed by this upgrade, only dependencies, so it has to be something between xf86-video-ati and xorg hmm .

Added:
I installed xf86-video-amdgpu instead, as it also handles my graphic card, and everything is working fine now. smile

Last edited by luken (2018-05-18 13:50:52)

Offline

Board footer

Powered by FluxBB