You are not logged in.

#1 2018-05-11 12:56:36

cryzed
Member
Registered: 2010-05-11
Posts: 10

Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

Hello! I own a NVIDIA GTX 1060 GPU and updated my system yesterday evening, most importantly: `linux 4.16.8-1` and `nvidia 396.24-2`. After booting today, X didn't start properly. I have a dual-monitor setup, one screen didn't seem to receive any HDMI signal, while the other one displayed a glitchy mess (horizontal white "snow" streaks). Figuring that it was probably the driver update, I chrooted into my system and installed the legacy NVIDIA drivers: `nvidia-390xx 390.48-2` and everything is fine again.

I couldn't find similar reports of this problem in this forum or the subreddit, which makes me afraid that I'm an insolated case. Has this happened to anyone else? I'll try to gather some logs related to this issue.

Offline

#2 2018-05-11 13:13:16

blablo
Member
Registered: 2011-06-02
Posts: 35

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

Offline

#3 2018-05-11 14:14:18

Misagi
Member
Registered: 2018-05-11
Posts: 1

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

Dont worry, you are not an isolated case.

I'm using an Optimus Laptop (nvidia + intel)

I had to downgrade the Kernel to 4.16.7-1  + nvidia + nvidia-utils to make it work again.

1) cd /var/cache/pacman/pkg/
2) sudo pacman -U nvidia-390.48-13-x86_64.pkg.tar.xz nvidia-utils-390.48-1-x86_64.pkg.tar.xz nvidia-settings-390.48-1-x86_64.pkg.tar.xz
3) sudo pacman -U linux-4.16.7-1-x86_64.pkg.tar.xz
4) Reboot & profit, I guess.

Last edited by Misagi (2018-05-11 14:32:13)

Offline

#4 2018-05-11 14:42:10

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,731

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

lib32-nvidia-utils as well, probably.

Offline

#5 2018-05-11 15:17:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,425

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

FWIW instead of downgrading you could also switch to the 390xx branch (if you happen to have a Fermi card that "could" becomes a must)

Last edited by V1del (2018-05-12 09:17:31)

Offline

#6 2018-05-11 15:28:09

cryzed
Member
Registered: 2010-05-11
Posts: 10

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

That's a relief, thanks guys! I'll keep running with the legacy 390xx drivers for now until I hear news about a fix.

Last edited by cryzed (2018-05-11 19:37:43)

Offline

#7 2018-05-12 09:36:38

Heep
Member
Registered: 2018-05-12
Posts: 1

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

You could also disable nvidia-drm.modeset, which worked for me on GTX 980 Ti. After all, it's not that you benefit a lot from nvidia modesetting at the current point, other than fan speed going down earlier and having the console across multiple screens.

Offline

#8 2018-05-12 09:46:32

pekka
Member
Registered: 2011-07-21
Posts: 99

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

try on nvidia-390.48 and kernel linux-4.16.8
and not working

Offline

#9 2018-05-17 15:09:06

MattWylde
Member
Registered: 2014-11-28
Posts: 2

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

Same problem with GTX 1080 eGPU. However, downgrading to the 390xx branch did not solve it for me. I noticed a warning about AllowExternalGpus in Xorg.0.log, but it still does not work with the following:
Section "Device"
    Identifier "NVidia Graphics"
        Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "AllowExternalGpus" "on"
EndSection

I do not have nvidia-drm.modeset=1 in my kernel boot line, and I have WaylandEnabled=false in gdm.conf

Offline

#10 2018-05-18 02:44:18

Batou
Member
Registered: 2017-01-03
Posts: 188

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

I currently have linux 4.16.8-1 (custom build) + nvidia-dkms 396.24-2 running on a 1070 without any issues. On my work laptop I have a 1060 and it also runs without any issues. I'm actually pleasantly surprised that I haven't been hit with this bug. Heh. Nvidia is absolute mess when it comes to drivers. I'm thinking about going to iGPU since I don't play games and my Intel CPU supports 4K @ 60Hz. I'm sick of all these Nvidia issues. They can never get anything right on the first try and break installs all the damn time.

I wonder why some people have this issue and some don't. Previous Nvidia issue (post-Spectre driver mess) impacted everyone.

Last edited by Batou (2018-05-18 02:45:11)


Please vote for all the AUR packages you're using. You can mass-vote for all of them by doing: "pacman -Qqm | xargs aurvote -v" (make sure to run "aurvote --configure"  first)

Offline

#11 2018-05-18 09:47:31

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 669
Website

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

@Batou This was a handy reminder for me at least (Nvidia 1030, kernel ARCH). Thx!


Seeded last month: Arch 50 gig, derivatives 1 gig
Desktop @3.3GHz 8 gig RAM, linux-ck
laptop #1 Atom 2 gig RAM, Arch linux stock i686 (6H w/ 6yrs old battery smile) #2: ARM Tegra K1, 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#12 2018-05-18 10:07:00

brrrrrrrt
Member
Registered: 2015-10-03
Posts: 4

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

i also had to downgrade to the nvidia 390xx packages, it worked until today, but after upgrading xorg to 1.20 it was broken again sad

had to downgrade xorg to 1.19 to make it work:

cd /var/cache/pacman/pkg/
pacman -U xorg-server-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz xorg-server-common-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz xorg-server-xvfb-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz xorg-server-xwayland-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz

it seems 390xx is not compatible with xorg 1.20:

[     4.352] (II) LoadModule: "nvidia"
[     4.352] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[     4.352] (II) Module nvidia: vendor="NVIDIA Corporation"
[     4.352]    compiled for 4.0.2, module version = 1.0.0
[     4.352]    Module class: X.Org Video Driver
[     4.352] ================ WARNING WARNING WARNING WARNING ================
[     4.352] This server has a video driver ABI version of 24.0 that this
driver does not officially support.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[     4.352] =================================================================
[     4.352] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[     4.352] (II) UnloadModule: "nvidia"
[     4.352] (II) Unloading nvidia
[     4.352] (EE) Failed to load module "nvidia" (unknown error, 0)

Because we don't think about future generations, they will never forget us.
        -- Henrik Tikkanen

Offline

#13 2018-05-18 10:09:01

blablo
Member
Registered: 2011-06-02
Posts: 35

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

Batou wrote:

I wonder why some people have this issue and some don't.

https://devtalk.nvidia.com/default/topi … 5/#5256185

Offline

#14 2018-05-18 10:13:52

blablo
Member
Registered: 2011-06-02
Posts: 35

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

brrrrrrrt wrote:

i also had to downgrade to the nvidia 390xx packages, it worked until today, but after upgrading xorg to 1.20 it was broken again sad

had to downgrade xorg to 1.19 to make it work:

https://bbs.archlinux.org/viewtopic.php … 4#p1785904

Offline

#15 2018-05-18 13:24:51

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 669
Website

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

Just like Batou above I have no issues running

linux-4.16.9-1-ARCH x86_64
xorg-server 1.20.0-2
nvidia-dkms 396.24-3

And then

nvidia-settings 396.24-1
nvidia-utils 396.24-1
opencl-nvidia 396.24-1
lib32-nvidia-utils 396.24-2
libvdpau 1.1.1+3+ga21bf7a-1
steam-1.0.0.54-3

On a GT 1030 ("Pascal" smthg).
I just uninstalled the old nvidia* pkgs then installed the new driver, starting with nvidia-dkms.
I have not tested Graysky's linux-ck yet.


Seeded last month: Arch 50 gig, derivatives 1 gig
Desktop @3.3GHz 8 gig RAM, linux-ck
laptop #1 Atom 2 gig RAM, Arch linux stock i686 (6H w/ 6yrs old battery smile) #2: ARM Tegra K1, 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#16 2018-05-18 14:21:57

Batou
Member
Registered: 2017-01-03
Posts: 188

Re: Issues with nvidia 396.24-2 and NVIDIA GTX 1060?

blablo wrote:
Batou wrote:

I wonder why some people have this issue and some don't.

https://devtalk.nvidia.com/default/topi … 5/#5256185

Interesting.

It seems they've fixed the issue:

sandipt wrote:

We have fixed this issue and the fix will be available in upcoming driver release ...

https://devtalk.nvidia.com/default/topi … 2/#5259772


Please vote for all the AUR packages you're using. You can mass-vote for all of them by doing: "pacman -Qqm | xargs aurvote -v" (make sure to run "aurvote --configure"  first)

Offline

Board footer

Powered by FluxBB