You are not logged in.

#1 2018-05-18 15:56:30

Registered: 2017-08-01
Posts: 26

[SOLVED] Repair Grub on Dualboot fails with error pointing to rec...

Hi guys.
I'm runnign a dualboot with Windows 10 and was using mostly Windows for a while. After a recent update Windows notified me about a partition getting small. It was a 450 MB partition on the very beginning of the disk. I coulndt really remember what the partition was for. It said Windows recovery partition, and since the warinings got really annoying and I had recently removed a Windows recovery partition from my Laptop without any trouble, I went full retard and deleted it with diskparted. Well after that my system always booted straigtht into windows.Thats where I came to the realisation that I used that partition for dualbooting. Allthough I cant remember how exactly the setuo was. Reinstalling grub turned out to be difficult and I couldnt manage to figure it out following the wiki instructions.

Heres my partition layout with fdisk -l:

/dev/sdb has both windows 10 and Arch Linux installed.

And heres my parted /dev/sdb print:

I mounted the EFI partition /dev/sdb1 to /mnt/boot/efi before I arch-chrooted into the system.
And then proceeded with the guide.

grub-install --target=x86_64-efi --efi-directory=/boot/efi/ --bootloader-id=GRUB

Reporting back with:

Installing for x86_64-efi platform.
EFI variables are not supported on this system.
EFI variables are not supported on this system.
Installation finished. No error reprted.

Followed by:

grub-mkconfig -o /boot/grub/grub.cfg

Reporting back with:

Generating grub configuration file ...
Found linux image : /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initframs-linux.img
Found fallback initrd image(s) in /boot: initframs-linux-fallback.img
   WARNING: Failed to connect to lvmetad. Falling back to device scanning.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your

The Bootmenu in the BIOS does only list the Windows Boot Manager  though.

Whats weird to me is that /dev/sdc1 comes into play when making the grub config since thats the bootable usbstick I use.
I hope that I didn't forget anything else important.

Last edited by beppo (2018-05-19 15:06:48)


#2 2018-05-19 15:11:50

Registered: 2017-08-01
Posts: 26

Re: [SOLVED] Repair Grub on Dualboot fails with error pointing to rec...

Alright I got it, since not getting a reply within a day is a good indicator that one has not been searching long enough, I continued to search for my problem.
And hey I found the answer:
The problem was that my Bios was set to either boot in Legacy or UEFI. Therefore the recovery USB stick got booted in Legacy, hence not finding the efi variables. Switching to UEFI only did the trick and reinstalling grub worked.


Board footer

Powered by FluxBB