You are not logged in.

#1 2018-05-18 13:53:35

overclockedllama
Member
Registered: 2018-02-05
Posts: 3

bumblebee gpu doesnt work on battery

Hi I have a asus vivobook s15 with intel integrated and nvidia 940MX

I am trying to set up bumblebee but I have a problem where the gpu refuses to turn on when running on battery power

Also when i plug the laptop in to charge, it still refuses to turn the gpu back on. The only way to re-enable the gpu is by rebooting whilst plugged in.

optirun glxgears

works as expected when laptop turned on with power supply attached

after unplugging the power i get this error:

 optirun glxgears
[   70.254364] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[   70.254396] [ERROR]Aborting because fallback start is disabled.

and this is what i get after restarting bumblebeed

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2018-05-18 14:43:40 BST; 7min ago
 Main PID: 3614 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 756.0K
   CGroup: /system.slice/bumblebeed.service
           └─3614 /usr/bin/bumblebeed

May 18 14:43:40 computer systemd[1]: Started Bumblebee C Daemon.
May 18 14:43:40 computer bumblebeed[3614]: [  182.484765] [INFO]/usr/bin/bumblebeed 3.2.1 started
May 18 14:43:44 computer bumblebeed[3614]: [  185.644594] [ERROR]Could not enable discrete graphics card

when i replug the laptop in, it doesnt change anything even after restarting bumblebeed

Offline

#2 2018-05-19 22:56:00

radiomike
Member
Registered: 2013-12-19
Posts: 32

Re: bumblebee gpu doesnt work on battery

There's a few other threads about this, but either look at blacklisting your card from runtime PM - especially if you're using TLP, but possibly other PM tools too.

Or look at adding bbswitch to your mkinitcpio.conf MODULES.

Offline

Board footer

Powered by FluxBB