You are not logged in.

#1 2018-05-23 17:06:44

joasis
Member
Registered: 2018-02-27
Posts: 13

[SOLVED][NVIDIA][Bumblebee][X.Org 1.20] X did not start properly

Hello everyone,

After the update to X.Org 1.20, I cannot run apps with Bumblebee's optirun command:

[jmi@Joasis ~]$ optirun glxgears
[36693.165883] [ERROR]Cannot access secondary GPU - error: X did not start properly
[36693.165910] [ERROR]Aborting because fallback start is disabled.

Everything runs smoothly if I roll back to X.Org 1.19.

The issue has already been reported on Bumblebee's GitHub page but I figured I'm more likely to get some help here.

4.16.10-1-ARCH
NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
Bumblebee 3.2.1-17
Nvidia 396.24-4

/var/log/Xorg.8.log:

[ 36692.733] 
X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
[ 36692.733] Build Operating System: Linux Arch Linux
[ 36692.733] Current Operating System: Linux Joasis 4.16.10-1-ARCH #1 SMP PREEMPT Mon May 21 07:57:23 UTC 2018 x86_64
[ 36692.733] Kernel command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img root=/dev/mapper/crypt_root cryptdevice=/dev/sda2:crypt_root rw modprobe.blacklist=iTCO_wdt acpi_osi=! "acpi_osi=Windows 2009" quiet splash
[ 36692.733] Build Date: 16 May 2018  05:24:07PM
[ 36692.733]  
[ 36692.733] Current version of pixman: 0.34.0
[ 36692.733] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[ 36692.733] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 36692.733] (==) Log file: "/var/log/Xorg.8.log", Time: Wed May 23 18:50:33 2018
[ 36692.733] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[ 36692.733] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[ 36692.733] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 36692.734] (==) ServerLayout "Layout0"
[ 36692.734] (==) No screen section available. Using defaults.
[ 36692.734] (**) |-->Screen "Default Screen Section" (0)
[ 36692.734] (**) |   |-->Monitor "<default monitor>"
[ 36692.734] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[ 36692.734] (**) |   |-->Device "DiscreteNvidia"
[ 36692.734] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[ 36692.734] (**) Option "AutoAddDevices" "false"
[ 36692.734] (**) Option "AutoAddGPU" "false"
[ 36692.734] (**) Not automatically adding devices
[ 36692.734] (==) Automatically enabling devices
[ 36692.734] (**) Not automatically adding GPU devices
[ 36692.734] (==) Automatically binding GPU devices
[ 36692.734] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 36692.734] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[ 36692.734] 	Entry deleted from font path.
[ 36692.734] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[ 36692.734] 	Entry deleted from font path.
[ 36692.734] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[ 36692.734] 	Entry deleted from font path.
[ 36692.734] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[ 36692.734] 	Entry deleted from font path.
[ 36692.734] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF
[ 36692.734] (++) ModulePath set to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules"
[ 36692.734] (==) |-->Input Device "<default pointer>"
[ 36692.734] (==) |-->Input Device "<default keyboard>"
[ 36692.734] (==) The core pointer device wasn't specified explicitly in the layout.
	Using the default mouse configuration.
[ 36692.734] (==) The core keyboard device wasn't specified explicitly in the layout.
	Using the default keyboard configuration.
[ 36692.734] (II) Module ABI versions:
[ 36692.734] 	X.Org ANSI C Emulation: 0.4
[ 36692.734] 	X.Org Video Driver: 24.0
[ 36692.734] 	X.Org XInput driver : 24.1
[ 36692.734] 	X.Org Server Extension : 10.0
[ 36692.735] (--) using VT number 2

[ 36692.735] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 36692.735] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 36692.735] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[ 36692.737] (--) PCI:*(2@0:0:0) 10de:139b:1028:0706 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[ 36692.737] (II) Open ACPI successful (/var/run/acpid.socket)
[ 36692.737] (II) LoadModule: "glx"
[ 36692.737] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[ 36692.794] (II) Module glx: vendor="NVIDIA Corporation"
[ 36692.794] 	compiled for 4.0.2, module version = 1.0.0
[ 36692.794] 	Module class: X.Org Server Extension
[ 36692.795] (II) NVIDIA GLX Module  396.24  Wed Apr 25 23:17:01 PDT 2018
[ 36692.796] (II) LoadModule: "nvidia"
[ 36692.797] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 36692.805] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 36692.805] 	compiled for 4.0.2, module version = 1.0.0
[ 36692.805] 	Module class: X.Org Video Driver
[ 36692.806] (II) LoadModule: "mouse"
[ 36692.806] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[ 36692.807] (II) Module mouse: vendor="X.Org Foundation"
[ 36692.807] 	compiled for 1.19.0, module version = 1.9.2
[ 36692.807] 	Module class: X.Org XInput Driver
[ 36692.807] 	ABI class: X.Org XInput driver, version 24.1
[ 36692.807] (II) LoadModule: "kbd"
[ 36692.807] (WW) Warning, couldn't open module kbd
[ 36692.807] (EE) Failed to load module "kbd" (module does not exist, 0)
[ 36692.808] (II) NVIDIA dlloader X Driver  396.24  Wed Apr 25 22:53:34 PDT 2018
[ 36692.808] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 36692.809] (II) Loading sub module "fb"
[ 36692.809] (II) LoadModule: "fb"
[ 36692.809] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 36692.810] (II) Module fb: vendor="X.Org Foundation"
[ 36692.810] 	compiled for 1.20.0, module version = 1.0.0
[ 36692.810] 	ABI class: X.Org ANSI C Emulation, version 0.4
[ 36692.810] (II) Loading sub module "wfb"
[ 36692.810] (II) LoadModule: "wfb"
[ 36692.810] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 36692.811] (II) Module wfb: vendor="X.Org Foundation"
[ 36692.811] 	compiled for 1.20.0, module version = 1.0.0
[ 36692.812] 	ABI class: X.Org ANSI C Emulation, version 0.4
[ 36692.812] (II) Loading sub module "ramdac"
[ 36692.812] (II) LoadModule: "ramdac"
[ 36692.812] (II) Module "ramdac" already built-in
[ 36692.813] (II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[ 36692.813] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 36692.813] (==) NVIDIA(0): RGB weight 888
[ 36692.813] (==) NVIDIA(0): Default visual is TrueColor
[ 36692.813] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 36692.814] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[ 36692.814] (**) NVIDIA(0): Option "UseEDID" "false"
[ 36692.814] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[ 36692.814] (**) NVIDIA(0): Enabling 2D acceleration
[ 36692.814] (**) NVIDIA(0): Ignoring EDIDs
[ 36692.814] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[ 36692.814] (**) NVIDIA(0):     mode
[ 36693.074] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 960M (GM107-A) at PCI:2:0:0 (GPU-0)
[ 36693.074] (--) NVIDIA(0): Memory: 4194304 kBytes
[ 36693.074] (--) NVIDIA(0): VideoBIOS: 82.07.7a.00.19
[ 36693.074] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 36693.074] (II) NVIDIA(0): Validated MetaModes:
[ 36693.074] (II) NVIDIA(0):     "NULL"
[ 36693.074] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[ 36693.074] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[ 36693.074] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 36693.075] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[ 36693.075] (II) NVIDIA:     access.
[ 36693.095] (II) NVIDIA(0): Setting mode "NULL"
[ 36693.099] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 36693.099] (==) NVIDIA(0): Backing store enabled
[ 36693.099] (==) NVIDIA(0): Silken mouse disabled
[ 36693.100] (==) NVIDIA(0): DPMS enabled
[ 36693.100] (WW) NVIDIA(0): Option "NoLogo" is not used
[ 36693.100] (II) Loading sub module "dri2"
[ 36693.100] (II) LoadModule: "dri2"
[ 36693.100] (II) Module "dri2" already built-in
[ 36693.100] (II) NVIDIA(0): [DRI2] Setup complete
[ 36693.100] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[ 36693.100] (II) Initializing extension Generic Event Extension
[ 36693.100] (II) Initializing extension SHAPE
[ 36693.100] (II) Initializing extension MIT-SHM
[ 36693.100] (II) Initializing extension XInputExtension
[ 36693.100] (II) Initializing extension XTEST
[ 36693.100] (II) Initializing extension BIG-REQUESTS
[ 36693.100] (II) Initializing extension SYNC
[ 36693.100] (II) Initializing extension XKEYBOARD
[ 36693.101] (II) Initializing extension XC-MISC
[ 36693.101] (II) Initializing extension SECURITY
[ 36693.101] (II) Initializing extension XFIXES
[ 36693.101] (II) Initializing extension RENDER
[ 36693.101] (II) Initializing extension RANDR
[ 36693.101] (II) Initializing extension COMPOSITE
[ 36693.101] (II) Initializing extension DAMAGE
[ 36693.101] (II) Initializing extension MIT-SCREEN-SAVER
[ 36693.101] (II) Initializing extension DOUBLE-BUFFER
[ 36693.101] (II) Initializing extension RECORD
[ 36693.101] (II) Initializing extension DPMS
[ 36693.101] (II) Initializing extension Present
[ 36693.101] (II) Initializing extension DRI3
[ 36693.102] (II) Initializing extension X-Resource
[ 36693.102] (II) Initializing extension XVideo
[ 36693.102] (II) Initializing extension XVideo-MotionCompensation
[ 36693.102] (II) Initializing extension XFree86-VidModeExtension
[ 36693.102] (II) Initializing extension XFree86-DGA
[ 36693.102] (II) Initializing extension XFree86-DRI
[ 36693.102] (II) Initializing extension DRI2
[ 36693.102] (II) Initializing extension GLX
[ 36693.102] (II) Initializing extension GLX
[ 36693.102] (II) Indirect GLX disabled.
[ 36693.102] (II) Initializing extension NV-GLX
[ 36693.102] (II) Initializing extension NV-CONTROL
[ 36693.150] (II) Using input driver 'mouse' for '<default pointer>'
[ 36693.150] (**) Option "CorePointer" "on"
[ 36693.150] (**) <default pointer>: always reports core events

Last edited by joasis (2018-05-23 17:25:15)

Offline

#2 2018-05-23 17:10:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,723

Re: [SOLVED][NVIDIA][Bumblebee][X.Org 1.20] X did not start properly

Those initializing messages worry me, and it looks like you are crashing on the long defunct mouse module. Remove every xf86-input* module except -libinput (and because you likely installed the group, remove every xf86-video package), and check if you can reproduce.

Last edited by V1del (2018-05-23 17:45:10)

Offline

#3 2018-05-23 17:23:08

joasis
Member
Registered: 2018-02-27
Posts: 13

Re: [SOLVED][NVIDIA][Bumblebee][X.Org 1.20] X did not start properly

Bullseye. Thanks a lot for a quick response V1del. Problem fixed after the removal of xf86-input-mouse module.

Offline

#4 2018-06-17 13:40:57

dimath
Member
Registered: 2012-01-18
Posts: 17

Re: [SOLVED][NVIDIA][Bumblebee][X.Org 1.20] X did not start properly

Had the same issue and spend a lot of time trying to fix (harmless?) error (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
This is the only thread I've found that solves the actual problem, thanks.

Offline

Board footer

Powered by FluxBB