You are not logged in.

#26 2018-05-18 19:45:38

Alaska23
Member
Registered: 2011-09-29
Posts: 12

Re: Updating to xorg-server-1.20 breaks sddm-0.17

Jonhoo wrote:

Xorg 1.20 also breaks sddm for me, but I'm using intel i915. The *way* in which it doesn't work is interesting though. Booting works just fine, but when it launches sddm, the boot log remains visible, with a mouse cursor on top of it (but no other visual elements). It *seems* like sddm is still running in the background, because if I type my password, the screen changes to all black, as if it (unsuccessfully) tried to start my window manager. Downgrading xorg-server{,-common} to 1.19 fixes the issue.

Exactly the same behaviour in my case, but I have a Southern Islands card and use the amdgpu driver, Downgrading xorg-server{,-common} to 1.19  and xf86-video-amdgpu 18.0.1-1 solved the issue for me as well for the time beeing.

Offline

#27 2018-05-18 19:48:26

Jonhoo
Member
Registered: 2009-05-23
Posts: 116

Re: Updating to xorg-server-1.20 breaks sddm-0.17

This is with xmonad. I tried starting X manually with startx, and get:

[  1911.633] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[  1911.634] 
X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
[  1911.634] Build Operating System: Linux Arch Linux
[  1911.634] Current Operating System: Linux x1c3 4.16.9-1-ARCH #1 SMP PREEMPT Thu May 17 02:10:09 UTC 2018 x86_64
[  1911.634] Kernel command line: BOOT_IMAGE=../../vmlinuz-linux root=UUID=7037a4b6-8449-4441-af32-04363a18ad23 rw intel_iommu=igfx_off i915.enable_fbc=0 usb-storage.quirks=0ee4:0690:u initrd=../../intel-ucode.img,../../initramfs-linux.img
[  1911.634] Build Date: 16 May 2018  05:24:07PM
[  1911.634]  
[  1911.634] Current version of pixman: 0.34.0
[  1911.634] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  1911.634] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1911.634] (==) Log file: "/home/jon/.local/share/xorg/Xorg.0.log", Time: Fri May 18 15:41:31 2018
[  1911.634] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1911.634] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1911.634] (==) No Layout section.  Using the first Screen section.
[  1911.634] (==) No screen section available. Using defaults.
[  1911.634] (**) |-->Screen "Default Screen Section" (0)
[  1911.634] (**) |   |-->Monitor "<default monitor>"
[  1911.634] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[  1911.634] (**) |   |-->Device "Intel Graphics"
[  1911.634] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[  1911.634] (==) Automatically adding devices
[  1911.634] (==) Automatically enabling devices
[  1911.634] (==) Automatically adding GPU devices
[  1911.634] (==) Automatically binding GPU devices
[  1911.634] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1911.634] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[  1911.634] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1911.634] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1911.634] (II) Module ABI versions:
[  1911.634] 	X.Org ANSI C Emulation: 0.4
[  1911.634] 	X.Org Video Driver: 24.0
[  1911.634] 	X.Org XInput driver : 24.1
[  1911.634] 	X.Org Server Extension : 10.0
[  1911.635] (++) using VT number 1

[  1911.640] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c15
[  1911.640] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1911.641] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[  1911.642] (--) PCI:*(0@0:2:0) 8086:1616:17aa:2227 rev 9, Mem @ 0xe0000000/16777216, 0xc0000000/536870912, I/O @ 0x00003000/64, BIOS @ 0x????????/131072
[  1911.642] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1911.642] (II) LoadModule: "glx"
[  1911.642] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1911.644] (II) Module glx: vendor="X.Org Foundation"
[  1911.644] 	compiled for 1.20.0, module version = 1.0.0
[  1911.644] 	ABI class: X.Org Server Extension, version 10.0
[  1911.644] (II) LoadModule: "modesetting"
[  1911.644] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  1911.644] (II) Module modesetting: vendor="X.Org Foundation"
[  1911.644] 	compiled for 1.20.0, module version = 1.20.0
[  1911.644] 	Module class: X.Org Video Driver
[  1911.644] 	ABI class: X.Org Video Driver, version 24.0
[  1911.644] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  1911.644] (WW) xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted
[  1911.644] (EE) 
Fatal server error:
[  1911.644] (EE) xf86OpenConsole: Switching VT failed
[  1911.644] (EE) 
[  1911.644] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  1911.644] (EE) Please also check the log file at "/home/jon/.local/share/xorg/Xorg.0.log" for additional information.
[  1911.644] (EE) 
[  1911.644] (WW) xf86CloseConsole: KDSETMODE failed: Operation not permitted
[  1911.644] (WW) xf86CloseConsole: VT_SETMODE failed: Operation not permitted
[  1911.644] (WW) xf86CloseConsole: VT_ACTIVATE failed: Operation not permitted
[  1911.702] (EE) Server terminated with error (1). Closing log file.

That is with the following .xserverrc (as suggested here):

#!/bin/sh
exec /usr/bin/X -keeptty -nolisten tcp "$@" vt$XDG_VTNR

If I run without that, I kept getting

xf86OpenConsole: Cannot open virtual console 1 (Permission denied)

Where it always seemed to pick a different virtual console than the one I had active?

Offline

#28 2018-05-18 20:25:40

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,098
Website

Re: Updating to xorg-server-1.20 breaks sddm-0.17

One possibility is that /usr/bin/X being a symlink to /usr/bin/Xorg used to run /usr/lib/xorg-xserver/Xorg.wrap, but now /usr/bin/Xorg is the Xorg binary identical to /usr/lib/Xorg but *not* /usr/lib/Xorg.wrap.

In otherwords, the default for most systems was previous to run Xorg.wrap, but now everyone is running just Xorg.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#29 2018-05-19 09:56:44

ghen
Member
From: Belgium
Registered: 2010-08-31
Posts: 98
Website

Re: Updating to xorg-server-1.20 breaks sddm-0.17

I had the same issue (xorg backtrace), removing xf86-video-nouveau fixed it for me.  Now apparantly using modeset driver.

Offline

#30 2018-05-19 13:20:24

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 5,985

Re: Updating to xorg-server-1.20 breaks sddm-0.17

yep, Xorg.wrap is broken , see https://bugs.archlinux.org/task/58644 for a workaround and hopefully soon a real solution.

Keep in mind that there appear to be atleast 2 separate problems :

- people getting a segfault / backtrace in xorg logs .
This appears to be caused by xf86-video-nouveau , maybe other drivers also.
Bug 58644 IS NOT about this issue.


- no segfault or backtrace, but X doesn't start.
symptoms :
startx comes back to prompt without any output.
xorg log may show something like this :

[ 19386.979] (EE) 
Fatal server error:
[ 19386.979] (EE) AddScreen/ScreenInit failed for driver 0
[ 19386.979] (EE) 
[ 19386.979] (EE) 

Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#31 2018-05-20 17:22:22

djraymondnm
Member
From: Socorro, NM, USA
Registered: 2011-12-28
Posts: 58
Website

Re: Updating to xorg-server-1.20 breaks sddm-0.17

I am having a similar problem with xorg-server-1.20 on an Intel laptop (i7-6600U, HD Graphics 520, rev 07).  I am starting openbox with startx.  What I get is some garbled stuff in the upper left corner of the screen on all virtual terminals.  However, the VTs are still usable and I can get out of the mess by killing the openbox process.

Curiously, if I start X using "xinit /usr/bin/openbox", openbox  runs in a normal way, but without any of the autostart stuff (as expected).  Many applications work, but running xrandr to change the screen resolution results in a blank screen.  (I need to do this because the native resolution is 2560x1440.).

Starting gdm with Wayland enabled and a gnome desktop (wayland version) works, but starting non-wayland desktops (like openbox) from gdm produces a mess similar to starting with xstart.

I have the Xorg log file which I can upload if needed, but it doesn't seem to be very informative.


Afterthought: I have a bunch of AMD machines running 1.20 with no trouble (lxdm launching openbox, lxqt, mate, etc.).


After-afterthought: The problem appears to be trying to set the resolution of the display with xrandr in xort-server-1.20.  If I eliminate it from my startup scripts, things work fine; startx and lxdm both properly start my openbox session, albeit with 2560x1440 resolution.  Running xrandr --output eDP-1 --scale-from 1600x900 in 1.19 works fine but results in a black screen in 1.20.  The X server is still running, but it is not painting the screen.

So, the question is, how do I set the scale in X11 version 1.20 without xrandr???

Answer: Install the following as "10-resolution.conf" in /etc/X11/xorg.conf.d/, setting "Virtual" to the screen resolution that you need.  (Be sure that it is appropriate for your monitor.)  This is a better solution than xrandr, since it allows the display manager to get the specified resolution as well.  (I have tried lxdm, lightdm, and sddm and they all work.)

Section "Screen"                                                                
        Identifier "Screen0"                                                    
        SubSection "Display"                                                    
                   Virtual 1600 900                                             
        EndSubSection                                                           
EndSection 

Last edited by djraymondnm (2018-05-20 21:08:16)

Offline

#32 2018-05-21 13:03:10

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 65
Website

Re: Updating to xorg-server-1.20 breaks sddm-0.17

I have also the nvidia graphic card. I use xf86-video-nouvea and xfce4.
Installing xfwm4-git from AUR solved my problem.
Maybe recompiling xfwm would be enough. I have not tried it.

Offline

#33 2018-05-21 16:21:42

Sauron
Member
Registered: 2016-03-17
Posts: 8

Re: Updating to xorg-server-1.20 breaks sddm-0.17

Good to know it was xorg that broke my system, I already fixed the problem but I had to downgrade both xorg-server and xf86-video-intel, so I wasn't sure which actually caused the problem. I was getting this error:

[drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out

and others along those lines, hopefully if someone googles that error they can find this thread.


M-x butterfly

Offline

#34 2018-05-21 16:43:33

loqs
Member
Registered: 2014-03-06
Posts: 4,548

Re: Updating to xorg-server-1.20 breaks sddm-0.17

[drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out

Is from the i915 kernel module and is probably unrelated to X not starting with the recent package upgrades.

Offline

#35 Yesterday 19:03:54

sergi34
Member
Registered: 2010-01-20
Posts: 24

Re: Updating to xorg-server-1.20 breaks sddm-0.17

Exactly same problem here. I've spend all the afternoon trying to solve the problem for myself but didn't find the way. Normally problems when upgrading arch linux are just easy and just a query on the forum does the trick.

This time was tricky. Nothing on the forums,  Segmentation fault on Xorg. I'm using xfce4 and startxfce4 did'nt start. But for user root everything was fine and could start xfce

Seems to be related somewhat with permissions with non root user. downgrading xorg to 1.19 and also nouveau and vesa solved the problem. My kernel is now 4.16.11-1

I will wait to upgrade to xorg-1.20 if the problem is not yet solved

thanks

Offline

#36 Yesterday 19:11:30

giannis-arch
Member
Registered: 2017-09-20
Posts: 2

Re: Updating to xorg-server-1.20 breaks sddm-0.17

Offline

Board footer

Powered by FluxBB