You are not logged in.

#26 2018-05-24 05:29:25

blablo
Member
Registered: 2011-06-02
Posts: 35

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Examples
xorg-server 1.20.0 autotools

$  ldd libfbdevhw.so
	linux-vdso.so.1 (0x00007ffcbffb9000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f48ad0df000)
	/usr/lib64/ld-linux-x86-64.so.2 (0x00007f48ad6a0000)

xorg-server 1.20.0 meson

 
$  ldd libfbdevhw.so
	linux-vdso.so.1 (0x00007fffa799a000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f2c87ac7000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f2c878a9000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f2c874ed000)
	/usr/lib64/ld-linux-x86-64.so.2 (0x00007f2c88061000)

xorg-server 1.20.0 autotools

$   ldd libshadow.so
	linux-vdso.so.1 (0x00007ffea55eb000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f3094055000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f3093e37000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f3093a7b000)
	/usr/lib64/ld-linux-x86-64.so.2 (0x00007f30945f5000)

xorg-server 1.20.0 meson

$   ldd libshadow.so
	linux-vdso.so.1 (0x00007fff71dd5000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f667bf18000)
	/usr/lib64/ld-linux-x86-64.so.2 (0x00007f667c4dd000)
	libfb.so => not found

xorg-server 1.20.0 autotools

$ ldd libglamoregl.so
	linux-vdso.so.1 (0x00007ffd8277b000)
	libgbm.so.1 => /usr/lib/libgbm.so.1 (0x00007f72f78e0000)
	libepoxy.so.0 => /usr/lib/libepoxy.so.0 (0x00007f72f75b3000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f72f721e000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f72f7000000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f72f6c44000)
	libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007f72f6a32000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f72f682e000)
	libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f72f65fc000)
	/usr/lib64/ld-linux-x86-64.so.2 (0x00007f72f7d1f000)

xorg-server 1.20.0 meson

 
$  ldd libglamoregl.so
	linux-vdso.so.1 (0x00007ffc075fe000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f798d477000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f798d1cf000)
	libXfont2.so.2 => /usr/lib/libXfont2.so.2 (0x00007f798cf96000)
	libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007f798cd84000)
	libgbm.so.1 => /usr/lib/libgbm.so.1 (0x00007f798cb77000)
	libepoxy.so.0 => /usr/lib/libepoxy.so.0 (0x00007f798c84a000)
	/usr/lib64/ld-linux-x86-64.so.2 (0x00007f798da66000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f798c4b5000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f798c297000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007f798c080000)
	libfontenc.so.1 => /usr/lib/libfontenc.so.1 (0x00007f798be78000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f798bbaf000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f798b9ab000)
	libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f798b779000)
	libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f798b569000)
	libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f798b336000)
	libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f798b084000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f798ad6d000)
	libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f798ab41000)
	libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f798a8cf000)

Xorg.wrap - autotools

-rwxr-xr-x root/root   2453392 2018-05-23 22:41 usr/lib/Xorg
-rwxr-xr-x root/root     10152 2018-05-23 22:41 usr/lib/Xorg.wrap

xorg-server-1.20.0-1-x86_64-build.log

make[6]: Entering directory '/build/xorg-server/src/xorg-server-1.20.0/hw/xfree86'
(cd /build/xorg-server/src/fakeinstall/usr/bin && rm -f X && ln -s Xorg X)
/usr/bin/mkdir -p /build/xorg-server/src/fakeinstall/usr/lib
mv /build/xorg-server/src/fakeinstall/usr/bin/Xorg /build/xorg-server/src/fakeinstall/usr/lib/Xorg
/usr/bin/install -c -m 755 Xorg.sh /build/xorg-server/src/fakeinstall/usr/bin/Xorg
chown root /build/xorg-server/src/fakeinstall/usr/lib/Xorg.wrap && chmod u+s /build/xorg-server/src/fakeinstall/usr/lib/Xorg.wrap
chown: changing ownership of '/build/xorg-server/src/fakeinstall/usr/lib/Xorg.wrap': Operation not permitted
make[6]: [Makefile:1158: install-exec-hook] Error 1 (ignored)

Xorg.wrap - meson

-rwxr-xr-x root/root   2285608 2018-05-21 19:41 usr/lib/Xorg
-rwsr-xr-x root/root     10400 2018-05-21 19:41 usr/lib/Xorg.wrap

https://gist.github.com/fafryd1125/8a80 … cf96d4396a

Offline

#27 2018-05-24 08:33:51

regid
Member
Registered: 2016-06-06
Posts: 141

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

seth wrote:

You could try to install another version (in doubt just the one from the repos) and symlink libfb.so into /usr/lib.
As you can see, it's not linked in your working build, so there's a rather good chance that this is the cause of the failure.

Eewww... SIS :-(
The version in AUR will not even install (requires a server even < 1.19) so xf86-video-vesa is probably indeed the only usable driver (but idk for real), so we'll need to focus on that.

Won't installing xf86-video-fbdev should give me what you are looking for? In that case, will I be able to choose fb or vesa, perhaps by a configuration file? What are the advantages, and disadvantages, of each, compared to the other?


powerofforreboot.efi (AUR): Utilities to be used from within a UEFI boot manager or shell.

Offline

#28 2018-05-24 11:36:38

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Idk anything about the SiS condition :-(
You'll have to just try (and yes, adding a device section selecting the "Driver" will allow you to select them)
The fb driver probably allows you to use non-VESA resolutions (ie. some 16:9 display or so)

However, for the moment I suggest to avoid a moving target and focus on the VESA condition, also because this seems to be a bug that should be addressed.

Offline

#29 2018-05-24 12:37:07

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,379

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Eewww... SIS :-(
The version in AUR will not even install (requires a server even < 1.19)

Actually that package is out of date, 0.10.9 was released on 2017-01-17 .
The last ABI change in xorg-server was in dec 2016, when 1.19.0 was released.

I'd say there's a big chance xf86-video-sis 0.10.9 is compatible with 1.19 + and 1.20+ .

Regid, are you willing/interested  to test a new xf86-video-sis ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#30 2018-05-24 21:41:46

regid
Member
Registered: 2016-06-06
Posts: 141

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Lone_Wolf@comment #29: I would like the SiS driver to be up to date. But. Do you mean building from AUR and configuring? I never did that for the SiS driver. If it won't work I might have hard time deciding if that is a bug or a configuration issue. As I wrote in comment #3, I hardly have time for the VESA driver. Don't count on me for the SiS driver. Though, once again, I would like the SiS driver to be up to date.

Last edited by regid (2018-05-24 21:42:30)


powerofforreboot.efi (AUR): Utilities to be used from within a UEFI boot manager or shell.

Offline

#31 2018-05-25 07:40:16

regid
Member
Registered: 2016-06-06
Posts: 141

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

I got lost. Here is the difference between the working for me 1.20.0-1 PKGBUILD with autotools/make, and the current 1.20.0-4 PKGBUILD meson/ninja version.

diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD
index 6b72b8e..16f23a3 100644
--- a/trunk/PKGBUILD
+++ b/trunk/PKGBUILD
@@ -3,26 +3,25 @@
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 
 pkgbase=xorg-server
-pkgname=('xorg-server' 'xorg-server-xephyr' 'xorg-server-xdmx' 'xorg-server-xvfb' 'xorg-server-xnest' 'xorg-server-xwayland' 'xorg-server-common' 'xorg-server-devel')
+pkgname=('xorg-server' 'xorg-server-xephyr' 'xorg-server-xdmx' 'xorg-server-xvfb' 'xorg-server-xnest'
+         'xorg-server-xwayland' 'xorg-server-common' 'xorg-server-devel')
 pkgver=1.20.0
-pkgrel=1
+pkgrel=4
 arch=('x86_64')
 license=('custom')
 groups=('xorg')
 url="http://xorg.freedesktop.org"
-makedepends=('pixman' 'libx11' 'mesa' 'mesa-libgl' 'xf86driproto' 'xcmiscproto' 'xtrans' 'bigreqsproto' 'randrproto' 
-             'inputproto' 'fontsproto' 'videoproto' 'presentproto' 'compositeproto' 'recordproto' 'scrnsaverproto'
-             'resourceproto' 'xineramaproto' 'libxkbfile' 'libxfont2' 'renderproto' 'libpciaccess' 'libxv'
-             'xf86dgaproto' 'libxmu' 'libxrender' 'libxi' 'dmxproto' 'libxaw' 'libdmx' 'libxtst' 'libxres'
-             'xorg-xkbcomp' 'xorg-util-macros' 'xorg-font-util' 'glproto' 'dri2proto' 'libgcrypt' 'libepoxy'
-             'xcb-util' 'xcb-util-image' 'xcb-util-renderutil' 'xcb-util-wm' 'xcb-util-keysyms' 'dri3proto'
-             'libxshmfence' 'libunwind' 'systemd' 'wayland-protocols') # 'meson') # ''git')
-#_commit=d0d1a694f967af770fba0d36043fd5218ff20984 # branch 1.19
-
-#source=("git+https://anongit.freedesktop.org/git/xorg/xserver.git#commit=$_commit"
+makedepends=('xorgproto' 'pixman' 'libx11' 'mesa' 'mesa-libgl' 'xtrans'
+             'libxkbfile' 'libxfont2' 'libpciaccess' 'libxv'
+             'libxmu' 'libxrender' 'libxi' 'libxaw' 'libdmx' 'libxtst' 'libxres'
+             'xorg-xkbcomp' 'xorg-util-macros' 'xorg-font-util' 'libepoxy'
+             'xcb-util' 'xcb-util-image' 'xcb-util-renderutil' 'xcb-util-wm' 'xcb-util-keysyms'
+             'libxshmfence' 'libunwind' 'systemd' 'wayland-protocols' 'egl-wayland' 'meson') # 'git')
 source=(https://xorg.freedesktop.org/releases/individual/xserver/${pkgbase}-${pkgver}.tar.bz2{,.sig}
+        'xwayland-config.h.meson.in::https://cgit.freedesktop.org/xorg/xserver/plain/include/xwayland-config.h.meson.in?id=xorg-server-1.20.0'
         xserver-autobind-hotplug.patch
-        xvfb-run
+        0001-v2-FS-58644.patch
+        xvfb-run # with updates from FC master
         xvfb-run.1)
 validpgpkeys=('7B27A3F1A6E18CD9588B4AE8310180050905E40C'
               'C383B778255613DFDB409D91DB221A6900000011'
@@ -30,23 +29,24 @@ validpgpkeys=('7B27A3F1A6E18CD9588B4AE8310180050905E40C'
               '995ED5C8A6138EB0961F18474C09DD83CAAA50B2')
 sha512sums=('1489e8511c9da682ef0460182dfeeddd241c72d4ef4d206d9706f1e39572c09953df851fab18cefb65a1ee4c6710c6ba13c63c9c9fc0bc1b5f12c50780412cde'
             'SKIP'
+            'd707e0870367de2665c3b82f09564d17ed3f62c9e8b4bd471c11af1fb1e9249e306e92c7961a04e355756eec9f5271bc8e66999e56c73c31bc9da4127ff30a8e'
             'd84f4d63a502b7af76ea49944d1b21e2030dfd250ac1e82878935cf631973310ac9ba1f0dfedf10980ec6c7431d61b7daa4b7bbaae9ee477b2c19812c1661a22'
-            'ca1cda27016f7c269cbdecc45da36255afeef5c1973cc484544f9dfbf56ed1868365c93a4c7f93e3a23e5322f084ec0cdd137e15b43872aae7f0c03040028ce6'
+            '74e1aa0c101e42f0f25349d305641873b3a79ab3b9bb2d4ed68ba8e392b4db2701fcbc35826531ee2667d3ee55673e4b4fecc2a9f088141af29ceb400f72f363'
+            '55bbf520333f6e818b0125b37179a7039b69a0d3d2242b80a08da003d94cbf6c1fb912d880abcce318a85d7947e3eff8fbc4cdf57d7118572e8ebc56c4569af6'
             'de5e2cb3c6825e6cf1f07ca0d52423e17f34d70ec7935e9dd24be5fb9883bf1e03b50ff584931bd3b41095c510ab2aa44d2573fd5feaebdcb59363b65607ff22')
 
-#pkgver() {
-#  cd xserver
-#  git describe --tags | sed 's/^xorg-server-//;s/_/./g;s/-/+/g'
-#}
-
 prepare() {
-  #cd xserver
+  # missing from tarball
+  cp xwayland-config.h.meson.in ${pkgbase}-${pkgver}/include/
+
   cd "${pkgbase}-${pkgver}"
 
   # patch from Fedora, not yet merged
   patch -Np1 -i ../xserver-autobind-hotplug.patch
 
-  autoreconf -vfi
+  # Fix rootless xorg - FS#58644
+  # https://bugs.freedesktop.org/show_bug.cgi?id=106588
+  patch -Np1 -i ../0001-v2-FS-58644.patch
 }
 
 build() {
@@ -57,82 +57,58 @@ build() {
   export CXXFLAGS=${CXXFLAGS/-fno-plt}
   export LDFLAGS=${LDFLAGS/,-z,now}
 
-  #cd xserver
-  cd "${pkgbase}-${pkgver}"
-
-#   arch-meson mesa-$pkgver build --help \
-#     -D enable-ipv6=true
-
-  ./configure --prefix=/usr \
-      --enable-ipv6 \
-      --enable-dri \
-      --enable-dmx \
-      --enable-xvfb \
-      --enable-xnest \
-      --enable-composite \
-      --enable-xcsecurity \
-      --enable-libunwind \
-      --enable-xorg \
-      --enable-xephyr \
-      --enable-glamor \
-      --enable-xwayland \
-      --enable-kdrive \
-      --enable-kdrive-kbd \
-      --enable-kdrive-mouse \
-      --enable-config-udev \
-      --enable-systemd-logind \
-      --enable-suid-wrapper \
-      --disable-install-setuid \
-      --enable-record \
-      --disable-xfbdev \
-      --disable-xfake \
-      --disable-static \
-      --libexecdir=/usr/lib/xorg-server \
-      --sysconfdir=/etc \
-      --localstatedir=/var \
-      --with-xkb-path=/usr/share/X11/xkb \
-      --with-xkb-output=/var/lib/xkb \
-      --with-fontrootdir=/usr/share/fonts \
-      --with-sha1=libgcrypt
-
-  make
+  arch-meson ${pkgbase}-$pkgver build \
+    -D os_vendor="Arch Linux" \
+    -D ipv6=true \
+    -D dmx=true \
+    -D xvfb=true \
+    -D xnest=true \
+    -D xcsecurity=true \
+    -D xorg=true \
+    -D xephyr=true \
+    -D xwayland=true \
+    -D xwayland_eglstream=true \
+    -D glamor=true \
+    -D udev=true \
+    -D systemd_logind=true \
+    -D suid_wrapper=true \
+    -D xkb_dir=/usr/share/X11/xkb \
+    -D xkb_output_dir=/var/lib/xkb
 
   # Print config
-#  meson configure build
-
-#  ninja -C build
+  meson configure build
+  ninja -C build
 
+  # fake installation to be seperated into packages
+  DESTDIR="${srcdir}/fakeinstall" ninja -C build install
+}
 
-  # Disable subdirs for make install rule to make splitting easier
-  sed -e 's/^DMX_SUBDIRS =.*/DMX_SUBDIRS =/' \
-      -e 's/^XVFB_SUBDIRS =.*/XVFB_SUBDIRS =/' \
-      -e 's/^XNEST_SUBDIRS =.*/XNEST_SUBDIRS = /' \
-      -e 's/^KDRIVE_SUBDIRS =.*/KDRIVE_SUBDIRS =/' \
-      -e 's/^XWAYLAND_SUBDIRS =.*/XWAYLAND_SUBDIRS =/' \
-      -i hw/Makefile
+_install() {
+  local src f dir
+  for src; do
+    f="${src#fakeinstall/}"
+    dir="${pkgdir}/${f%/*}"
+    install -m755 -d "${dir}"
+    mv -v "${src}" "${dir}/"
+  done
 }
 
 package_xorg-server-common() {
   pkgdesc="Xorg server common files"
   depends=(xkeyboard-config xorg-xkbcomp xorg-setxkbmap)
 
-  #cd xserver
-  cd "${pkgbase}-${pkgver}"
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-common"
-  install -m644 COPYING "${pkgdir}/usr/share/licenses/xorg-server-common"
-  
-  make -C xkb DESTDIR="${pkgdir}" install-data
-
-  install -m755 -d "${pkgdir}/usr/share/man/man1"
-  install -m644 man/Xserver.1 "${pkgdir}/usr/share/man/man1/"
+  _install fakeinstall/usr/lib/xorg/protocol.txt
+  _install fakeinstall/usr/share/man/man1/Xserver.1.gz
 
-  install -m755 -d "${pkgdir}/usr/lib/xorg"
-  install -m644 dix/protocol.txt "${pkgdir}/usr/lib/xorg/"
+  install -m644 -Dt "${pkgdir}/var/lib/xkb/" "${pkgbase}-${pkgver}"/xkb/README.compiled
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server() {
   pkgdesc="Xorg X server"
-  depends=(libepoxy libxfont2 pixman xorg-server-common libunwind dbus libgl xf86-input-libinput
+  depends=(libepoxy libxfont2 pixman xorg-server-common libunwind
+           dbus libgl xf86-input-libinput nettle
            libpciaccess libdrm libxshmfence) # FS#52949
 
   # see xorg-server-*/hw/xfree86/common/xf86Module.h for ABI versions - we provide major numbers that drivers can depend on
@@ -142,112 +118,96 @@ package_xorg-server() {
   replaces=('glamor-egl' 'xf86-video-modesetting')
   install=xorg-server.install
 
-  #cd xserver
-  cd "${pkgbase}-${pkgver}"
-  make DESTDIR="${pkgdir}" install
-  
+  _install fakeinstall/usr/bin/{Xorg,cvt,gtf}
+  ln -s /usr/bin/Xorg "${pkgdir}/usr/bin/X"
+  _install fakeinstall/usr/lib/Xorg{,.wrap}
+  _install fakeinstall/usr/lib/xorg/modules/*
+  _install fakeinstall/usr/share/X11/xorg.conf.d/10-quirks.conf
+  _install fakeinstall/usr/share/man/man1/{Xorg,Xorg.wrap,cvt,gtf}.1.gz
+  _install fakeinstall/usr/share/man/man4/{exa,fbdevhw,modesetting}.4.gz
+  _install fakeinstall/usr/share/man/man5/{Xwrapper.config,xorg.conf,xorg.conf.d}.5.gz
+
   # distro specific files must be installed in /usr/share/X11/xorg.conf.d
   install -m755 -d "${pkgdir}/etc/X11/xorg.conf.d"
-  
-  rm -rf "${pkgdir}/var"
-
-  rm -f "${pkgdir}/usr/share/man/man1/Xserver.1"
-  rm -f "${pkgdir}/usr/lib/xorg/protocol.txt"
-
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server/COPYING"
 
-  rm -rf "${pkgdir}/usr/lib/pkgconfig"
-  rm -rf "${pkgdir}/usr/include"
-  rm -rf "${pkgdir}/usr/share/aclocal"
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server-xephyr() {
   pkgdesc="A nested X server that runs as an X application"
-  depends=(libxfont2 libgl libepoxy libunwind libsystemd libxv pixman xorg-server-common xcb-util-image
-           xcb-util-renderutil xcb-util-wm xcb-util-keysyms)
+  depends=(libxfont2 libgl libepoxy libunwind libsystemd libxv pixman xorg-server-common
+           xcb-util-image xcb-util-renderutil xcb-util-wm xcb-util-keysyms
+           nettle libtirpc)
 
-  #cd xserver/hw/kdrive
-  cd "${pkgbase}-${pkgver}/hw/kdrive"
-  make DESTDIR="${pkgdir}" install
+  _install fakeinstall/usr/bin/Xephyr
+  _install fakeinstall/usr/share/man/man1/Xephyr.1.gz
 
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-xephyr"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server-xephyr/COPYING"
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server-xvfb() {
   pkgdesc="Virtual framebuffer X server"
-  depends=(libxfont2 libunwind libsystemd pixman xorg-server-common xorg-xauth libgl which)
+  depends=(libxfont2 libunwind pixman xorg-server-common xorg-xauth libgl nettle)
 
-  #cd xserver/hw/vfb
-  cd "${pkgbase}-${pkgver}/hw/vfb"
-  make DESTDIR="${pkgdir}" install
+  _install fakeinstall/usr/bin/Xvfb
+  _install fakeinstall/usr/share/man/man1/Xvfb.1.gz
 
   install -m755 "${srcdir}/xvfb-run" "${pkgdir}/usr/bin/"
-  install -m644 "${srcdir}/xvfb-run.1" "${pkgdir}/usr/share/man/man1/"
+  install -m644 "${srcdir}/xvfb-run.1" "${pkgdir}/usr/share/man/man1/" # outda
 
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-xvfb"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server-xvfb/COPYING"
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server-xnest() {
   pkgdesc="A nested X server that runs as an X application"
-  depends=(libxfont2 libxext libunwind pixman xorg-server-common libsystemd)
+  depends=(libxfont2 libxext pixman xorg-server-common nettle libtirpc)
 
-  #cd xserver/hw/xnest
-  cd "${pkgbase}-${pkgver}/hw/xnest"
-  make DESTDIR="${pkgdir}" install
+  _install fakeinstall/usr/bin/Xnest
+  _install fakeinstall/usr/share/man/man1/Xnest.1.gz
 
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-xnest"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server-xnest/COPYING"
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server-xdmx() {
   pkgdesc="Distributed Multihead X Server and utilities"
-  depends=(libxfont2 libxi libxaw libxrender libdmx libxfixes libunwind pixman xorg-server-common)
+  depends=(libxfont2 libxi libxaw libxrender libdmx libxfixes
+           pixman xorg-server-common nettle)
 
-  #cd xserver/hw/dmx
-  cd "${pkgbase}-${pkgver}/hw/dmx"
-  make DESTDIR="${pkgdir}" install
+  _install fakeinstall/usr/bin/{Xdmx,dmx*,vdltodmx,xdmxconfig}
+  _install fakeinstall/usr/share/man/man1/{Xdmx,dmxtodmx,vdltodmx,xdmxconfig}.1.gz
 
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-xdmx"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server-xdmx/COPYING"
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server-xwayland() {
   pkgdesc="run X clients under wayland"
-  depends=(libxfont2 libepoxy libunwind libsystemd libgl pixman xorg-server-common)
+  depends=(libxfont2 libepoxy libunwind libsystemd libgl pixman xorg-server-common
+           nettle libtirpc)
 
-  #cd xserver/hw/xwayland
-  cd "${pkgbase}-${pkgver}/hw/xwayland"
-  make DESTDIR="${pkgdir}" install
+  _install fakeinstall/usr/bin/Xwayland
 
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-xwayland"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server-xwayland/COPYING"
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
 }
 
 package_xorg-server-devel() {
   pkgdesc="Development files for the X.Org X server"
-  depends=(# see pkgdir/usr/lib/pkgconfig/xorg-server.pc
-           xproto randrproto renderproto xextproto inputproto kbproto 
-           fontsproto pixman videoproto xf86driproto glproto 
-           mesa dri2proto dri3proto xineramaproto libpciaccess
-           resourceproto scrnsaverproto presentproto
+  depends=('xorgproto' 'mesa' 'libpciaccess'
            # not technically required but almost every Xorg pkg needs it to build
-           xorg-util-macros)
+           'xorg-util-macros')
 
-  #cd xserver
-  cd "${pkgbase}-${pkgver}"
-  make DESTDIR="${pkgdir}" install
-
-  rm -rf "${pkgdir}/usr/bin"
-  rm -rf "${pkgdir}/usr/share/man"
-  rm -rf "${pkgdir}/usr/share/doc"
-  rm -rf "${pkgdir}/usr/share/X11"
-  rm -rf "${pkgdir}/usr/lib/xorg"
-  rm -rf "${pkgdir}/usr/lib/xorg-server"
-  rm -rf "${pkgdir}/var"
-
-  install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server-devel"
-  ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server-devel/COPYING"
+  _install fakeinstall/usr/include/xorg/*
+  _install fakeinstall/usr/lib/pkgconfig/xorg-server.pc
+  _install fakeinstall/usr/share/aclocal/xorg-server.m4
+
+  # license
+  install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgbase}-${pkgver}"/COPYING
+
+  # make sure there are no files left to install
+  find fakeinstall -depth -print0 | xargs -0 rmdir
 }

How should I continue, and what else should I patch, if at all?

Last edited by regid (2018-05-25 07:43:24)


powerofforreboot.efi (AUR): Utilities to be used from within a UEFI boot manager or shell.

Offline

#32 2018-05-25 19:34:31

blablo
Member
Registered: 2011-06-02
Posts: 35

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Offline

#33 2018-05-25 20:28:58

loqs
Member
Registered: 2014-03-06
Posts: 9,078

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

@blablo can you please take a look at https://bugs.archlinux.org/task/58662 thanks.

Offline

#34 2018-05-26 21:13:03

loqs
Member
Registered: 2014-03-06
Posts: 9,078

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Offline

#35 2018-05-28 22:27:51

regid
Member
Registered: 2016-06-06
Posts: 141

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

My current kernel is

4.16.11-1-ARCH #1 SMP PREEMPT Tue May 22 21:40:27 UTC 2018 x86_64 GNU/Linux

Since the possible kernel patch mentioned by loqs@message #34 is from May 25, I am not sure how this possible kernel issue affect my int10 problem with xorg-server 1.20.0-2.


powerofforreboot.efi (AUR): Utilities to be used from within a UEFI boot manager or shell.

Offline

#36 2018-05-29 06:36:32

tobek
Member
Registered: 2018-05-29
Posts: 4

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

regid wrote:

My solution was to downgrade to the previous versions I have, namely

  • xorg-server 1.19.6+13+gd0d1a694f-2

  • xorg-server-common 1.19.6+13+gd0d1a694f-2

  • libinput 1.10.6-1

  • xf86-video-vesa 2.4.0-1

FWIW for those looking for a quick workaround, I also ran into this issue (in particular, I was unable to scale an external display - depending on settings it either remained unscaled but mispositioned, was totally blank, and/or my main display would start flickering). However I don't use xf86-video-vesa, I have xf86-video-fbdev, so I had to downgrade that instead (to 0.4.4+12+ge0bce0d-1). I'd recommend downgrade (AUR package) for newbies.

Offline

#37 2018-06-02 01:14:58

regid
Member
Registered: 2016-06-06
Posts: 141

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Official arch xorg-server{,-common}-1.20.0-5 failed to run. Applying 0001-fix-libshadow.patch from upstream Bug 106656 made it run.
It still reports

(WW) Failed to open protocol names file lib/xorg/protocol.txt

, even though /usr/lib/xorg/protocol.txt is there and looks to me to have reasonable content.
Log file is at /var/log/, in spite of xinit run by a non priviledged user.
Lone_Wolf@comment #29: Does the offer to test xf86-video-sis still open? If provided a PKGBUILD I will try to run it by following https://wiki.archlinux.org/index.php/SiS.

Last edited by regid (2018-06-02 01:20:52)


powerofforreboot.efi (AUR): Utilities to be used from within a UEFI boot manager or shell.

Offline

#38 2018-06-02 11:55:05

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,379

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

I looked into it, but contrary to what i thought xorg-server 1.20 did have an ABI change.

xorg-server 1.19.x :

'X-ABI-VIDEODRV_VERSION=23'
'X-ABI-XINPUT_VERSION=24.1'
'X-ABI-EXTENSION_VERSION=10.0'

xorg-server 1.20.x :

'X-ABI-VIDEODRV_VERSION=24.0'
'X-ABI-XINPUT_VERSION=24.1'
'X-ABI-EXTENSION_VERSION=10.0'

An increase in X-ABI-VIDEODRV_VERSION results in xf86-video-* needing sourcecode changes.
I tried building 0.10.9 against 1.20, but got errrors I barely understand and can't solve.
We'd need help from a coder with xorg experience.

You could try asking on xorg devel mailing list whether xf86-video-sis will be updated to work with xorg-server 1.20.x  .
I've been following that list a while now (just lurking) and the atmosphere seems friendly and open for discussion.

Last edited by Lone_Wolf (2018-06-02 11:55:47)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#39 2018-06-02 17:55:07

regid
Member
Registered: 2016-06-06
Posts: 141

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

Last edited by regid (2018-06-02 18:11:27)


powerofforreboot.efi (AUR): Utilities to be used from within a UEFI boot manager or shell.

Offline

#40 2018-06-03 11:08:14

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,379

Re: xorg-server{,-common} 1.20.0-1 work but not -2, with VESA 2.4.0-2

I have opened a discussion at the AUR forum regarding xf86-video-sis. Were it better if I didn't?

No, that's fine, i'm glad loqs is helping.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB