You are not logged in.

#1 2018-05-30 23:14:13

hpmachining
Member
From: Michigan
Registered: 2016-11-23
Posts: 40
Website

[SOLVED] Can't build packages in clean chroot after upgrading.

This may be related to this bug report. I can't build anything in a clean chroot with the latest updates.

$ makechrootpkg -cr $CHROOT 
==> Synchronizing chroot copy [/home/paul/chroot/root] -> [paul]...done
chmod: changing permissions of '/tmp/tmp.gkVoou8OFS': Operation not permitted

==> ERROR: An unknown error has occurred. Exiting...

==> ERROR: An unknown error has occurred. Exiting...
/usr/bin/makechrootpkg: line 500: 12498 User defined signal 1   sudo -u "$makepkg_user" env SRCDEST="$SRCDEST" BUILDDIR="$builddir" makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o
==> ERROR: Could not download sources.

I only have the problem in clean chroot. If I roll back my packages to 2018/05/28 everything works. Also, if I roll back my system but leave the chroot updated, it will work. If I go from 2018/05/28 to 2018/05/29, I will get the error. Here are the packages that were upgraded between 05/28 and 05/29:

Packages (12) appstream-glib-0.7.7-2  ffmpeg-1:4.0-3  fftw-3.3.8-1  gst-plugins-bad-1.14.1-2  lib32-libdrm-2.4.92-1
              libpackagekit-glib-1.1.10-2  nm-connection-editor-1.8.12-1  pacman-5.1.0-1  pyalpm-0.8.3-1  vlc-3.0.2-2
              volume_key-0.3.10-1  x265-2.8-1

Any suggestions?

Last edited by hpmachining (2018-05-30 23:34:38)

Offline

#2 2018-05-30 23:16:08

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,414
Website

Re: [SOLVED] Can't build packages in clean chroot after upgrading.


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#3 2018-05-30 23:33:40

hpmachining
Member
From: Michigan
Registered: 2016-11-23
Posts: 40
Website

Re: [SOLVED] Can't build packages in clean chroot after upgrading.

Thank you. Installing devtools 20180528-1 fixed it.

Last edited by hpmachining (2018-05-30 23:35:52)

Offline

#4 2018-06-02 22:30:11

hpmachining
Member
From: Michigan
Registered: 2016-11-23
Posts: 40
Website

Re: [SOLVED] Can't build packages in clean chroot after upgrading.

I am having a problem building v8 from the AUR in a clean chroot. I am thinking it might be related to this issue. It builds in my host environment but I get the following error in clean chroot.

  -> Using system libraries for ICU
  -> Running GN...
Done. Made 127 targets from 80 files in 74ms
rm: cannot remove '/logdest/logpipe.hzkeTAtZ': No such file or directory
==> ERROR: A failure occurred in prepare().
    Aborting...
==> ERROR: Build failed, check /home/paul/chroot/paul/build

Do you think this is an issue with devtools or the v8 package, or something in my setup?

Last edited by hpmachining (2018-06-02 22:31:10)

Offline

Board footer

Powered by FluxBB