You are not logged in.

#26 2006-07-17 20:44:46

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: [forums] We interupt this programme...

...or override the default style with a stylesheet particular to this page. Subsequent styles override earlier ones.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#27 2006-07-17 20:53:59

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: [forums] We interupt this programme...

That could be a bit beyond me...I have made some serious usability fixes for now though!

Offline

#28 2006-07-17 20:58:40

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: [forums] We interupt this programme...

OK- the new theme tarball is up.  It's worth noting that the problem with glance (the syndicated announcements on the index page) row size MUST be from a CSS change as the glance.php files have not been edited at all.

Go for it guys!  Looking forward to seeing your work!

If someone can do what Cactus says and reorder the CSSs then it should fix it, I think, as the original CSS has not been changed at all except for in colour...so the problems are being inherited from tehAerch CSS.  Hope that makes sense.

Offline

#29 2006-07-17 21:27:38

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

To fix the super-tall rows, look for the line:

<table width="100%" cellpadding="4" cellspacing="1" border="0" class="forumline" height="100%">

And simply remove " height="100%"", in here:

<span><br></span>
<table width="100%" cellpadding="4" cellspacing="1" border="0" class="forumline" height="100%">
    <tr>
        <th class="thCornerL" height="25" align="center" nowrap="nowrap" width="30">& nbsp;
    < ! --    <span> -- > ETC.
         </span> -->
        </th>

        <th class="thTop" height="25" align="left">
                Latest Announcements and Advisories
        </th>
        < !-- <th class="thTop" width="100" align="center" nowrap="nowrap">& nbsp;Forum& nbsp;</th>-->
        <th class="thTop" width="100" align="center" nowrap="nowrap">& nbsp;Author& nbsp;</th>
        < !-- <th class="thTop" width="50" align="center" nowrap="nowrap">& nbsp;Replies& nbsp;</th>-->
        <th class="thCornerR" align="center" nowrap="nowrap">& nbsp;Last Post& nbsp;</th>
    </tr>

[edit] Geeez!  How does one submit HTML examples?!

:shock:

Offline

#30 2006-07-17 21:48:58

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: [forums] We interupt this programme...

cactus wrote:

...or override the default style with a stylesheet particular to this page. Subsequent styles override earlier ones.

... pwnt.  You are so correct.   :oops:

Offline

#31 2006-07-17 22:43:12

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [forums] We interupt this programme...

On a forum listing of the threads like here: http://bbs.archlinux.org/viewforum.php?f=24
would it be possible to have the:

Users browsing this forum: None    
Post new topic    Moderate this forum        Forum Index -> Announcements, Package and Security Advisories

left-justified instead of centered?

PS. I'm using Adblock so I don't know where the google ads
are placed.

Offline

#32 2006-07-17 22:50:00

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [forums] We interupt this programme...

Also, in memberlist, the "Select sort method" line is off-sided to the right.

Offline

#33 2006-07-17 23:09:13

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: [forums] We interupt this programme...

soloport wrote:

To fix the super-tall rows, look for the line:

<table width="100%" cellpadding="4" cellspacing="1" border="0" class="forumline" height="100%">

In the source, I see the line appearing as follows. Only one line with both forumline and height="100%" in it.

<table class="forumline" border="0" cellpadding="4" cellspacing="1" height="100%" width="100%">

Just make it read:

<table class="forumline" border="0" cellpadding="4" cellspacing="1" width="100%">

And that fixes it on a static snag of the page contents. Good eye soloport.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#34 2006-07-17 23:25:10

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

cactus wrote:

In the source, I see the line appearing as follows. Only one line with both forumline and height="100%" in it.

<table class="forumline" border="0" cellpadding="4" cellspacing="1" height="100%" width="100%">

Just make it read:

<table class="forumline" border="0" cellpadding="4" cellspacing="1" height="100%" width="100%">

Hmmmm...  Those look identical, to me.  (Hopefully the removing height="100%" did the trick?)

:?

[edit]  Also, you must be looking at your changes on a local copy -- the official forum hasn't changed, true?

:?:

Offline

#35 2006-07-17 23:58:23

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

In the CSS section:

/* Used for the navigation text, (Page 1,2,3 etc) and the navigation bar when in a forum */
.nav            { font-weight: bold; font-size: 11px; color : #000000;}
a.nav            { text-decoration: none; color : #35526F; }
a.nav:hover        { text-decoration: underline; }
h <==<TYPO<==<
/* titles for the topics: could specify viewed link colour too */
.topictitle,h1,h2    { font-weight: bold; font-size: 11px; color : #000000; }
a.topictitle:link   { text-decoration: none; color : #35526F; }
a.topictitle:visited { text-decoration: none; color : #35526F; }
a.topictitle:hover    { text-decoration: underline; color : #CEB4CB; }

Look for the lone 'h' on it's own line (a typo).  Don't know what effect this would have on things, nor why, but it does occur just prior to 'topictitle' class -- which is used for text that is currently having the "big font" problem (e.g. click "Arch Discussion" and see topics).

[edit] Confirmed: This fixes the big-font problem.

wink

Offline

#36 2006-07-18 00:37:13

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: [forums] We interupt this programme...

soloport wrote:

Hmmmm...  Those look identical, to me.  (Hopefully the removing height="100%" did the trick?)

doh. thanks soloport. fixed my fix.
o.O

[edit]  Also, you must be looking at your changes on a local copy -- the official forum hasn't changed, true?

Indeed. I just saved the site via firefox, and edited it locally..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#37 2006-07-18 00:44:30

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

Ok, so now I'm anxious!  Having found the two bugs that were bugging me the most (are there others?) all I can say is: Let's launch this puppy.

The new theme is very nice!  (Though currently somewhat annoying lol )

Offline

#38 2006-07-18 00:56:43

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [forums] We interupt this programme...

Another point: the "Mark all threads as read" button is no longer there in the new layout.

Offline

#39 2006-07-18 01:08:05

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

Snowman wrote:

Another point: the "Mark all threads as read" button is no longer there in the new layout.

Huh?  It's either at the bottom-left of page (forum home) or at the top-right of page (forum main topic).  Same location for both themes.  See it?

Offline

#40 2006-07-18 01:24:44

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [forums] We interupt this programme...

soloport wrote:
Snowman wrote:

Another point: the "Mark all threads as read" button is no longer there in the new layout.

Huh?  It's either at the bottom-left of page (forum home) or at the top-right of page (forum main topic).  Same location for both themes.  See it?

Yes, but I'm talking about the "Mark all topics read" button that is on each individual sections (on the old layout).

Offline

#41 2006-07-18 03:19:21

neotuli
Lazy Developer
From: San Francisco, CA
Registered: 2004-07-06
Posts: 1,201
Website

Re: [forums] We interupt this programme...

Patches! Patches! Patches! There's nothing that I know would delight dtw more than patches! (I know I'll be sending him at least one)


The suggestion box only accepts patches.

Offline

#42 2006-07-18 07:06:58

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: [forums] We interupt this programme...

Snowman: what browser are you using?  I am using firefox and it is fine but I know it is all fucked up in IE.

Apart from refining the new header (which i think neo is looking at) we only need to fix the compatibility problems and the spacing of...well, everything!

You may have noticed that the [code] and

areas in psts lost all their alignment and everything is hard left aligned.  Also look at the spacing between the smilies on the posting page.

Other changes made and commited.

Offline

#43 2006-07-18 07:36:44

Marco`
Member
From: Schoorl, The Netherlands
Registered: 2005-11-27
Posts: 47
Website

Re: [forums] We interupt this programme...

Can you please increase the margin/padding between the topiclist, this just hurts my eyes  :shock:


was known as 'Chestah'
Last.fm profile

Offline

#44 2006-07-18 13:05:00

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 785
Website

Re: [forums] We interupt this programme...

Where did the "Posts since last login" stuff go!

Other than that, excellent work so far.

Offline

#45 2006-07-18 13:57:28

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [forums] We interupt this programme...

dtw wrote:

Snowman: what browser are you using?  I am using firefox and it is fine but I know it is all fucked up in IE.

I'm using firefox too.

Offline

#46 2006-07-18 13:59:00

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: [forums] We interupt this programme...

Weird!  Did you say you were using adblock or something else that alters the page content?  Could others with display issues also post i fthey are using such extentions?  It displays perfectly on my system and is better much better in IE as of this AM.

Offline

#47 2006-07-18 14:36:08

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

Snowman wrote:

Yes, but I'm talking about the "Mark all topics read" button that is on each individual sections (on the old layout).

Sorry, snowman, I've checked and checked and "Mark all topics read" shows up in the same place for either theme, for me.

BTW: The new theme just keeps getting better.  In fact as far as I can tell it's at par, functionally, with the old theme.  Thanks go to whoever made all the recent fixes!

Offline

#48 2006-07-18 15:42:13

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [forums] We interupt this programme...

soloport wrote:
Snowman wrote:

Yes, but I'm talking about the "Mark all topics read" button that is on each individual sections (on the old layout).

Sorry, snowman, I've checked and checked and "Mark all topics read" shows up in the same place for either theme, for me.

I just realized that I have the "Mark all topics read" button. I just need to scroll horizontally.  roll The whole line is offset to the right.

Offline

#49 2006-07-18 16:07:11

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: [forums] We interupt this programme...

I expected that - do you have an adblocker?  It's the way the google ads are being displayed I think!

Offline

#50 2006-07-18 17:57:11

soloport
Member
Registered: 2005-03-01
Posts: 442

Re: [forums] We interupt this programme...

Another bug, explored...  First, go to this poll: Which was your distro before use Arch Linux?

Next, look for the missing width="100%", which causes the poll graphics to appear left-justified.  Here's the code snippet, with the width="100%" included:

  <td class="row2" colspan="2"><br>
    <table cellspacing="0" cellpadding="4" border="0" align="center" width="100%">
      <tr>
        <td colspan="4" align="center"><span><b>How many distros (Linux) have you used before Arch?</b></span></td>
      </tr>

[edit] To be clear: Adding width="100%" allows the table's align="center" to work properly.

Finally, the first and last rows contain a colspan="4", but not the row in which the poll resides.  In no case are there 4 colums, either (i.e. colspan="4" could be removed).  This doesn't cause the left-justify problem, but it's still sloppy. roll

Offline

Board footer

Powered by FluxBB