You are not logged in.

#1 2017-09-02 21:39:10

andyspiros
Member
Registered: 2015-03-10
Posts: 19

Bluetooth "off" after resuming from sleep

I have a ThinkPad X1 Carbon 4th generation.
The bluetooth works fine and I use it to steam music to my headphones, to connect to the phone and to use the mouse.

The problem is that most often, when I resume my laptop from sleep, I can't use it. The bluetooth device disappears, and `bluetoothctl` can't find it (it's not just powered off, it looks like it has been unplugged) and behaves as though no bluetooth controller is present. I have to suspend the laptop once more (or twice, or multiple times) until the bluetooth controller wakes up in good mood to start working again. Sometimes only a reboot helps.

More information:

  • Laptop: ThinkPad X1 Carbon 4th generation

  • Bluetooth controller 8087:0a2b (see code block below).

  • Kernel: Linux linus 4.12.8-2-ARCH #1 SMP PREEMPT Fri Aug 18 14:08:02 UTC 2017 x86_64 GNU/Linux

  • Bluez: version 5.46-1

Bus 001 Device 002: ID 8087:0a2b Intel Corp. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          224 Wireless
  bDeviceSubClass         1 Radio Frequency
  bDeviceProtocol         1 Bluetooth
  bMaxPacketSize0        64
  idVendor           0x8087 Intel Corp.
  idProduct          0x0a2b 
  bcdDevice            0.01

Offline

#2 2017-09-05 09:35:18

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,390

Re: Bluetooth "off" after resuming from sleep

This is a rather common problem with some devices and it is most likely a driver bug. You can google for yourself if a bug has been reported for this particular Bluetooth device. I could only suggest you try a few things. Try to find the modules operating your Bluetooth device (lspci -k or inxi) and do a modinfo on this module. Maybe disable power management or something like that will do the trick. You can also try to disable Bluetooth before sleep and re-enable it afterward though scripts. First, try to find a way to do it by hand with the required commands (try to use rfkill to disable it and remove the module before sleeping; reload the module and wake it up with rfkill after resuming). If you find something that works automate the task by reading the wiki.

Last edited by olive (2017-09-05 09:39:48)

Offline

#3 2018-06-07 18:01:14

leandroaveiro
Member
From: Rochester, NY, USA
Registered: 2007-04-12
Posts: 45

Re: Bluetooth "off" after resuming from sleep

Hi, my system is fully updated (June 2018) and I'm having the same problem. I have an HP Envy laptop.
Sometimes after resuming from a sleep, I noticed that I have to do:

rfkill unblock bluetooth

and then it works again. What makes a device being blocked automatically? I thought that once you unblocked, it was for good.

Sometimes, I have the exactly same issue where the adapter is simply gone. In that case I have to follow a tip from the Bluetooth wiki page and launch my Windows OS and then reboot back to Arch.
I think this may be related to BIOS. Because when it fails and I have to reboot to Windows, I notice that it's takes about 30 seconds to load the bootloader. It just sits there with a blank screen. When bluetooth is working nicely, the bootloader comes up very quickly.

I've tried pairing my devices with blueman, bluetoothctl and the Plasma Bluetooth applet. Same results.

I've read in some other distros about people scripting "rfkill block" and then "rfkill unblock" before and after sleeping to get rid of the problem.

Offline

#4 2018-06-07 21:16:46

judd1
Member
Registered: 2015-09-04
Posts: 106

Re: Bluetooth "off" after resuming from sleep

You can also help by turning off pulseaudio, re-igniting bluetooth and then running the pulseaudio daemon again:

pulseaudio -k
systemctl restart bluetooth.service
pulseaudio --start

At least It works for me.

Last edited by judd1 (2018-06-07 21:21:11)

Offline

Board footer

Powered by FluxBB